PDA

View Full Version : THD Stuck in Boot



major18
01-26-2010, 08:18 PM
Greetings, I was hoping someone could help me out.

I recently decided to activate a TIVO HD that I had lying around and ran into some problems. It had a160G drive (from the expanded THD unit I currently use) with a restored image and prior to putting it in the closet was booting to the Guided Set-Up (GSU) without difficulty. I activated the unit online and proceeded to boot it up. Took a few tries to get through the GSU, but eventually I did (Comcast, I hadn't yet received the MS cable card). I was trying to manually force a 'pending restart' in order to get the S/W up to date for MRV, and started getting consistent 'Error S02...unable to connect' errors.
Rather than waste time on the phone with Tivo, I decided to 'Restore' the image to my backed-up 11.0d image on a new 500G drive. That went fine, but the THD would not boot past the Welcome...powreing up! screen. I restored the virgin image to the 160G drive (the one that was working before, except for the software update) and received the same result. Besides MFSLive (which is a great product btw), I also have an Instant Cake boot disk. So, I baked a new image on the 500G disk but it wouldn't get past the first boot screen.

Here are my knuckleheaded troubleshooting steps:
1. Restored 11.0d image to 500G drive using WinMFS. No worky (Stuck on Welcome....Powering Up!).
2. Restored 9.4 ('virgin' image I have from when I expanded last year) to 160G using WinMFS. No worky (Stuck on Welcome...Powering Up!).
3. Baked new image on 500G disk. No worky (Stuck on Welcome...powering up!)
4. Used other THD power supply to make sure I didn't have a PS problem. (Stuck on Welcome....powerung up!)
5. Tried Instant Cake drive (#3 above) in my other THD and it booted to GSU on first try.
6. One last try with Instant Cake image (9.2) after power supply test...Still stuck on Welcome...Powering UP! See pertinent text below from kernel log. The full kernel log is attached as kernel_9.2.
7. Decided to Restore my 11.0d image on the same 500G drive. Now it boots to the Almost There screen but hangs up. Again, see tidbit from kernel log. This run is attached as Kernel_11.0.

Excerpt from Instant Cake (9.2) boot getting stuck on Welcome....Powering Up! System invokes a kernel panic.

Jan 2 00:00:47 (none) kernel: --- Kernel Panic Log. Uncompressed size 38400 ---
Jan 2 00:00:47 (none) kernel: eJztfX10HFl1p8ZSayzZ3f6QZQswScE4oMnIUn9JaiueQbY1MzIjjxtLHkzGpFxdVa0u
Jan 2 00:00:47 (none) kernel: VF1VrqrWx8wAGlBYDRhWJN7ESZxdLTuAIYaIYA6G+AQDZuMc5oA5ccBkh7NKYsBDJhtt
Jan 2 00:00:47 (none) kernel: 4hwMeDJ7733vVVVL8kf+yNk9Z1XnWK73u/d933ffffe9V51XLOOxicd016qBp7eGPUM1
Jan 2 00:00:47 (none) kernel: m773dz8dMKzKuDSqu55hW1K6PdueTkqthYphar30t6x4vu52d94vtQ6rasCZac+0Z++X
Jan 2 00:00:47 (none) kernel: 7ktJ+yC0X/Wl9A4p1d3T2dWT7pTyfUNSOpnsbqxZef7vPzuzD+3JH5RcfdSgvjO8HimZ


Excerpt from boot attempt with 11.0d 'restored' using MFSLive. Got hung on Almost There screen. Some obvious problems with 'superblocks' and missing files at the end.


Jan 2 00:00:56 (none) kernel: /sbin/e2fsck: Bad magic number in super-block while trying to open /dev/hda9^M
Jan 2 00:00:56 (none) kernel:
Jan 2 00:00:56 (none) kernel: The superblock could not be read or does not describe a correct ext2
Jan 2 00:00:56 (none) kernel: filesystem. If the device is valid and it really contains an ext2
Jan 2 00:00:56 (none) kernel: filesystem (and not swap or ufs or something else), then the superblock
Jan 2 00:00:56 (none) kernel: is corrupt, and you might try running e2fsck with an alternate superblock:
Jan 2 00:00:56 (none) kernel: e2fsck -b 8193 <device>
Jan 2 00:00:56 (none) kernel:
Jan 2 00:00:56 (none) kernel: Can't clean /dev/hda9 - rebuilding
Jan 2 00:00:56 (none) kernel: mke2fs 1.06, 7-Oct-96 for EXT2 FS 0.5b, 95/08/09
Jan 2 00:00:56 (none) kernel: ext2fs_check_if_mount: No such file or directory while determining whether /dev/hda9 is mounted.^M

Based on the logs, does anyone have any idea what the dealio is? Other than the HDD, it is a stock THD with no PROM mods. I read in another thread about potential tivoapp corruption. I didn't see anywhere in the kernel log where it is trying to initialize tivoapp.

Do I need to update the kernel?

Should I have the PROM done now. Otherwise it's a paperweight.

Any help is greatly appreciated.