PDA

View Full Version : Bash Req'd For Service Hack?



Venom
01-14-2002, 01:15 PM
Hi all, this is sure a fun kinda hobby. Been playing with this all weekend, and just need to do the final sub hack.

Working JUST from a PC at this point, no serial cable (yet), is this even possible to succeed at or is BASH via the serial port REQUIRED to do this step?

Installed xtreme got it up and running fine, but no sub hack. So I did:

Installed 25Extreme and finished that no problem.
Plug drive back into tivo, let boot and build etc...tv comes up fine.(tivo says I need to subscribe/make a call of course)
Unplug drive, hook back up to computer.
Boot 25xtreme disk
type: mkdir /mnt/td
type: mount /dev/hdc4 /mnt/td
type: touch /mnt/td/etc/SubTest
unmount hdc4
reboot box, power off, unplug drive
put back in tivo, power up.
Gets to the almost done few more seconds, and BOOM
Green Screen of Death , severe error etc...
Then i have to go re-2.5extreme/mad to get the drive in a workable state. Rinse & repeat many times. :)


I'm editing partition 4 which I understand to be the necessary one (opposed to 7 or 9). Is that right?

Thoughts? Otherwise I guess I'll go get a cable, but a prompt is a prompt, since bash is just Borne Again SHell, it should be the same no matter if I used a cable or dircelty to hard drive, provided i am editing the right partition (4).

Hopefully i'm not missing some steps entirely...like the mentions of fixup02c.tcl and rc.sysinit? I'm a little lost as to what role those play other than telling you which file to touch.

Thanks in advance ppl!

BubbaJ
01-14-2002, 02:33 PM
while the drive is still in the PC after running extreme, mount /dev/hdX9 and edit the rc.sysinit in the hack directory (this is what ends up as the funtional rc.sysinit

Venom
01-14-2002, 03:35 PM
Well I can do that to add the code needed to call SubTest no problem which I assume is what you are suggesting, but then do I touch using the 9 partition as well?

I have absolutley no problem reading thru past posts, just can't find anywhere that says "You can't do the sub hack from a pc" or "you must use the serial port on the back to be successfull" just didn't want to waste my time if it wasn't possible.

iogene
01-14-2002, 06:01 PM
Venom,
Yes, you can do the sub hack from the pc once the 25Xtr has booted in the tivo.
From the bootable Surgeon CD I was able to "touch" and
chmod +x.
GL

Venom
01-15-2002, 04:27 AM
iogene you get a case of beer! thanks so much. after several hours of frustration, my linux-non-newbie ass finally realized i never chmod'd the SubTest file to +x so it was causing a receiver lockup when trying to boot, giving me the green screen of death.

I really appreciate all the help i've got. I'm now up, subbed, and got the log files deleteing nicely. just have to do the locals hack and i think i'm all done. On to CCC now!
Thanks smooth, bubba, zap et al.
Thanks surgeon for combining so many usefull things into one distro cd.

BubbaJ
01-15-2002, 10:49 AM
SubTest does NOT need to be +x

You can edit the rc.sysinit in partition9/hack not to look for subtest by commenting the line that says if ???SubTest??? and the subsequent fi line

anthead123
02-15-2002, 04:00 PM
I did the same procedure, 25xtreme, boot from t60, touch the file in hdx4, and got the green screen of death.

Following that, I did the whole process again, install 25xtreme, boot up, touch file in hdx4, tried also "tail"ing the file in hdx9, same green screen.

I also tried touch file hdx4 then chmod +x, same green screen.

I think I just need some details regarding the rc.sysinit edit. Do I comment out the entire if ...SubTest.... fi including the phrase in the middle, or just those two particular lines (the if and the fi). Do I need to chmod the sysinit or chattr or anything.

Sorry, I'm a linux newbie, but I've been doing this for the past 16 hours over and over, thinking I'm just doing something wrong. Now I think I might be missing a step or something...

Thanks in advance!

BubbaJ
02-15-2002, 04:58 PM
You are getting the green screen because you are not allowing the machine to tidy up mfs before you pull the plug. (This from what I've READ.. I've never actually seen the green screen, as I'm PATIENT) :D

wylie
02-15-2002, 10:13 PM
venom,

i did mine just this week from the computer (no screen of death however)

steps:

just install 25x
put in tivo
boot, let finish
remove
put in comp.
mount /dev/hdx4 /mnt
cd /mnt
touch /etc/SubTest
unmount
ctrl del
power off

i also did it in hdx7, just for good measure..i had seen post saying both..

i worked on this for a couple days..
and got help here and at home..aatdss..

good luck

wylie

anthead123
02-17-2002, 03:20 AM
Alright, so I wasn't being patient...

But it payed off, and now I'm rolling.

Thanks BubbaJ :)

dtv killer
02-18-2002, 12:42 AM
After running xtreme on two drives and letting them boot up in the tivo unit do you have to put both units back in the computer or just drive a to run touch?
jc

BubbleLamp
02-18-2002, 12:53 AM
Originally posted by dtv killer
After running xtreme on two drives and letting them boot up in the tivo unit do you have to put both units back in the computer or just drive a to run touch?
jc

Just the A drive.

anthead123
02-18-2002, 12:57 AM
Just a drive (but it needs to be configured as something other than primary master)

dtv killer
02-18-2002, 01:05 AM
Thanks for the quick replies guys!
jc

netman
02-18-2002, 09:33 AM
Venom,

What configuration did you use when you set this up. I mean where did you put the tivo drive and your cd rom on the ide controller. Did you put the tivo drive on the secondary slave and cdrom on the sceondary master? I will be doing this hack sometime this week.

Thanks,
Netman

You can email me directly at:

netman2k21@hotmail.com

Any help would be greatly appreciated.

dtv killer
02-19-2002, 04:28 PM
Once you have been set to 5 lifetime sub is there any reason for the unit to be hooked up to the phoneline.
jc

neo72ca
05-21-2002, 03:28 PM
I installed 25xtreme. Boot Hard Drive in tivo and put back only A in PC using secondary master. Boot in PC using CD and did:

mkdir /mnt/td
mount /dev/hdc4 /mnt/td
touch /mnt/td/etc/SubTest
chmod +x /mnt/td/etc/SubTest
umount hdc4

Ctrl+Alt+Del to shut down. Put hard drive back in tivo and make daily call. Now I have lifetime. Thanks to everybody for the useful posts.

plarser46
08-20-2009, 07:35 PM
When this is done on (presumably) older units, how do you get the guide data after completing? It sounds like folks got the sub, but wasn't sure how program guide gets updated.

stevel
08-21-2009, 07:37 PM
I'm surprised that this thread is still here. In any event, I don't think 2.5 works anymore.

plarser46
08-21-2009, 07:54 PM
Looks like I've been digging just a bit TOO deep here :)

captain_video
08-24-2009, 07:09 AM
No problems. It's refreshing to see someone researching the archives first instead of asking questions right out of the gate.