Results 1 to 4 of 4

Thread: Truly difficult Joe error (not previously seen in this forum - I searched)

  1. #1
    Join Date
    May 2002

    Question Truly difficult Joe error (not previously seen in this forum - I searched)

    OK, I'm definatly going to be the JOE test dummy. That is, if I can make it go wrong, it certainly will

    OK, so install the turbonet, and get the bash prompt. YEA (it wasn't that easy, but learning is a good thing).

    learn to ftp file. (again cannot figure out how to get sz and rz to work, but get ws_ftp to do it)

    decide to install joe.

    download, unzip (winzip with the Tar smart conversion unchecked as taught)

    ftp joe and joerc with ws_ftp to /var/hack/ (fall prey to the ftp with binary instead of ascii problem, but get that resolved ... this forum is amazing)

    telnet to /var/hack with hyperterminal (do the chmod 755 *)

    type ./joe filename (tried a variety of filenames --> testfile and /.profile, for example)

    I get the following error.

    "BUG IN DYNAMIC LINKER dynamic-link.h: 46: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!"

    reboot Tivo (power down, power up), telnet, try again. Same error.

    Review the forums. Nothing here under joe and dynamic.

    Any ideas?

  2. #2
    Join Date
    Apr 2002
    Checksum joe on the tivo and off to make sure it isn't corrupted in the transfer.

    Don't worry about "joe filename" just "joe" will open it with a new file (unnamed) that removes any problems you may have with the files you are trying to open.

    If you have no checksum facility then FTP it off the Tivo and compare it to the original.

  3. #3
    Join Date
    May 2002


    You were right, it was a cksum error in the transfer.

    And quite magically, it started working whence before it wouldn't work when i had done apparently the same exact steps earlier (and we wonder why Linux hasn't conquered the desktop world yet???)

    Here's my theory and maybe someone can verify.

    Originally I transferred joe and joerc to the Tivo using WS_FTP in binary mode. This resulted in the errors noted in other posts. (Processing '/var/hack/joerc'...
    /var/hack/joerc 1: No context selected for macro to key-sequence binding)

    The solutions in the other posts were to switch the transfer mode in WS_FTP to ascii instead of binary.

    I did this and repeatedly received the errors I reported in my first post.

    So it looked like neither the binary nor ascii modes of ws_ftp would work properly (even though this is one of the tivo forum "approved" ftp proggies, frig)

    While playing with WS_FTP, however, i noticed that I could default the transfer mode to "l8", which is not listed on the front panel asking transfer mode. I did this and then checked "auto detect" on the front panel and transferred the files.

    The "autodetect" said it was transferring in binary. I looked over the cksum on the Tivo and now both were correct. But i figured, i'd get the error I noted above from the first time I had transferred them binary.

    Decided to try Joe anyway .... and .... it worked!!!!

    But why???

    Two theories: First the "l8" is something magical that I should use when transferring to the Tivo using WS_FTP

    Second: WS_FTP really isn't that good of a windows based ftp proggy to transfer files to the TIVO. If so, anybody have any other recommendations?

    Thanks for all the help

  4. #4
    Join Date
    Mar 2002
    WS_FTP works fine. The problem was that you must transfer joe as a binary file and joerc as an ASCII file. Sounds like you transferred them both as either binary or ASCII.

    The autodetect detected the proper mode to transfer the files.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts