Results 1 to 5 of 5

Thread: Tytool5r2 Nowshowing has stopped working!

  1. #1
    Join Date
    Jun 2002
    Posts
    41

    Question Tytool5r2 Nowshowing has stopped working!

    Tytool suddenly seems to be broken on my UK SA Tivo..

    (From the Telnet session)

    SERVER: We got a message! buf = 'SHOWING'
    syntax error in expression "*60*60"
    while executing
    "expr $tz*60*60"
    (procedure "get_tzoffset" line 31)
    invoked from within
    "get_tzoffset $setuptz $daylightsavings"
    (procedure "init_db" line 54)
    invoked from within
    "init_db"
    (file "./NowShowing.tcl" line 455)
    Waiting for an incomming connection!

    I've tried copying over every version I can find, and even running it...

    ./NowShowing.tcl

    which I think used to output to the telnet session. However, nothing works.

    I tried rebooting as well, still the same error.

    Anyone care to hazard a guess?

    TIA

    J

  2. #2
    Join Date
    Jan 2002
    Posts
    59
    I don't know why it is failing for you, but to workaround that particular error you should be able to set the $tz variable manually. From the error you posted I assume that the script is trying to get a value from MFS that it is not finding, then you get a syntax error because that variable is set to an empty string. If you set the $tz manually (I assume it is the GMT offset, which would be -8 for PST, -7 for MST, etc) then it should at least clear up the problem. I don't have the application in question so I can't really go into much deeper detail since I can't look at the code.

  3. #3
    Join Date
    Jan 2002
    Posts
    4,809
    I have been trying to fix it. I just need someone to give me telnet access to a UK tivo. It should take me about an hours for a permanent and proper fix. I just don't have anyway to do it at the moment as I don't have a UK tivo.

    --jdiner

  4. #4
    Join Date
    Aug 2002
    Posts
    65
    Any progress on this?

    Access to my tivo is difficult but happy to try things and provide feedback and/or files.........


    Cheers

    David

  5. #5
    Join Date
    Jun 2002
    Posts
    41
    Davidblack,

    Check the other thread on this, i've posted a file there for you...

    I shouldn't have created this thread, and I would close it if I could..

    But I can't. My mistake.

    J

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •