Results 1 to 6 of 6

Thread: Tivo Airnet with Kraven

  1. #1
    Gabriel Guest

    18 Tivo Airnet with Kraven

    hi,

    I have installed the TivoA Airnet card with a D-Link PCMCIA , I have a Linksys WAP/Switch functional with DHCP running

    Kraven supports Turbonet the instructions say to add the following to rc.sysinit

    ifconfig net0 192.168.1.99 netmask 255.255.255.0
    route.tivonet delete default 2> /dev/null
    route.tivonet add default gw 192.168.1.1 netmask 0.0.0.0 dev net0

    two questions:

    1) if I want my Dtivo to call I'm assuming I would use "eth0" instead of net0

    2) is there an ifconfig command switch to set the SSID to that used by the WAP?

    thanks for your help

    Gabriel

  2. #2
    Join Date
    Nov 2001
    Posts
    730
    With no experience I'd say:

    1. Correct.
    2. No, you have to have an open network.

    Dennis

  3. #3
    Gabriel Guest

    no device

    so I added:

    ifconfig eth0 192.168.1.109 netmask 255.255.255.0
    route.tivonet delete default 2> /dev/null
    route.tivonet add default gw 192.168.1.1 netmask 255.255.255.0 dev eth0

    to my /etc/rc.d/rc.remote-login

    sync'd and rebooted but I dont seem to have a network device?

    bash-2.02# ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Bcast:127.255.255.255 Mask:255.0.0.0
    UP BROADCAST LOOPBACK RUNNING MTU:3584 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 coll:0

    bash-2.02# ifconfig eth0
    eth0: unknown interface.

  4. #4
    Join Date
    Oct 2001
    Location
    Out West
    Posts
    3,171
    Kraven has stated that his regular Ethernet driver is hardcoded as net0. I don't know if that's the case for the wireless driver as well. I'd try manually loading the driver and then setting the IP stuff so you can determine where things are going wrong.

  5. #5
    Gabriel Guest
    per this post http://<a href="http://dealdatabase....ght=insmod</a>

    I did this:

    insmod -f /lib/modules/ax88796.o macaddr=012345 timing=5 devicename=net0

    on both eth0 and net0

    I get

    /lib/modules/ax88796.o: invalid parameter devicename

    it appears that eth0 is the standard interface and s/b loaded from rc.arch?

  6. #6
    Join Date
    Oct 2001
    Location
    Out West
    Posts
    3,171
    Originally posted by Gabriel
    per this post http://<a href="http://dealdatabase....ght=insmod</a>

    I did this:

    insmod -f /lib/modules/ax88796.o macaddr=012345 timing=5 devicename=net0

    on both eth0 and net0

    I get

    /lib/modules/ax88796.o: invalid parameter devicename

    it appears that eth0 is the standard interface and s/b loaded from rc.arch?
    That's because the driver included in Kraven's update did not support the devicename command, Nick added that later. Like I said, Kraven's driver is hardcoded as net0. (Which I didn't know when I wrote in that other thread!) You'd have to use a hex editor on the driver to change it. I'd just replace the driver itself with the newer one from the Silicondust site and use the command line parameter. If there are other references to net0 in Kraven's files (and I believe there are) you'll need to change them as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •