Page 1 of 7 123 ... LastLast
Results 1 to 15 of 99

Thread: MfsStream Web Module v.98!

  1. #1
    Join Date
    Nov 2001
    Location
    Canada
    Posts
    157

    MfsStream Web Module v.98!

    Well after much testing (thanks grytpype!!), here is .98 of mfsstream web module.. if v.97 is working for you right now, you won't find any new functionality, but here are the changes:

    - Now works with both 2.x and 3.x tivos (Directivo and SA)!

    - Fixed a timezone bug when dealing with GMT 0

    - Added error checking when opening .cfg file

    - Changed file read routine so it should work on all tivos..

    Thanks to whoever fixed it for 3.0 tivos (please PM me so i can give you proper credit for the initial hack) and also to jdiner for his version detection algorithm that i ripped out so blatantly..

    To upgrade, you only need to replace the mfsstream.itcl and mfsstream.cfg in your modules directory..

    Lemme know if it doesn't work for you! Or just tell me it works 100%! hehe

    cheers,
    gosquad


    Jan 19 2002 - updated this to v.98b.. there was a big bug in the title edit code.. it has been fixed. - gosquad
    Last edited by gosquad; 01-19-2003 at 04:47 PM.

  2. #2
    Join Date
    Nov 2001
    Location
    Canada
    Posts
    157
    Hey all.. just changed the readme.txt to add a shout out to mrblack51 who did the initial 3.x support.. thanks mrblack! (I'll remember who did what next time )

    - gosquad

  3. #3
    Join Date
    Jan 2003
    Posts
    3

    Thumbs up Great Work!!!

    I got v.98 to work on my SA Phillips. Video extraction was the last mod I was hopig to get working on my unit. After several attempts at other methods none of which I was able to get working, I was able to get this one going in no time.

    Thanks!!!

  4. #4
    Join Date
    Jan 2002
    Posts
    7

    Error Message when using Edit

    I cannot edit the show title when using MFSSTREAMS. I get the folowing error:

    INTERNAL SERVER ERROR
    action_mfsstream '/title/407868/sm' ''
    no value given for parameter "chan" to "fsidEdit"

    Any suggestions?

    Thanks,

    Bill

  5. #5
    Join Date
    Nov 2001
    Location
    Canada
    Posts
    157
    Thanks to bill for finding that bug. v.98b has been uploaded above. please give it a try...

    cheers,
    gosquad

  6. #6
    Join Date
    Nov 2002
    Posts
    60
    perhaps I'm doing something wrong, but whenever I click onto a movie I go to "page can't be found" page.

  7. #7
    Join Date
    Jun 2001
    Posts
    3,108
    you probably forgot to start tyhttpd

  8. #8
    Join Date
    Nov 2002
    Posts
    60
    nope, I'm an *****. took the instructions too literately. I actually put in "/path/to/tyhttpd" instead of my actual path...duh.

  9. #9
    Join Date
    Dec 2001
    Posts
    31

    Not working

    I get errors trying to edit or delete anything.


    INTERNAL SERVER ERROR
    --cut here--
    action_mfsstream '/title/635841/ESPN-Outside the Lines: Ultimate Fighting' ''
    no value given for parameter "chan" to "fsidEdit"
    while executing
    "fsidEdit $fsid $action $val $chan"
    (procedure "::action_mfsstream" line 82)
    invoked from within
    "::action_$action $chan $part $env"
    ("eval" body line 1)
    invoked from within
    "eval {::action_$action $chan $part $env}"
    --cut here--

  10. #10
    Join Date
    Jan 2003
    Posts
    8

    Am I doing something wrong?

    Maybe I am missing something but I have installed mfsStream and it seems to work fine. I can download the ty files to my PC. From there nothing seems to work. I've tried tydemux and I get divide by zero errors, I tried vsplit and I get empty output files. Tried TyTools in process mode and got the same thing. I have a D-tivo ver 3.1.0-01-1-011 ... Am I missing something??


    TIA.

  11. #11
    Join Date
    Dec 2001
    Posts
    31

    blax

    blax,
    are you running noscramble?

  12. #12
    Join Date
    Nov 2001
    Location
    Canada
    Posts
    157

    Re: Not working

    please re-read this thread

    Originally posted by Marksmanaz
    I get errors trying to edit or delete anything.


    INTERNAL SERVER ERROR
    --cut here--
    action_mfsstream '/title/635841/ESPN-Outside the Lines: Ultimate Fighting' ''
    ---snip---
    --cut here--

  13. #13
    Join Date
    Sep 2002
    Posts
    140
    OK I am stupid. But:

    When I click on a file it saves it as 0 bytes....

    And when I try to rename anything, I get:

    INTERNAL SERVER ERROR
    --cut here--
    action_mfsstream '/startdate/349295/01/19/2003 08:59am' ''
    no value given for parameter "chan" to "fsidEdit"
    while executing
    "fsidEdit $fsid $action $val $chan"
    (procedure "::action_mfsstream" line 82)
    invoked from within
    "::action_$action $chan $part $env"
    ("eval" body line 1)
    invoked from within
    "eval {::action_$action $chan $part $env}"
    --cut here--

    Matt

  14. #14
    Join Date
    Nov 2002
    Posts
    203

    Gosquad - DEVO SNL clip

    I still have that SNL DEVO clip for you from the DTIVO - it's about 105 meg if you want me to upload it somewhere.


  15. #15
    Join Date
    Jun 2002
    Posts
    36

    mfsstream stops at 3.99GB

    I loaded mfstream V.98 and for me it works much better than previous versions with one major exception: It stops downloading at 3.99GB.

    The download begins normally but once the download reaches 3.99 GB it just stops. The download window stays open but there is no network activity. If I stop the download the partial .ty file is deleted because the download was not completed.

    I have tried to download several streams and get the same results.

    Any ideas?

    Thanks,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •