Page 2 of 99 FirstFirst 12341252 ... LastLast
Results 16 to 30 of 1477

Thread: Mfs_Ftp: extract, archive, restore & transfer recordings

  1. #16
    Join Date
    Sep 2001
    West of Bermuda
    ok, i'm a dummy. i've got this installed and have successfully pulled off a .tmf, and i want to make a dvd.

    the tmf is a 30 minute show, and is in two parts in the tmf. so, i have two .tys that i need to concat and what - vsplit and mux? how do i put the two ty back together?

    sorry if this has been covered; please feel free to point me to a faq


  2. #17
    Join Date
    Jun 2001
    Well with the windows command line it goes like this:

    copy /B C:\part00.ty+C:\part01.ty+C:\part02.ty c:\combined.ty

  3. #18
    Join Date
    Jun 2002
    Just as an FYI: I am running TiVoWeb, mfs_ftp and ftpd simultaneously with out problems. I just started mfs_ftp on a different port. I have extracted 6 shows today without any problems.

  4. #19
    Join Date
    Nov 2002
    Santa Clara (SF Bay area)

    FTP Client for Mac OS X? seems to work good for me.

  5. #20
    Join Date
    Oct 2002
    Originally posted by mini__me
    Strange my problem is slightly different to yours as I can get them to run from 1.2.1 and I can browse around with the phoenix and shutdown working fine and I'm able to see shows however I get this critical error when I try to download and upload just hangs as if waiting for something that never happens.

    Are you running the .tcl through dos2unix just in case? I am doing this to every file now and have had no problems of file not found anymore.
    I had *exactly* the same problem. As soon as you turn of the multiple connection option in FileZilla it all starts working again....
    ( at least one place was under Queue, Use Multiple Connections )



  6. #21
    Join Date
    Feb 2003

    Lightbulb explanation-why mfs-ftp wont run.

    I've noticed a number of posts about why the mfs_ftp.tcl script doesn't run for some people. I think I can clarify the confusion.

    First, what's really going on:
    A text file on a dos system has a <cr><nl> at the end of each line. Unix expects just a nl.
    Looking at the 1st line in mfs_ftp_1.2.3.tcl, we see a line that is supposed to start the tcl interpreter:
    This invokes a program called /tvbin/tivosh. So
    far this is 1st grade stuff. Now for the fly in the ointment...
    If the file is a DOS format file, the <cr> before the <nl> becomes part of the filename, and looks like this:
    Yes, in UNIX a <cr> *can* be part of a filename. Of course the tivo can't find the tivosh<cr> program, and, well, end of story.

    The dos2unix command probably strips the <cr> (I dont use this utility myself), or Unix purists might use the command
    "tr -d '\r' <mfs_ftp_1.2.3.tcl >mfs_ftp_1.2.3_unix.tcl"
    to do the same thing. In either case, this will remove the <cr> and fix the problem.
    why does the command "/tvbin/tivosh ./mfs_ftp_1.2.3.tcl" work? because TCL doesnt
    need that filename, and doesn't (usually) care
    about the extra <cr> in the file.
    Why is this happening? I looked at the unziped files on my unix system, and find that the mfs_ftp_1.2.2.tcl and mfs_ftp_1.2.3.tcl files are in 'DOS' format. In order to work the <cr> needs to be stripped.. somehow...

    IF you use FTP from a *DOS* system up to the tivo
    (unix) system in *ASCII* mode, the format translation is done for you , and things should work out of the box. If you use *BINARY* mode,
    OR come from a UNIX system, FTP believes no translation is needed... and the extra <cr> is left intact (booo).

    If you are running unix, or have the 'od' utility on your Tivo, the following command will show the line terminators and you can see it for yourself:
    od -c mfs_ftp_1.2.3.tcl | less
    Conclusion: Just run the dos2unix command, or the tr command to remove the 'cr', and enjoy the use of the program!
    Last edited by majictek; 02-28-2003 at 11:34 PM.

  7. #22
    Join Date
    Dec 2002

    Re: Linux FTP client?

    Originally posted by jodell
    [B]Has anyone found a suitable Linux GUI FTP client that supports FXP?
    gtkfxp works

  8. #23
    Join Date
    Dec 2002
    I haven't downloaded or tried this yet, in fact, I just found it, but I have a question...

    With this, and a corresponding client/server app sitting on another tivo, how hard would it be to have Tivo A pull a recording from Tivo B, then start playing that recording once it has buffered enough data, ala HMO for Series 1...

    I think the real challange would be doing that from the Tivo interface w/o having to actually log into either box.


  9. #24
    Join Date
    Mar 2003

    Success Report


    Just wanted to report in another successful installation of this program. I really love the feature, you did a great job.

    Just to let you know a little about my experiences:

    I am using 1.2.4 on a SA Series 1 (S-2000) v3.0. Turbonet card using the standard 3.0 drivers. (Should I change these?)

    I have to start it using tivosh mfs_ftp.tcl, and I edited the script to call tivosh directly also.

    I am getting 1.2 to 1.5 MB/s downloads using FileZilla 2.1a, but uploads are between 200 and 300 kB/s. I haven't gone through the debug suggestions a few pages back yet.

    A few times I seem to have locked up the program, either from aborted transfers, or unknown causes. Sometimes using the abort.txt file fixed it. Sometimes I was able to telnet to 3105 and issue the exit command. Other times, however it wouldn't accept new connections and never responded and I ended up killing the process (and causing a TiVo reboot).

    One file which NowShowing reports as 5GB shows up on the tmf directory as being only 1GB. When downloading it actually is splitting itself into 2 pieces. The first 1GB file gets then conflicts with the remaining 4GB file at the last moment. Download fails with a "Critical transfer error" message. I need to kill mfs using the abort.txt file to recover.

    All other files seem to report the correct size. I don't know if this is a FileZilla issue or the mfs_ftp package. Let me know how I could trace down better debug info.

    Thanks again for the great package.

    Last edited by wactuary; 03-10-2003 at 12:57 AM.

  10. #25
    Join Date
    Aug 2002

    I was one of the few experiencing the critical transfer errors. I have switched clients to WS-FTP and am having NO problems whatsoever. However, if I try to use filezilla, I still get that error.

    I haven't had time to really debug this situation, but apparently it's a client issue, NOT necessarily an mfs_ftp error.

    Hope you have luck fixing your problem.

  11. #26
    Join Date
    Oct 2002
    Spring, TX
    Just wanted to be one of the folk that says thanks for all the work on this. It works great! mfs_ftp is the icing on the cake for the tivo network!
    Steve Mc

    DSR6000 35hrs
    Sat-T60 110hrs

  12. #27
    Join Date
    Jan 2003

    Reinsertion Question

    I have not yet attempted to re-insert a program, but I have a question regarding the process. Say I download a tmf file, extract the ty files from it, and then use cat to join the ty files into one big ty file.

    If I replace the multiple ty files in the tmf with the large ty file I created and then re-insert the tmf file, will this work? I guess my question is whether or not the re-inserted tmf needs to have the same number and size ty files as the original tmf.


  13. #28
    Join Date
    May 2002
    I don't think it will work if a pice is larger then 512M I don't know if it will work with multiple pieces smaller then that (it's designed around multiple 512M pieces plus one smaller piece at the end)

  14. #29
    Join Date
    Mar 2003
    Can you put a cat'd ty back into a tmf and reinsert?

    No. (unless you segment it into 512mb chunks and generate the required xml data for Now Showing to display).

    Does it need the same sized segments to reinsert?


  15. #30
    Join Date
    Mar 2003

    500k/sec typical with hub?

    I'm running a stock Philips 20hr SA (no hd upgrades) with a turbo net card - anyone else got this setup?

    I'm getting 500k/sec - which is fine, but I'm seeing others get 6x that speed.

    Is my hub the limiting factor (compared to a switch), or the hard drive?

    Riley - this is a truly great app - takes me 11 minutes for a half hour show at basic quality - takes about a minute in tytool 6r3 to convert it to a m2v which I can watch through media player.

    Time to start taking tv shows to work on the ipod to watch at lunchtime

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts