Page 23 of 99 FirstFirst ... 1321222324253373 ... LastLast
Results 331 to 345 of 1476

Thread: Mfs_Ftp: extract, archive, restore & transfer recordings

  1. #331
    Join Date
    Jun 2003
    Location
    Somerset, England
    Posts
    1,124
    Quote Originally Posted by cojonesdetoro
    I'm seeing a problem where MFS_FTP drops the control channel when I issue a PORT or PASV command. I'm not sure what's causing it. It seems to happen after a recent copy but sometimes happens when no access has happened for a while.

    Has anyone else seen this? I'm thinking that I just have to write a routine that opens the channel, tries PASV-or-PORT and retries both until a proper server response comes back.
    The socket-to-mfs_ftp stuff I've done is quick in and out - login, commands, quit - so I've never tried to keep the control cocket open for more than a singe transfer, but I've not seen this as a problem.
    Stuart

    Newbies - see if your questions are answered here Experts - can you add to the knowledge stored here? Developers - are your hacks listed here?

  2. #332
    Join Date
    Mar 2002
    Posts
    1,339
    the control channel is closed whenever there's an error, whether it's on the control/data channels or a problem calling a binary (browsers / ftpfs are kinda dumb sometimes, much cleaner to close the link & make them reconnect / re-issue commands whenever there's a problem)

    crank the mfs_ftp loglevel up to 5 - it'll tell you exactly why the connection was closed

  3. #333
    Join Date
    Sep 2003
    Location
    NY
    Posts
    89

    move shows to new tivo

    I need to send my Tivo back for repair (under warranty) and of course I'll be putting the orig HD back in. I would imagine I am going to get a new MB (just NO response whatsoever from the unit)

    This tivo does not have the kmem for no scrambling. So what I wanna do is transfer the shows back into the new unit when I get it back. Can this be done with scrambles shows?

    I've tried, unsuccessfully, in the past to swap HDs from tivo to tivo.

    So can anyone point me in the right direction or if its even possible?

    Thanks
    Dave
    -----------------------------
    Life's a reach, then you gybe
    Hacks -SA 2 PROM, telnet, ftpd, tivoweb, tserver, mfs_ftp, & extraction
    SA2.5 PROM - telnet, ftpd, tserver (waiting for a tivoapp patch)

  4. #334
    Join Date
    Mar 2002
    Posts
    1,339
    if they were recorded scrambled on a s2 there's nothing you can do, they won't play back on a different motherboard/crypto-chip
    ---
    Give a man a fish and he will eat for a day. Teach a man to fish and he will sit in a boat all day and drink beer

  5. #335
    Join Date
    Oct 2003
    Posts
    122

    fxpmerge error

    I am using fxpmerge to transfer a show. I am getting an error and I am not sure what it means. Please help.

    Rkshack

    08:32:31:AM - 220 Mfs_Ftp ver 1.2.9p - {sock22} from "192.168.1.100:1027"
    08:32:31:AM - 331 User name okay, need password.
    08:32:31:AM - 230 Running in TiVo Mode.
    08:32:31:AM - 250 Directory change successful.
    08:32:31:AM - 227 Entering Passive Mode (192,168,1,100,12,32).
    08:32:32:AM - 150 About to open data connection.
    bgerror invoked with error

    " child killed: write on pipe with no readers "

    re-initializing mfs_ftp

    close the current ftp connection and simply open another

    "core dump"

    info(version): 1.2.9p
    info(tswv): 3.0-01-1-000
    info(dbl): 0
    info(ithrottle): 2
    info(insert_priority): 10
    info(multithreaded): 0
    info(saveuntil): suggestion
    info(name_detail): 5
    info(bjuggle): 0
    info(active): 0
    info(ac_interval): 1800
    info(gatewayip): 127.0.0.1
    info(gatewayport): 3105
    hdr612 hacked to 128hrs
    hdr312 not hacked

  6. #336
    Join Date
    Oct 2002
    Posts
    63
    Okay... Can't seem to find the answer to this but I am a bit bleary eyed after a day of upgrades... I have MFS FTP working downloads and uploads. I have been trying to insert some recordings that I dumped from an old disk (same machine) that I had recently unscrambled. When I try to play them on the tivo I get the "Do You Want to Delete" screen followed by an error saying that there is no video present. I originally thought that this was a scrambling issue. Then I tried downloading them as .ty files (they were upped as .tmf) and when re downloaded they play fine on my computer. I'm reasonably sure that it is something obvious. Any help would be appreciated. Oh, and I did search and read the threads so if I missed it I am sorry.
    Last edited by whackit; 02-07-2004 at 07:02 PM.

  7. #337
    Join Date
    Jul 2003
    Posts
    769
    Quote Originally Posted by rkshack
    I am using fxpmerge to transfer a show. I am getting an error and I am not sure what it means. Please help.

    Rkshack

    08:32:31:AM - 220 Mfs_Ftp ver 1.2.9p - {sock22} from "192.168.1.100:1027"
    08:32:31:AM - 331 User name okay, need password.
    08:32:31:AM - 230 Running in TiVo Mode.
    08:32:31:AM - 250 Directory change successful.
    08:32:31:AM - 227 Entering Passive Mode (192,168,1,100,12,32).
    08:32:32:AM - 150 About to open data connection.
    bgerror invoked with error
    Yep, I'm seeing the same problem. It seems to happen when i issue the PASV or PORT command. It may work if you give it a minute and try again.

    I rewrote my script to retry the command three times after waiting 30 seconds between tries. That seems to correct it some times but every once in a while mfs_ftp gets hosed. There must be something about the way my script works that causes problems. I'm still messing around with it. In the mean time, Stuart will be releasing his hack soon. It may make my stuff not worth the trouble. Keep reading this thread.

    BTW, I've also yanked my script because I never asked embeem for permission to use his copyrighted code. I sent him a PM at the TC forum but have not heard back from him.

  8. #338
    Join Date
    Jan 2004
    Location
    Noo Hampsha
    Posts
    738
    I had trouble inserting as tmf, due to the way scrambling works. Uploading as ty+ did the trick for me, as it zeroes/ignores the scrambling key (I did have the tivoapp patch applied.)
    Steve

  9. #339
    Join Date
    Jan 2003
    Posts
    388
    Some of you reading this thread may find this useful. I have updated chunkedit.tcl to allow batch copying between Tivo's using mfs_ftp without editing or need for cutfiles. Here is a little more info about the new feature.
    Last edited by rung; 02-08-2004 at 06:51 PM.

  10. #340
    Join Date
    Jan 2002
    Location
    In Front of the Grill....
    Posts
    165
    Quote Originally Posted by Will
    I never had any luck with Transmit and mfs_ftp. Gives me a valid-looking list of files, but the download starts going into an endless sequence of empty subdirectories and then Transmit quits after a few seconds.

    Could you describe what you do to make it work for you?
    I got Transmit to work fine at first...so I paid the $25 and now all I get is the empty subdirectories...I dunno what happened.


    I guess I'll try SmartFTP...is this what most OSX users are using?
    Should I throw something on the grill
    for ya?

  11. #341
    Join Date
    Dec 2001
    Posts
    173
    Quote Originally Posted by BBQ-AllStar
    I guess I'll try SmartFTP...is this what most OSX users are using?
    I use CuteFTP lately. It gives me the fastest mfs_ftp download speeds I've seen outside the command line.

  12. #342
    Join Date
    Jan 2002
    Location
    In Front of the Grill....
    Posts
    165
    Quote Originally Posted by Will
    I use CuteFTP lately. It gives me the fastest mfs_ftp download speeds I've seen outside the command line.
    What speeds are you getting?

    I found a nice FTP program that works well called "CaptainFTP 3.1.1" via version tracker...it's shareware but gives you a 15-day trial. But my d/l speeds are only around 500 kb/sec.

    I'm using a 50 ft ethernet cable...will a shorter (12 ft) cable make a big difference?
    Should I throw something on the grill
    for ya?

  13. #343
    Join Date
    Jan 2003
    Posts
    30

    Fetch

    Quote Originally Posted by Will
    I use CuteFTP lately. It gives me the fastest mfs_ftp download speeds I've seen outside the command line.
    I've never had any trouble with Fetch. :-) Good luck.
    /mhb

  14. #344
    Join Date
    Dec 2001
    Posts
    173
    Quote Originally Posted by BBQ-AllStar
    What speeds are you getting?

    I found a nice FTP program that works well called "CaptainFTP 3.1.1" via version tracker...it's shareware but gives you a 15-day trial. But my d/l speeds are only around 500 kb/sec.
    CuteFTP runs consistently about 4X that on my system. Fetch was much more variable, from about 1500 to 1750 (on a good day).

    Quote Originally Posted by BBQ-AllStar
    I'm using a 50 ft ethernet cable...will a shorter (12 ft) cable make a big difference?
    I don't believe there should be. Some of my cable runs are 100 feet plus, through switches.

  15. #345
    Join Date
    Jun 2003
    Location
    Somerset, England
    Posts
    1,124
    I've written a patch for mfs_ftp to let you start a transfer from the Now Showing screen.

    It also removed the "bookmark juggle" dance when watching a streaming recording from another TiVo.

    More here:

    http://www.dealdatabase.com/forum/sh...ad.php?t=32184
    Stuart

    Newbies - see if your questions are answered here Experts - can you add to the knowledge stored here? Developers - are your hacks listed here?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •