Results 1 to 3 of 3

Thread: File mode changed to character?

  1. #1
    Join Date
    Jan 2002
    Location
    Inside my Tivo
    Posts
    15

    File mode changed to character?

    I'm running Tivo 2.5.2 with xPlusz and recently upgraded elseed to version 0.6.0. I created a new /etc/elseed.conf file with two standard MAPs.

    Prior to the upgrade, I used to "tail /var/log/elseed.log" when at my computer to see who called, but now this file appears to stay empty. When I check the file with an "ls -l" it now shows as:
    crw-rw-rw- 1 0 0 1, 3 Mar 19 04:24 elseed.log

    My Linux books show this as a "Character special file", but I'm not sure how this came about. I always "sync" before rebooting and have not had any weird issues prior to this. Elseed works - I even renamed elseed.log and created a new one, which "tails" properly. This could be the end of my problem (just delete the old one), except that svclog, tivoLog.prv, and tivoLog.pub are the same way. Should I recreate those files? Any ideas why this would happen?

    TIA
    Last edited by xmetalloid; 03-19-2003 at 10:59 AM.

  2. #2
    Join Date
    Jan 2002
    Location
    New York
    Posts
    2,407

    Re: File mode changed to character?

    Originally posted by xmetalloid
    I'm running Tivo 2.5.2 with xPlusz and recently upgraded elseed to version 0.6.0. I created a new /etc/elseed.conf file with two standard MAPs.

    Prior to the upgrade, I used to "tail /var/log/elseed.log" when at my computer to see who called, but now this file appears to stay empty. When I check the file with an "ls -l" it now shows as:
    crw-rw-rw- 1 0 0 1, 3 Mar 19 04:24 elseed.log

    My Linux books show this as a "Character special file", but I'm not sure how this came about. I always "sync" before rebooting and have not had any weird issues prior to this. Elseed works - I even renamed elseed.log and created a new one, which "tails" properly. This could be the end of my problem (just delete the old one), except that svclog, tivoLog.prv, and tivoLog.pub are the same way. Should I recreate those files? Any ideas why this would happen?

    TIA
    You are nulling out your log files to save on space.

    There must be an option in XPlusZ to turn off no logging. The logsNull module does that exact thing to all files in /var/log.

    read through the XPlusZ instructions and turn off log management, OR move the elseed.log file to a different directory (that is my real recommendation).

    Elseed comes with a significant enough readme that you'll be able to redirect the log file wherever you want it.

    JJ

  3. #3
    Join Date
    Jan 2002
    Location
    Inside my Tivo
    Posts
    15
    Hmm. Okay, I used to null my logs a different way and never thought of it when I upgraded to xPlusz. This certainly makes sense though, from what I recall about the alternate procedure to null the logs. I'm not really hung up on either, as long as one is running!

    I'll edit xPlusz.tcl to pass a different path to elseed upon launch and not sweat about the other logs.

    Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •