Results 1 to 7 of 7

Thread: HDVR2: TY files and Vsplit problems?

  1. #1
    Join Date
    Mar 2003
    Posts
    12

    HDVR2: TY files and Vsplit problems?

    All --

    Ok, I am able to get a .TY file off of my HDVR2 using jdiner's "TYToolAlpha6r3" with no problem. I recorded 2 minutes of video = 48mb. I used alldeadhomiez's hack for noscramble. The header bytes look fine for a TY file.

    So, the question of the hour ... vsplit DIES when trying to create the .m2v and .m2a files. (see output below)

    I have tried this on NTFS (WXP) as well as FAT (WME), so that's not the problem.

    I'm lost! Anyone have any idea why? Anyone get video extraction fully working yet on the HDVR2?

    Thanks,
    O=-SiNiKaL-=O
    -----------------------

    R-1x4: Old Aud ByteCount = 0 0 0 to 0 0 0
    -1x4: We are NOT aligned on the audio... It is an OOB chunk!
    -1x4: We are NOT aligned on the Video... It is an OOB chunk!
    Nope... Not in sequence... Skipping it...


    -1x4 - No Audio or Video timestamps in this chunk... Checking byte counts...
    -1x4: New Vid ByteCount = EB F5 58 to ED E1 80
    -1x4: New Aud ByteCount = FD FB 80 to FE E 0
    -1x4: Old Vid ByteCount = 0 0 0 to 0 0 0
    -1x4: Old Aud ByteCount = 0 0 0 to 0 0 0
    -1x4: We are NOT aligned on the audio... It is an OOB chunk!
    -1x4: We are NOT aligned on the Video... It is an OOB chunk!
    Nope... Not in sequence... Skipping it...

    [...and it continues like this until...]

    A/V Sync Offset: -0ms (i.e. plays 0ms late!)

    DiffTime = 2.123000 (2123) == 0.035383 Minutes
    total = 27262976

    Done with 'C:\blah-.ty'...
    Last edited by sinikal6969; 03-31-2003 at 03:57 AM.

  2. #2
    Join Date
    Mar 2003
    Posts
    12

    Also noticed the following...

    ...when using VSplitMux02c...

    Detected Tivo Type: DTivo
    Detected Audio Stream Type: MPEG Layer II
    Final standardAudioSize = 592
    Final standardFrameLength = 0 <<<<<<<<<<<<---- ???
    Final standardAudioDiff = 6480 or 00:00:00.072
    First Video PTS: 13:15:21.858

    [other junk already posted]

    O=-SiN-=O

  3. #3
    Join Date
    Dec 2001
    Location
    Seattle, WA
    Posts
    174
    Try TyStudio (or the old version, TyDemux). Its supposed to understand S2 streams.

  4. #4
    Join Date
    Mar 2003
    Posts
    7
    Yeah, use the tydemux that comes with tystudio. Its the only one I've had any luck with on my SA S2. So far I've only come across one TY file that it couldn't split correctly.

  5. #5
    Join Date
    Mar 2003
    Posts
    12

    The procedure

    Hey!

    So, I've found a combination that works for me:

    (1) Run tserver_mfs_mips6 on the HDVR2
    (2) Use TyTool6aR3 to extract the ty file
    (3) Use TyStudio TyDemux to create that video and audio streams
    (4) Use TMPGEncoder to create a final MPG video/audio.
    (5) Watch a perfect MPG
    Only caveat is that if I want to fast fwd or rewind, the audio gets de-synched.

    What didn't work
    ----------------------
    - If I use TyTools to create the final MPG video/audio, it won't play right (in ATI player it is either de-synched or the video 'stutters', and RealPlayer has the audio in-synch, no stutter, but the video is elongated vertically [??])
    - If I use TyTools from the GUI, it crashes at 49%
    - The final MPG is MPEG-2, and is 2gb for a 2hr movie. Would like to be able to make a smaller (VCD quality) file ... don't yet know how.

    Does anyone have a "better" solution that is working for them on the HDVR2?

    Any help is greatly appreciated!

    O=-SiNiKaL-=O
    Last edited by sinikal6969; 04-13-2003 at 05:55 AM.

  6. #6
    Join Date
    Dec 2001
    Location
    Seattle, WA
    Posts
    174

    Re: The procedure

    Originally posted by sinikal6969
    (3) Use TyTools TyDemux to create that video and audio streams
    Point of clarification...

    Do you mean Use TyStudio TyDemux to create the video and audio streams?

  7. #7
    Join Date
    Mar 2003
    Posts
    12

    Re: Re: The procedure

    Originally posted by FreydNot
    Point of clarification...

    Do you mean Use TyStudio TyDemux to create the video and audio streams?
    Oh. Yep. Thanks for the correction. Edited above.
    Vsplit doesn't work for me at all on the HDVR2 streams (as mentioned in my original post at the beginning of this thread).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •