Page 3 of 3 FirstFirst 123
Results 31 to 38 of 38

Thread: MythTivo now available

  1. #31
    Join Date
    Feb 2004
    Posts
    54

    35 I did it

    Ok i did get this to compile and install. also made the changes to the menus in mythtv.

    there just seems to be on problem when i go to the mythtivo. i see the tivos in the list but when clicked mythtv just shuts down. not just mythtivo it is mythtv that shuts down.

    has anyone seen this or can you point me in the correct path on what to look for to fix it. i have searched but can not seem to find any help.

    thanks
    5 Hughes Dtivo all running 6.2 and hacked

  2. #32
    Join Date
    Oct 2004
    Posts
    87
    Quote Originally Posted by usa11usa View Post
    Ok i did get this to compile and install. also made the changes to the menus in mythtv.

    there just seems to be on problem when i go to the mythtivo. i see the tivos in the list but when clicked mythtv just shuts down. not just mythtivo it is mythtv that shuts down.

    has anyone seen this or can you point me in the correct path on what to look for to fix it. i have searched but can not seem to find any help.

    thanks
    usa11usa,
    Yes I had this problem, the wrong codec where install, run mythfrondent from a terminal, go to mythtivo run and let is crash out, then in ther terminal it will say what went wrong. My suggestion is to get mplayer working first before trying to get mythtivo working, since mplayer is a critical component.

  3. #33
    Join Date
    Feb 2004
    Posts
    54

    Next error problem.

    Ok I did that and fixed a few settings and cleaned up a few errors. But here is the error i'm getting when i try to play the movie. vserver is running on the tivo and mfs_ftp is running but dont think the mfs_ftp is needed but anyway. when i try to run it this is the last few errors i'm getting.

    i'm going to look into it. but any help would be greate.. thanks for all the help so far.

    nd:mplayer -vm -quiet -fs -sb 393216 -af list=volnorm tivo://90.0.0.201/1915978
    MPlayer 1.0pre8-4.1.1 (C) 2000-2006 MPlayer Team
    CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1


    93 audio & 211 video codecs
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not open config files /root/.lircrc and /etc/lircrc
    mplayer: No such file or directory
    Failed to read LIRC config file ~/.lircrc.
    You will not be able to use your remote control.

    Playing tivo://90.0.0.201/1915978.
    File not found: '90.0.0.201/1915978'
    Failed to open tivo://90.0.0.201/1915978.
    No bind found for key 'c'.
    No bind found for key 'l'.
    5 Hughes Dtivo all running 6.2 and hacked

  4. #34
    Join Date
    Oct 2004
    Posts
    87
    Quote Originally Posted by usa11usa View Post
    93 audio & 211 video codecs
    Opening joystick device /dev/input/js0
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    Setting up LIRC support...
    mplayer: could not open config files /root/.lircrc and /etc/lircrc
    mplayer: No such file or directory
    Failed to read LIRC config file ~/.lircrc.
    You will not be able to use your remote control.
    You can ignor those error unless you have joystick or a remote, I havn't set my up yet and I get those

    Quote Originally Posted by usa11usa View Post
    Playing tivo://90.0.0.201/1915978.
    File not found: '90.0.0.201/1915978'
    Failed to open tivo://90.0.0.201/1915978.
    No bind found for key 'c'.
    No bind found for key 'l'.

    Try running mplayer in the terminal (outside of myth)

    type
    mplayer tivo://90.0.0.201/1915978

    And see if it plays, the 1915978 is just the show id number.

    Also I believe I droped "-af list-volnorm" it caused me problems, and for right now drop -vm -quiet and -fs and see if it works

  5. #35
    Join Date
    Oct 2007
    Posts
    2
    Has there been any update of mythtivo to run on the latest version of mythtivo 20.2?

    Thanks
    -Ringo

  6. #36
    Join Date
    Oct 2004
    Posts
    87
    Quote Originally Posted by ringo View Post
    Has there been any update of mythtivo to run on the latest version of mythtivo 20.2?

    Thanks
    -Ringo
    I believe the program has been abandoned by the developer, I wrote the changes to make it work with 19. What error messages are you getting I might be able to fix it.

  7. #37
    Join Date
    Jul 2007
    Location
    RTP, NC
    Posts
    4

    MythTivo on MythTV 0.21?

    Okay, I've searched far and wide and declare defeat... I'm trying to compile mythtivo for mythtv 0.21, and it isn't working. I'm running Mythbuntu Hardy 8.04.

    I followed the steps above, having to install enough packages to meet the various prerequisites; created a symbolic link in /usr/include/mythtv/mythtv which points to libmythui; modified the files as indicated, etc etc.

    Anyway, when I run 'make' here is the error:

    Code:
    g++ -c -pipe -Wall -W -O3 -march=i586 -fomit-frame-pointer -D_REENTRANT -fPIC  -D_GNU_SOURCE -DPREFIX=\"/usr\" -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I/usr/include -I/usr/local/include -I/usr/include/qt3 -I/usr/include/mythtv -I/usr/include/qt3 -o main.o main.cpp
    main.cpp: In function 'int mythtivo_main(QSqlDatabase*, MythMainWindow*, const char*)':
    main.cpp:104: error: 'class MythContext' has no member named 'LoadSettingsFiles'
    It looks like the LoadSettingsFiles method is designed to load the mythtivo-settings.txt file, but that method is normally used for the mysql.txt settings. The method was made private, apparently inaccessible to mythtivo. I guess I could hard-code the settings using LoadSettings() methods one-by-one, but was wondering if someone had a better idea?

    Has anyone gotten mythtivo to work for MythTv 0.21? Any insights into LoadSettingsFile()?

    Thank you in advance!

  8. #38
    Join Date
    Oct 2007
    Posts
    1

    MythTivo on MythTV 0.21?

    jmw86069

    Sorry for the really late reply.
    You probably already have it working by now.
    I just migrated my 0.20 to 0.21 (WAF was high)
    I too followed all the great help in this thread and got stuck same as you.
    What I did was comment out
    // gContext->LoadSettingsFiles( "mythtivo-settings.txt" );
    in main.cpp and used sql to insert these into the settings table:
    insert into settings values ('default_helper','mplayer -vm -quiet -fs -sb 393216 -aop list=volnorm %s',NULL);
    insert into settings values ('tivo1','Family Room ; 127.0.0.1',NULL);
    insert into settings values ('showmaxrating','6',NULL);
    insert into settings values ('CombineNowShowing','no',NULL);

    Hope this helps someone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •