Up until now I only used my Sony Vaio laptop to run tmpgenc. It comes with it's own mpeg2 decoder that tmpgenc likes - so no problem. But then I tried to run tmpgenc on my old desktop and it wouldn't load mpeg2 files (like those from tystudio).

Well, I finally got it to work - here's how:

1) Install the Ligos MPEG2 decoder (I used the "K-lite codec pack")
2) Run the Ligos' configuration program "LSMpgCfg.exe". K-lite called it "MPEG-2" in the config folder it installed.
3) Uncheck "Use Overlay Mixer" (the first two options remain checked)
4) In tmpgenc's "VFAPI plugin" settings, move "Ligos" up to have the highest priority.

It took me longer than I'd like to admit to figure all that out!