Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Errors being posted in tverr log

  1. #1
    Join Date
    Jul 2003
    Posts
    669

    Question Errors being posted in tverr log

    I am having the below error posted over and over again in my tverr log...

    Aug 30 15:36:15 (none) Scheduler[174]: Scheduled recording 340956 expires before it starts
    Aug 30 15:37:24 (none) last message repeated 7 times
    Aug 30 15:38:29 (none) last message repeated 8 times
    Aug 30 15:39:34 (none) last message repeated 8 times
    ...

    I figure that one of the scheduled suggestions or the todo list is muged but how do I figure out which one?

    Or is this a "normal" abnormal error message?
    Four Hacked HDVR2's,
    One Still slightly confused Hacker,
    4 dogs, 8 cats, and 1 wife that is happy as long as I don't screw up her TiVo ...... Oh yeah two grandchildren that are the light of my life!

  2. #2
    Join Date
    Jul 2003
    Posts
    669

    Found the Culprit but what do I do now?

    It appears that this is being caused by an aborted attempt to upload a .ty file using mfs_ftp ...

    This record 340956 shows up in /mfs/Recording/Active when I browse with tivoweb...


    Question is, How do I nuke this entry?
    Four Hacked HDVR2's,
    One Still slightly confused Hacker,
    4 dogs, 8 cats, and 1 wife that is happy as long as I don't screw up her TiVo ...... Oh yeah two grandchildren that are the light of my life!

  3. #3
    Join Date
    Jul 2003
    Posts
    669

    Figured out how to fix it....

    Originally posted by tivomaster
    It appears that this is being caused by an aborted attempt to upload a .ty file using mfs_ftp ...

    This record 340956 shows up in /mfs/Recording/Active when I browse with tivoweb...


    Question is, How do I nuke this entry?
    Figured out the problem. It seemed that when the mfs_ftp upload aborted, the recording expire time was not posted correctly. It was posted with an expire date that was munged. What I did to fix it was to undelete the problem recording with tivoweb, then go in with Tivo NowShowing and change the expire to "keep until I delete", then go in with Tivo and delete it. That fixed the weird date. I am going to post this to the mfs_ftp tread in case this happens to someone else.
    Four Hacked HDVR2's,
    One Still slightly confused Hacker,
    4 dogs, 8 cats, and 1 wife that is happy as long as I don't screw up her TiVo ...... Oh yeah two grandchildren that are the light of my life!

  4. #4
    Join Date
    Jun 2003
    Posts
    55
    I had the same problem. Your fix worked great! Thanks for posting your findings!!!

  5. #5
    Join Date
    Jul 2003
    Location
    NYC
    Posts
    339
    Code:
    Jul 25 13:58:42 (none) FsRegion[133]: Free space too badly fragmented
    Jul 25 20:49:07 (none) FsRegion[133]: Free space too badly fragmented
    Jul 25 21:15:41 (none) FsRegion[133]: Free space too badly fragmented
    hmmm.... I get this....

  6. #6
    Join Date
    Oct 2003
    Location
    Kenosha, WI
    Posts
    110
    I'm having a similiar issue, but MFS_FTP is not running.

    Can this be caused by anything else?
    Oh No - Mr Bill!!!

    1 HDVR2 w/ 120 gig drive (hacked a long time ago, sleeper tivoscripts v1.02, running v4.x w/ HMO (Thanks Haderk!) - suits my purposes well.)

    1 DSR7000 w/ 120 gig drive - Currently 3.1.1b. Want to move it to HMO v4.0 WITHOUT sleeper (still testing killhdinit and other variants).

    2 DVR39s - just to play with and break stuff. Also just using one for MRV off the other tivos!

  7. #7
    Join Date
    May 2004
    Posts
    34
    I'm seeing the same problem, and first thought it was because of mfs_ftp. I then noticed that when viewing shows that were recorded normally on my tivo, that they had the expire date set back in 2001. So now I'm thinking it may be related to something else, I'm just not sure what yet.

    This is on a HDVR2 running 4.0.1b-02-2-240, killhdninitrd, hmo superpatch.

    I started noticing the problem when I transfered my season passes using tivowebplus 1.0. I'm thinking the script that did the transfer messed up something. I'm going to try and rebuild the system and see if I can isolate the issue.

    -steve

  8. #8
    Join Date
    Aug 2004
    Location
    Austin, TX
    Posts
    42
    I seem to be getting this on all my mfs_ftp inserts, saved and deleted. It was easy enough to fix the saved ones, but this repair is tedious.

    This also looks like a good place to start programming, so if noone beats me to it I may try to write a utility to find recordings with invalid experation dates and fix it. Unfotunately it won't be till this weekend, so I am sure someone will do this first.

    Charlie

  9. #9
    Join Date
    Jul 2004
    Posts
    26
    Quote Originally Posted by chedlin
    I seem to be getting this on all my mfs_ftp inserts, saved and deleted. It was easy enough to fix the saved ones, but this repair is tedious.

    This also looks like a good place to start programming, so if noone beats me to it I may try to write a utility to find recordings with invalid experation dates and fix it. Unfotunately it won't be till this weekend, so I am sure someone will do this first.

    Charlie
    I would be very interested in the utility seeing how I'm getting the same error. I just tried to delete the shows that mfs_ftp'd back to my Tivo once I swapped out the drive. I'll have to see if that fixes my problem, otherwise I'm will to try out your util.

  10. #10
    Join Date
    Aug 2004
    Location
    Austin, TX
    Posts
    42
    Quote Originally Posted by badgerbalm
    I would be very interested in the utility seeing how I'm getting the same error. I just tried to delete the shows that mfs_ftp'd back to my Tivo once I swapped out the drive. I'll have to see if that fixes my problem, otherwise I'm will to try out your util.
    Deleting won't work, manually setting the expiration date ("Keep unil") will (from now playing with the remote or TiVoWeb). Still planning on it this weekend, but my life is upside down right now, so it may not work out. Chances are decent though.

    CHarlie

  11. #11
    Join Date
    Aug 2004
    Location
    Austin, TX
    Posts
    42
    I have a script that will reset the expiration date on the invalid shows. There is a bug in mfs_ftp that causes it to get set to an invalid value. I have seen other posts referencing it, so it should be fixed in the next release.

    Here is a script that you can run after inserts to clean things up.

    Just copy it anywhere into the tivo (I used /var/hack), type chmod +x fix_expdate.tcl, then run it. It will report the fsids it fixes on std_out.

  12. #12
    Join Date
    Aug 2004
    Location
    Austin, TX
    Posts
    42
    If anyone finds that utility usefull I would love to hear about it. It was my first attempt at programming with tivosh.

    It worked perfectly on my two TiVos.

    Charlie

  13. #13
    Join Date
    Nov 2001
    Location
    Southern California
    Posts
    938
    Quote Originally Posted by chedlin
    If anyone finds that utility usefull I would love to hear about it. It was my first attempt at programming with tivosh.

    It worked perfectly on my two TiVos.

    Charlie
    Works outstanding for me on a T60 @ 3.1.0c2
    My tverr log was over 28,000 lines long due to these errors

    Thanks
    HayreAss

  14. #14
    Join Date
    Jan 2004
    Location
    West Sussex, England
    Posts
    15
    Quote Originally Posted by chedlin
    If anyone finds that utility usefull I would love to hear about it. It was my first attempt at programming with tivosh.
    Modified it a little to fix a problem on my TiVo where TiVoWeb had set an expiration date less than the StopDate.

    Thanks!
    Latest versions of my TiVoWeb modules: Now Playing with Folders and Sort; What's On; Show series conflicts; Showcase; Sky red dot remover etc are here.

  15. #15
    Join Date
    Feb 2003
    Posts
    411
    Quote Originally Posted by chedlin
    If anyone finds that utility usefull I would love to hear about it. It was my first attempt at programming with tivosh.

    It worked perfectly on my two TiVos.

    Charlie
    Thanks, My logs aren't growing uncontrolable anymore.
    Mikey

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •