Results 1 to 8 of 8

Thread: 51killer not working on HR10-250

  1. #1
    Join Date
    May 2002
    Posts
    16

    51killer not working on HR10-250

    Hi,

    Having a bit of a problem with error 51. I'm mod'ing a HR10-250 using the S2 3.1.5 kernel on PTV's $5 CD, and I run 51killer.tcl:

    -------------------
    #!/tvbin/tivosh
    EnableTransactionHoldoff true
    set db [dbopen]
    RetryTransaction {
    set obj [db $db open "/State/Media"]
    dbobj $obj remove DiskConfiguration
    }
    -------------------

    as: tivosh 51killer.tcl

    I get no output from that script, but after I run it there's a delay before the prompt comes back (so it seems it is running). I know this isn't a ^M issue. After a reboot I still have the 51 error.
    Service Number showing up as not avail (000000...)

    Is the script not working or does it not work on my unit/kernel?? I really don't want to have to resort to clear and delete every time the unit gets a software update and I re-hack it (and I would like to get/participate in software updates).

    Speaking of service updates, please confirm my understanding of how this works: when I get a software update my hacks will go away and I will still be able to watch recorded video. But when I update the kernel again (like I have here) even if 51killer works, I'll still have no access to the recordings since the key gets re-created. So, in effect if hacking is the goal, every software update means a clearing of all my recordings. And no, I don't have access to older kernels of mine, this unit is fresh out of the box.

    Thanks
    Last edited by boody; 01-29-2006 at 01:41 PM.

  2. #2
    Join Date
    Jan 2002
    Posts
    5,601
    Sorry, I can't help you with 51killer.

    On the upgrade issue, you're wrong. The procedure I use:

    Block software upgrades. When the new software version is available modify installSw.itcl to prevent the reboot, then run it to install the new software. Rehack the new software, then reboot. Watch your old recordings, new recordings, or live TV as desired.

    PlainBill
    There's a difference between needing help, and just being plain ole' lazy.

    "You cannot teach a man anything. You can only help him find it for himself." Galileo Galilei (1564-1642)

    HR20-700 with 2 TB, HR22-100, HR22-100, HR22-100, HR23-100 all running 0x5cd and networked.

  3. #3
    Join Date
    Nov 2004
    Posts
    33
    Make sure that you haven't edited the file and introduced characters that are causing problems. As I recall, the 51killer.tcl script that I've seen has some extra verbage in it that appears to be missing from yours. In other words, get the original, transfer it to the TiVo in binary mode, and execute it.

  4. #4
    Join Date
    May 2002
    Posts
    16
    I did move the original over, the one that prompts you to enter yes or no and when I type yes it comes back with "Not changing anything"

    I edited that on the tivo to remove the prompt and it worked like the bare bones script I pasted above - no output and no joy after reboot.
    Last edited by boody; 01-29-2006 at 05:44 PM.

  5. #5
    Join Date
    May 2002
    Posts
    16
    More fun, I finally got it to call in via modem and afterwords, the 51 error came up again. Previously I had gotten rid of it by doing a clear & delete. This is a vicious cycle - c&d to get rid of 51 -> need to dialin to activate dvr -> error 51. Help!!!

    UPDATE: This is weird: so on a whim I ran the original version of 51killer.tcl again, and this time:

    Code:
    51killer.tcl by AlphaWolf_HK
     
    This script will clear the error #51 nag from a hard drive that was transfered
    from one tivo to another.
     
    WARNING: Because the key generated for this nag is also used as part of the
    encryption process for tystreams, any encrypted (scrambled) streams that you
    currently have on the disk will be rendered useless!
     
    Do you want to continue? (type yes or no):
    yes
    Done! Reboot for the changes to take effect.
    bash-2.02# reboot
    When it came back up, error 51 was still there.

    Why all of a sudden is 51killer script working, but not having any effect?

    The sequence from the beginning was this:

    (box is new)
    - software: 3.1.5f
    - setup, modem activate/dial in, made normal call, everything is fine
    - cracked the box, made a backup
    - restored the backup with 275 swap and tpip'd ONTO A NEW 300GB DRIVE (is that part of the 51 problem here - the orig drive isn't the one being hacked). All subsequent activity is happening to new drive:
    - dd'd PTV's 3.1.5 kernel to hdc6
    - mod'd rc.sysinit.author to get network/telnet
    - booted up, network ok
    - tried 51killer to no avail
    - clear & delete
    (51 error gone, but now need to re-dial in)
    - dialed in (no reboot)
    - 51 error back immediately
    - 51killer now works
    (reboot)
    - 51 still there
    - clear & delete
    (service # still reads 0000000...)
    - ran fakecall
    - ran 51killer
    (reboot)
    - 51 still there
    Last edited by boody; 01-29-2006 at 08:06 PM.

  6. #6
    Join Date
    Jan 2004
    Location
    Noo Hampsha
    Posts
    767
    What software version are you using?
    Steve

  7. #7
    Join Date
    Jan 2006
    Posts
    6
    having the same problem (not changing anything).
    Series2
    software version: 7.2.1a-oth-01-2-140
    No problems with telnet and ftpd

  8. #8
    Join Date
    May 2002
    Posts
    16
    post mortem: this was all caused by

    /bin/bash </dev/ttyS3 >& /dev/ttyS3 &

    which I innocently and ignorantly put in rc.sysinit.author

    that was messing up the crypto chip/program and the rest is history.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •