Results 1 to 10 of 10

Thread: Lockups on s2 unit. Remote stops working, tivowebplus 1.1 stops working

  1. #1
    Join Date
    Oct 2004
    Posts
    268

    Lockups on s2 unit. Remote stops working, tivowebplus 1.1 stops working

    I cannot say if the two are related, as I don't "use" TWP that often, but it's always running.

    I've read every thread I could find and didn't come up with an answer, so I'll try here.

    Tonight, I was watching a show, went to pause it (after having skipped ahead through some commercials), and it wouldn't pause. None of the DTivo remote functions would work.

    I could still telnet to it, but not use TWP. I killed TWP and of course, it rebooted.

    Dtivo SD-DVR40 (with a 120gig).
    Hacked by hand using killhdinitrd, 2.4.4 kernel, 3.1.1c software
    upgradesoftware=false
    hackman
    tnlited
    bash
    Tivoftpd.mips
    tserver (not running)
    backported USB2.0 drivers by Jamie and ADH.
    FA120 Ethernet adapter
    elseed
    vserver (non-functional, just commented it out of rc.sysinit.author)
    endpadplus.tcl

    Tivoweb.log had nothing useful (just info since the recent startup, didn't check while locked up).

  2. #2
    Join Date
    Jan 2004
    Location
    n.h. usa
    Posts
    955
    Event bug.. search for it.. known issue

    usually you need something waiting on events though\


    which version of twp

  3. #3
    Join Date
    Oct 2004
    Posts
    268
    twp 1.1 beta.

    However, the event bug seems to be referred to a lot, but not explained what the issue itself is. From my reading, it's a tivoapp bug that gets exposed by twp and other hacks. But WHAT in TWP makes the bug manifest itself? Is there a way to avoid the issue (such as restarting TWP after each use)? I have found that I can set up cron and a cron job to restart it, but again, that seems like a lot of trouble just to keep the thing running. I didn't try it, but will wget -o http://localhost/restart/0 (and I understand the syntax is probably wrong, but I ran across that last night in correct syntax) from a telnet session resolve the issue once TWP and the remote stop functioning? I can't imagine so since it's using TWP, but wasn't sure what part of TWP hung or if the whole process did, etc.

  4. #4
    Join Date
    Oct 2004
    Posts
    69
    >elseed

    Next time it locks up, try unplugging the phone line.
    If that unlocks it, let me know, because I am having the same problem, and belive it is elseed
    As soon as I unplug the phone line, its free...
    HDVR2 4.0

  5. #5
    Join Date
    Sep 2004
    Posts
    35

    Event Bug - 4x Non-Rid / init_framework /killhdinit

    The Remote locks up and the remote will not work at all, happens daily. Looks like the event-bug, but I though this was fixed in 4.x??? A little history; this box was running sleeper no problems until the hard drive went bad. So a new hard drive, no sleeper this time, I used the below files to setup the system, and now it appears that I have the event bug

    Anyone have any suggestions or info before I dive back in to see what is going on?

    HDVR2 S2 NON-RID
    120GB HD
    PTV Instantcake
    PTV 3.1.1c pre killhdinit kernel
    Init_Framework files
    Tivotools
    Superpatch-4all-NuxKase
    Last edited by inet22; 11-23-2004 at 08:28 PM.

  6. #6
    Join Date
    Jan 2002
    Posts
    1,777
    Merged two "possible event bug lockup on 4.x" threads.

    Things to look at after the remote has locked up:

    - /var/log/{tvlog,tverr}
    - can you launch another instance of tivosh? if not, what happens? can you "mls /" in this new session?
    - see anything interesting if you "strace -p" the eventswitcher pid? nanosleep of death? (google for it)
    - are you using sendkey in any capacity? are you using an old 3.x sendkey? what if you stop using sendkey?
    - disable each tcl script you're using, one by one, until it goes away (including individual TWP modules if necessary)
    - if you used the Sleeper ISO, don't forget to nuke those ridiculous backdoor and sps30 scripts - they produced keypress events

    Expect to spend at least a week or two isolating the problem. That's the nature of intermittents.

  7. #7
    Join Date
    Oct 2004
    Posts
    268
    By the way, I'm on 3.1.1c, not 4.x. Here's my ps... there's no "issue" right now, just some things that bug me.

    First, ADH, is /tvbin/switcherstart -m -F the one you're wanting the strace on? Second, why so freaking many dssappAV processes? Is this normal (DTivo S2)?

    I do not, to my knowledge, have sendkey running, based on the following
    (none):/$ ls sendkey -R
    ls: sendkey: No such file or directory



    1 0 SW init
    2 0 SW [keventd]
    3 0 SW [kswapd]
    4 0 SW [kreclaimd]
    5 0 SW [bdflush]
    6 0 SW [kupdated]
    7 0 SW /bin/bash /etc/rc.d/rc.sysinit
    46 0 696 S /tvbin/dssappAV
    48 0 696 S /tvbin/dssappAV
    49 0 696 S /tvbin/dssappAV
    51 0 696 S /tvbin/dssappAV
    52 0 696 S /tvbin/dssappAV
    53 0 696 S /tvbin/dssappAV
    54 0 696 S /tvbin/dssappAV
    55 0 696 S /tvbin/dssappAV
    65 0 40 S syslogd -p /var/dev/log -m 10000
    67 0 SW klogd
    74 0 124 S /tvbin/switcherstart -m -F
    75 0 840 S /tvbin/mfsd
    76 0 72 S fancontrol
    102 0 SW /tvbin/mcp
    103 0 SW /bin/bash /etc/rc.d/rc.sysinit.author
    105 0 SW /bin/bash
    108 0 SW [khubd]
    109 0 244 S PipeListener
    110 0 388 S Mcp event hdlr
    111 0 516 S /tvbin/tcphonehome
    114 0 SW FsMpStream
    116 0 232 S PipeListener
    117 0 200 S PhoneHome event hdlr
    120 0 564 S /tvbin/ApgManager
    121 0 620 S PipeListener
    122 0 1052 S ApgManager event hdlr
    123 0 3740 S ApgWriter
    124 0 2536 S ApgReaderThread
    125 0 1832 R /tvbin/dbgc-mcp
    126 0 228 S PipeListener
    127 0 692 S /tvbin/myworld
    128 0 324 S PipeListener
    129 0 2120 S TmkTaskManager-myworld
    132 0 456 S FsMpStream
    133 0 SW CamBot
    134 0 648 S CamManager
    135 0 696 S /tvbin/dssappAV
    136 0 696 S /tvbin/dssappAV
    137 0 696 S /tvbin/dssappAV
    138 0 696 S /tvbin/dssappAV
    139 0 696 S /tvbin/dssappAV
    140 0 696 S /tvbin/dssappAV
    141 0 696 S /tvbin/dssappAV
    142 0 696 S /tvbin/dssappAV
    143 0 696 S /tvbin/dssappAV
    144 0 696 S /tvbin/dssappAV
    145 0 696 S /tvbin/dssappAV
    146 0 696 S /tvbin/dssappAV
    147 0 696 S /tvbin/dssappAV
    148 0 696 S /tvbin/dssappAV
    151 0 SW TmkSinkMixAud
    156 0 20 S /hacks/tnlited 23 /bin/bash -login
    158 0 SW /hacks/tivoftpd.mips
    161 0 880 S tivosh /tivowebplus/httpd-tt.tcl
    163 0 792 S TmkClipCache0
    164 0 612 S TmkClipCache1
    165 0 184 S TmkClipCache2
    166 0 188 S TmkClipCache3
    167 0 720 S TvMomBrcm7020Sink
    168 0 388 S ReadAheadHelper167
    169 0 SW TvMomBrcm7020Sink
    170 0 SW ReadAheadHelper169
    171 0 920 S Mediaswitch0
    173 0 744 S Mediaswitch1
    174 0 1020 S TvVideoManager
    176 0 2884 S TvRecorder
    179 0 292 S Scheduler
    181 0 468 S Prioritizer
    182 0 496 S EventLog event handler
    183 0 584 S PvrMain
    185 0 2136 S ApgSmartSorter
    186 0 SW bus handler
    187 0 760 S ContextMgr event handler
    188 0 SW /hacks/vserver
    190 0 344 S /bin/bash /hacks/elseed_forever.sh
    2148 0 SW /bin/bash -login
    2160 0 360 D tserver
    5474 0 1248 S /bin/bash -login
    5576 0 448 S sleep 5
    5577 0 716 R ps

  8. #8
    Join Date
    Jan 2002
    Posts
    1,777
    Quote Originally Posted by snowman
    First, ADH, is /tvbin/switcherstart -m -F the one you're wanting the strace on? Second, why so freaking many dssappAV processes? Is this normal (DTivo S2)?
    Yes. Threads. Yes.

  9. #9
    Join Date
    Sep 2004
    Posts
    35
    My problem was not the event bug, it was a bad hard drive. Posted before I investigated. New hard drive installed all is working fine now right now. Thanks for the help.

  10. #10
    Join Date
    Oct 2004
    Posts
    268
    Quote Originally Posted by alldeadhomiez
    Yes. Threads. Yes.
    Thanks man. I didn't realize that there could be that many threads running. I figured 3 at best... one per tuner recording and one playback. I thought maybe it wasn't recycling the used threads.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •