Page 14 of 20 FirstFirst ... 41213141516 ... LastLast
Results 196 to 210 of 289

Thread: MFS_FTP issues

  1. #196
    Join Date
    Jun 2004
    Posts
    29
    I'm having trouble uploading (like TivoTyro above) with the same error:
    Code:
    07:13:47:AM - 226 Transfer complete.
    07:13:47:AM - 200 Type set to I
    07:14:09:AM - 200 PORT command successful.
    07:14:10:AM - 150 Opening BINARY mode data connection for "{{Lost}{2005-11-30}{W
    hat Kate Did}{02.00 AM Wed Nov 12, 2003}{DT7}.tmf}"
    bgerror invoked with error
    
     " can't read "TmkEvent::EVT_DATA_CHANGED": no such variable "
    
    re-initializing mfs_ftp
    
    close the current ftp connection and simply open another
    
    "core dump" :p
    
    info(version): 1.2.9p
    info(tswv): 6.2-01-2-351
    info(dbl): 0
    info(ithrottle): 2
    info(insert_priority): 10
    info(multithreaded): 0
    info(saveuntil): suggestion
    info(name_detail): 5
    info(bjuggle): 0
    info(active): 0
    info(ac_interval): 1800
    info(gatewayip): 127.0.0.1
    info(gatewayport): 3105
    
    
    catch close lastsock val ""
    Any ideas? Does anyone know the right combination of mfs_ftp files to use? I've tried a few.

  2. #197
    Join Date
    Jun 2004
    Posts
    29
    Did more digging and found my answer here:

    http://www.dealdatabase.com/forum/sh...41&postcount=7

  3. #198
    Join Date
    Aug 2003
    Location
    Southlake, Texas
    Posts
    277

    linux players report wrong show length for my mfs_ftp shows

    I am using mfs_ftp to get a tmf file. I convert the tmf file to a mpg and
    can play it on different linux players ( mplayer, vlc, xine, etc ) They each
    act differently but all seem to have issues with the show length. A 30 minute
    show will say that it's 15 minutes in length.

    I think that it has something to do with the fact that I untar the tmf file and
    end up with part01.ty, part02.ty, part03.ty, etc. and I cat these into a 'full.ty'
    file before I avsplit it. I think that the length corresponds to the first, part01.ty
    file.

    Also... if I get a ty or ty+ file... the players listed above (even mplayer
    with vstream support ) only play the first 15 minutes of the show and then
    exit out. They only play the 'part01.ty' portion of the ty or ty+ stream.

    The only way I've been able to play the full stream us to get the tmf file,
    un-tar it, cat all of the partxx.ty files and then use that created, ty file to
    split and mux.

    Is it just me or what?

    I've got the latest ( I think ) mfs_ftp and mfs_utils.

    Thanks - jack

  4. #199
    Join Date
    Apr 2003
    Posts
    2,402
    Quote Originally Posted by EvilJack
    I am using mfs_ftp to get a tmf file. I convert the tmf file to a mpg and
    can play it on different linux players ( mplayer, vlc, xine, etc ) They each
    act differently but all seem to have issues with the show length. A 30 minute
    show will say that it's 15 minutes in length.

    I think that it has something to do with the fact that I untar the tmf file and
    end up with part01.ty, part02.ty, part03.ty, etc. and I cat these into a 'full.ty'
    file before I avsplit it. I think that the length corresponds to the first, part01.ty
    file.

    Also... if I get a ty or ty+ file... the players listed above (even mplayer
    with vstream support ) only play the first 15 minutes of the show and then
    exit out. They only play the 'part01.ty' portion of the ty or ty+ stream.

    The only way I've been able to play the full stream us to get the tmf file,
    un-tar it, cat all of the partxx.ty files and then use that created, ty file to
    split and mux.

    Is it just me or what?

    I've got the latest ( I think ) mfs_ftp and mfs_utils.

    Thanks - jack
    I'd make sure about the latest mfs_utils. There once was a bad build of mfs_stream or mfs_export that would insert some text between (maybe at the end?) of the parts.

    ew

  5. #200
    Join Date
    Jul 2004
    Posts
    7

    Incomplete ty dl, but ty+ okay?

    What's up with that?

    S1DTiVo w/cachecard.

    Fire up mfs_ftp pulls down a half hour show in ty format (approx 525MB) no problems, but choked on a 1 hr (approx 850mb). The hour show pulled down in ty+ with no problems.

    how very odd, to say the least.

    The pull of ty isn't resolved, but I did get my show in ty+.

  6. #201
    Join Date
    Mar 2004
    Posts
    2
    Using mfs_ftp 1.2.9p on a S1 standalone and it crashes the tivo if I have more than 255 shows in the ty directory listing. anyone else have this problem and better yet, know how to fix it?

    Right now I'm having to pull up the now showing list via tivoweb and delete shows until I have less than 255 (had 389 until the last need to ftp a show from the tivo).

    Thanks

  7. #202
    Join Date
    Feb 2004
    Posts
    152

    Large show count crashes...

    Quote Originally Posted by Varelse
    Using mfs_ftp 1.2.9p on a S1 standalone and it crashes the tivo if I have more than 255 shows in the ty directory listing. anyone else have this problem and better yet, know how to fix it?

    Right now I'm having to pull up the now showing list via tivoweb and delete shows until I have less than 255 (had 389 until the last need to ftp a show from the tivo).

    Thanks
    Check this out...
    http://www.dealdatabase.com/forum/sh...postcount=1044

  8. #203
    Join Date
    Mar 2004
    Posts
    2
    thanks for posting this patch but what is the procedure to install it? I FTP'd it into the mfs_ftp dir but it isn't being called.

    EDIT: nevermind. Didn't think to stop and start the FTP server. Working fine now.
    Last edited by Varelse; 03-28-2006 at 09:19 AM.

  9. #204
    Join Date
    May 2006
    Posts
    12

    35 S2SA transfers 0 bytes

    I have 2 SD-DRV40's running 6.2, 1 HR10-250 running 3.15f, and 2 TCD240xx units running 7.2.2. For all five machines I downloaded mfs_ftp.tar from here and followed the instructions on installing it. I then got the S2 binaries (mfs-utils_bin.mips-20050604.tar.bz2) from here and copied the mfs_{export,import,stream,tarstream,uberexport} files to the var/mfs_ftp directory of the machines. I also created a tzoffset.txt file to avoid that issue. (all my transfers have been done in binary mode, and I use smart ftp as my client).

    At least for the time being all I want to do is export from each Tivo to my laptop. This works for all three of my D units but does not work for either SA unit.

    I've been doing alot of searching and reading though posts but have not found anything yet that helps. If someone could please lead me in the right direction I would really appreciate it.


    from the log... (and yes all the mfs filles are executable)

    07:09:24:PM - 150 About to open data connection.
    bgerror invoked with error

    " couldn't execute "/var/mfs_ftp/mfs_tarstream": no such file or directory "

    re-initializing mfs_ftp

    close the current ftp connection and simply open another

    "core dump"

    info(version): 1.2.9p
    info(tswv): 7.2.2-oth.K1-01-2-140
    info(dbl): 0
    info(ithrottle): 2
    info(insert_priority): 10
    info(multithreaded): 0
    info(saveuntil): suggestion
    info(name_detail): 2
    info(bjuggle): 0
    info(active): 0
    info(ac_interval): 1800
    info(gatewayip): 127.0.0.1
    info(gatewayport): 3105

  10. #205
    Join Date
    Dec 2005
    Posts
    296
    did you apply the patches?

    Quote Originally Posted by mfs-utils instructions
    ....
    The patches can be applied on your TiVo with "patch < mfs_ftp.jamie.patch" while in your mfs_ftp directory, if you have the busybox patch program installed. If you want both patches, apply the jbuehl patch first, then the jamie patch......
    inside mfs-utils_noarch-20050604.tar.bz2 (attached in the same post as the mfs-utils_bin.mips-20050604.tar.bz2) theres two files:

    Code:
    mfs_ftp.jbuehl.patch
    mfs_ftp.jamie.patch

    send them to your mfs_ftp folder, telnet in and type these two commands in your mfs_ftp dir (jbuehl patch first):

    Code:
    patch < mfs_ftp.jbuehl.patch
    and then

    Code:
    patch < mfs_ftp.jamie.patch
    Last edited by drez; 06-15-2006 at 10:46 PM.

  11. #206
    Join Date
    Nov 2004
    Location
    Gurnee, IL
    Posts
    2,384
    I don't think that's it...look at the error msg. It cannot find mfs_tarstream. Is mfs_tarstream present?
    --
    Christopher D. Heer
    Quote Originally Posted by Oscar Wilde
    Perhaps, after all, America never has been discovered. I myself would say that it had merely been detected.

  12. #207
    Join Date
    Dec 2005
    Posts
    296
    Quote Originally Posted by cheer
    I don't think that's it...look at the error msg. It cannot find mfs_tarstream. Is mfs_tarstream present?
    i think it is because i read through the jamie patch and one of the lines is:

    Code:
    -set pout [open "|$info(path)/mfs_tarstream -x -s $parts >@$info(dc) 2>/dev/null " w]
    +set pout [open "|$info(path)/mfs_uberexport -tx $parts >@$info(dc) 2>/dev/null " w]

    also, the mfs_tarstream in mfs-utils is only a 2KB script file and the mfs_tarstream that comes with the original mfs_ftp is a 70KB binary

  13. #208
    Join Date
    Aug 2004
    Posts
    4,075
    I've been suggesting lately that people don't apply the patch. It only helps insertion performance, not extraction, and bcc pointed out some issues here. The issue relates to tcl buffering and passing a socket back and forth between tcl and an external C program. There doesn't seem to be an easy fix, and it's one of those things that sometimes works and sometimes doesn't depending on factors that are out of my control.

  14. #209
    Join Date
    May 2006
    Posts
    12
    Quote Originally Posted by cheer
    I don't think that's it...look at the error msg. It cannot find mfs_tarstream. Is mfs_tarstream present?
    Yes, it it present - here is a directory listing. Sometimes it's mfs_stream that is reported as missing (depends on what type of file I try to download).

    -rw-r--r-- 1 root root 0 Sep 8 2003 abort.doc
    -rwxr-xr-x 1 root root 22 Jun 18 2003 abort_toggle.sh
    drwxr-xr-x 2 root root 4096 Jun 16 03:28 cache
    prw-r--r-- 1 root root 0 Sep 8 2003 fifo
    lrwxrwxrwx 1 root root 11 Jun 16 02:17 ftp -> mfs_ftp.tcl
    -rwxr-xr-x 1 root root 33 Sep 15 2003 ftpf.sh
    -rwxr-xr-x 1 root root 34 Sep 15 2003 ftpf21.sh
    -rw-r--r-- 1 root root 439 Dec 18 2003 license.txt
    lrwxrwxrwx 1 root root 13 Jun 16 02:17 log -> port.3105.log
    -rwxr-xr-x 1 root root 840 Jun 16 02:18 mfs_export
    -rwxr-xr-x 1 root root 53428 Sep 13 2003 mfs_ftp.tcl
    -rwxr-xr-x 1 root root 67672 Jun 16 02:18 mfs_import
    -rwxr-xr-x 1 root root 150705 Aug 28 2003 mfs_stdinsert
    -rwxr-xr-x 1 root root 637 Jun 16 02:18 mfs_stream
    -rwxr-xr-x 1 root root 1331 Jun 16 02:18 mfs_tarstream
    -rwxr-xr-x 1 root root 152232 Jun 16 02:18 mfs_uberexport
    -rw-r--r-- 1 root root 2144 Jun 16 03:29 port.3105.log
    -rwxr-xr-x 1 root root 17625 Dec 18 2003 readme.txt
    drwxr-xr-x 2 root root 1024 Jun 16 02:17 scramble_utils
    drwxr-xr-x 2 root root 1024 Sep 13 2003 seasonpass
    lrwxrwxrwx 1 root root 12 Jun 16 02:17 set -> settings.tcl
    -rwxr-xr-x 1 root root 39039 Sep 8 2003 setpri
    -rwxr-xr-x 1 root root 389 Jun 16 02:18 settings.tcl
    -rwxr-xr-x 1 root root 3070 Dec 18 2003 tzoffset.tcl
    -rwxr-xr-x 1 root root 26 Jun 16 02:18 tzoffset.txt
    Last edited by Sirshagg; 06-15-2006 at 11:36 PM.

  15. #210
    Join Date
    May 2006
    Posts
    12
    Quote Originally Posted by drez
    did you apply the patches?
    No, they were not applied.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •