While I am able to grab .ty files from my Series2 using mfs_ftp and so on, and I can use the command-line tytools stuff to fix them up for DVD, I'd like to be able to edit, which means I need indexing (right?). I have installed the tyindex and tyserver onto my tivo and they are the S2 binaries. The tyindex updates the 'nowshowing' file, but then fails at the end of the first file index with a segfault. I have no way of knowing if it is looking for something it can't find, or whatever, but I'm at my wits end here --- tyindex sure doesn't give any info.

I've got these installed at /var/index on the tivo. Here is a sample output:

Code:
tivo:/var/index$ ./tyindex 
Classic
Found 14 shows.
/var/index/index/481110 not avalible
/var/index/index/511582 not avalible
/var/index/index/511581 not avalible
/var/index/index/511580 not avalible
/var/index/index/511577 not avalible
/var/index/index/505792 not avalible
/var/index/index/481114 not avalible
/var/index/index/481113 not avalible
/var/index/index/453319 not avalible
/var/index/index/476153 not avalible
/var/index/index/453096 not avalible
/var/index/index/476158 not avalible
/var/index/index/476135 not avalible
/var/index/index/452681 not avalible
Need to make 481110 index 
Malloc the FSID 
Input source: 514550
Still indexing chunk 400 of 1182 
Still indexing chunk 600 of 1182 
Still indexing chunk 800 of 1182 
Still indexing chunk 1000 of 1182 
Segmentation fault
and
Code:
tivo:/var/index$ ls -lsF tyindex
 735 -rwxrwxr-x   1 0        0          747828 May 26 23:02 tyindex*
Anyone got any clue?

Thanks