Results 1 to 3 of 3

Thread: HR10-250 Support Question

  1. #1
    Join Date
    Aug 2004
    SF, CA, US

    HR10-250 Support Question

    Complete Newbie Support Question here:

    I've backed up my HR10-250's drive. Tested it and it works, and stashed the original for safe keeping.

    Then put the drive in a PC, booted a big disk support mfstools2 CD and ran

    killhdinitrd /dev/hdc6

    I got an indication that the patch was successful.

    I then mount /dev/hdc7 /mnt/tivo

    Write the following file as
    In directory: /mnt/tivo/etc/rc.d

    #install usb and ethernet drivers
    insmod /lib/modules/usbcore.o
    insmod /lib/modules/hcd.o
    insmod /lib/modules/ehci-hcd.o
    insmod /lib/modules/ax8817x.o
    sleep 10

    #configure ethernet
    ifconfig eth0 broadcast netmask
    sleep 100

    tnlited 23 /bin/bash -login &


    I then copy tivoftpd.mips to the /mnt/tivo/etc/rc.d directory.

    When I put the drive back in the TIVO and boot it (with a Netgear FA120 plugged into a USB port) it boots correctly and functions correctly, but there is no power or link indication on the FA120.

    So, I am of course wonder what might have gone wrong and what I can do to check it. Is it possible that I ran the killhdinitrd on the wrong partition? Or that maybe I installed the in the wrong partition? How do you figure out which partition pair the tivo is currently booting from?

    Any pointers would be great appreciated. Thanks

  2. #2
    Join Date
    Feb 2002
    If you did a backup and restore then only the active partitions were copied to your new drive. The inactive partitions do not get copied when using MFS Tools unless you do a dd copy of the specific partitions.

    Now for the $64K question - Did you make your new file executable (i.e. chmod 755 If not then your HDTivo would still boot normally but your hacks would never run since the file would not have been executed.
    Please don't PM me or any other members looking for personal assistance. You'll do better by posting (after you've exhausted the search feature, of course) and taking advantage of the collective expertise of the membership instead of a single individual that may or may not be able to help you. Thank you and enjoy your stay at DDB!

  3. #3
    Join Date
    Aug 2004
    SF, CA, US
    12 executable? I think so....

    No, I didn't chmod the, but thats only because after I copied it over I did an ls-la and foudnd that it already was executable (that is 'x' is the last character of the attributes.) Could the ls have been wrong? Might I have to chmod it anyway? Is that not what the 'x' means? Do I have anymore stupid questions? No...

    Thanks very much for the help,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts