Results 1 to 4 of 4

Thread: HR10-250 hd backup takes forever

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Nov 2004

    HR10-250 hd backup takes forever

    heya, I'm trying to follow MarkZ's "Newbie guide to the Hughes HR10-250" (thread), and when I go to test my backup after step 1, the directivo does not boot.

    I then tried to just perform a hard disk backup as described in the Hinsdale-howto . When I run the mfsbackup command
    mfsbackup -f 9999 -6so /mnt/dos/tivo.bak /dev/hdb (yes I need hdb, not hdc)
    the process gets up to
    Scanning source drive. Please wait a moment.
    then runs for a few more seconds, then falls into a "disk sleep" state according to /proc/###/status.

    I've tried both the MFSTools 2.0 CD with large disk support (link here), and the standard "MFSTools 2.0" CD without large disk support.

    Any ideas what the heck I'm doing wrong?

    thanks in advance!

  2. #2
    Join Date
    Dec 2001
    I think this is the command you need:

    mfsbackup -f 9999 -1so /mnt/dos/hd_tivo.bak /dev/hdb

    BE sure to use the CD with LB48 support. Also, here is a complete backup guide:


  3. #3
    Join Date
    Nov 2004

    Thanks, I think I found the problem

    Thanks, Huge. I think the DOS partition onto which I was going to make the backup was corrupt. I'll try again. BTW, that -6so vs -1so shouldn't make a difference, that just specifies how much compression to use.

    Along the way, an interesting problem arose. I rebooted the tivo with their stock disk re-installed, so I could see what version of the kernel they had installed. Tivo told me to make a phone call right away, bla bla bla. In short, it looks like the modem is fried, and so D* is going to replace the unit for me. I'm glad I caught this problem before upgrading the disk.

    The lesson: Always make backups, just in case.


  4. #4
    Join Date
    Nov 2004

    Problem solved, put the two drives on separate IDE cables

    Ugh, what a mess. I found that you *must* install the disks on separate IDE cables. Weird as it is, that's what worked for me, and a bunch of others at

    My setup (all devices set to CS (Cable Select)):

    primary master: Tivo original disk
    primary slave: empty
    secondary master: CD-ROM
    secondary slave: disk with a FAT32 partition

    happy hacking.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts