Results 1 to 2 of 2

Thread: genrenums error

  1. #1
    Join Date
    Nov 2004
    Posts
    27

    genrenums error

    I am running 4.01b on my dvr40. I have tivoweb, hmo, and mfs_ftp installed on the unit. When I look up a title using tivoweb and click on the episode, I get this message:

    INTERNAL SERVER ERROR
    --cut here--
    action_showing '/165371/37' ''
    can't read "genrenums": no such variable
    while executing
    "lsearch $genrenums $genre"
    ("foreach" body line 2)
    invoked from within
    "foreach genre $genres {
    set genreindex [lsearch $genrenums $genre]
    if { $genreindex != -1 } {
    if { $genrestr != "" } {..."
    ("uplevel" body line 293)
    invoked from within
    "uplevel $body"
    invoked from within
    "transaction {uplevel $body}"
    (procedure "RetryTransaction" line 5)
    invoked from within
    "RetryTransaction {
    if { [regexp {([0-9]*)/(.*)} $objectid junk fsid subobjid] } {
    set showing [db $db openidconstruction $fsid $subobjid]
    ..."
    (procedure "::action_showing" line 48)
    invoked from within
    "::action_$action $chan $part $env"
    ("eval" body line 1)
    invoked from within
    "eval {::action_$action $chan $part $env}"
    --cut here--

    I've done a search here on the forums for that error, but can't pull anything up. Any help would be appreciated. Thanks.

  2. #2
    Join Date
    Nov 2001
    Location
    Southern California
    Posts
    938
    Peculiar, I typed in genrenums, and got 21 hits.

    Have you tried restarting tivoweb? The Tivo?

    What version of tivoweb are you using?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •