Results 1 to 4 of 4

Thread: fdisk cannot display partitions

  1. #1
    Join Date
    Jan 2004
    Posts
    24

    fdisk cannot display partitions

    I just finished cloning a drive from an SD-DVR120 to a 200GB drive, expanding it to use the additional space (thanks, PlainBill, for the tip on that front). However, after using dd to put a killhdinitrd'd kernel on the drive, I tried to mount the root filesystem to begin hacking and was not able to do so. Instead, I got the error message

    # mount /dev/hdd7 tivo
    mount: special device /dev/hdd7 does not exist

    When I tried to print the partition table, I got the following:

    # fdisk /dev/hdd
    Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklab el
    Building a new DOS disklabel. Changes will remain in memory only,
    until you decide to write them. After that, of course, the previous
    content won't be recoverable.


    The number of cylinders for this disk is set to 24792.
    There is nothing wrong with that, but this is larger than 1024,
    and could in certain setups cause problems with:
    1) software that runs at boot time (e.g., old versions of LILO)
    2) booting and partitioning software from other OSs
    (e.g., DOS FDISK, OS/2 FDISK)
    Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)

    Any guidance on this? Anyone seen this before?

  2. #2
    Join Date
    May 2004
    Posts
    247
    TiVo doesn't use a DOS partition table, but an Apple one. You need to use pdisk. Do some searching.

  3. #3
    Join Date
    Jan 2004
    Posts
    24

    that was a silly mistake to make

    I even used pdisk in an earlier post.

    I just put Ubuntu linux on a pc at a friend's recommendation, and expected to be able to read the Tivo drive from it. Seems that the kernel doesn't have lba48 enabled. Though I'm not entirely sure how to verify that.

    So, using a boot CD, I can run pdisk and see that partition table fine, as well as mount partitions. I just can't do it in Ubuntu (2.6.10-5-386).

    Thanks for the response.

  4. #4
    Join Date
    Aug 2004
    Posts
    4,086
    Quote Originally Posted by beemer
    I just can't do it in Ubuntu (2.6.10-5-386).
    Sure you can. You just need tivopart (for the revalidate option) and pdisk. You can find both here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •