I just finished cloning a drive from an SD-DVR120 to a 200GB drive, expanding it to use the additional space (thanks, PlainBill, for the tip on that front). However, after using dd to put a killhdinitrd'd kernel on the drive, I tried to mount the root filesystem to begin hacking and was not able to do so. Instead, I got the error message

# mount /dev/hdd7 tivo
mount: special device /dev/hdd7 does not exist

When I tried to print the partition table, I got the following:

# fdisk /dev/hdd
Device contains neither a valid DOS partition table, nor Sun, SGI or OSF disklab el
Building a new DOS disklabel. Changes will remain in memory only,
until you decide to write them. After that, of course, the previous
content won't be recoverable.


The number of cylinders for this disk is set to 24792.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
(e.g., DOS FDISK, OS/2 FDISK)
Warning: invalid flag 0x0000 of partition table 4 will be corrected by w(rite)

Any guidance on this? Anyone seen this before?