Results 1 to 7 of 7

Thread: Series 2 DTV frozen

  1. #1
    Join Date
    Oct 2004

    Series 2 DTV frozen

    I give up.... I have a RCA DVR80 with 6.2, a 300G drive, superpatch, tytools, HMO, MRV, etc. All was working great for a many months, then it started to reboot every few days. I read that "mfsassert -please" would force a GSOD and start a scandisk-ish function on the hard drive, and tried it. After the GSOD completed (3 hours) the "Almost there..." screen came up and there it sat.

    I have tried the KickStart options on with no luck. I still freeze on the same screen.

    Pulled the drive and ran PowerMax which reported no errors.

    Put it in a PC and can mount the /dev/da4 partition fine. I copied a backup copy of my file to the etc/rc.d directory and tivoapp into the tvbin directory. Still no change.

    I noticed that the VAR directory totally empty, so I put the log dir back and put some old log files in it in case it was hanging while trying to write to missing logs. Still no luck.

    Don't think it is the swap file, as I am not in the reboot loop, I just freeze at Almost There.

    Where do I go from here? Can I mount the MFS partitions and copy shows to a fat drive to make sure i do not lose them? FYI: I have a fat drive in the PC that I used to copy the backups to the TiVo drive.

  2. #2
    Join Date
    Jan 2002
    Check the kernel log in partition 9 / log. Or better yet, check the serial console output and attach it if you can't find the error.

    There's a difference between needing help, and just being plain ole' lazy.

    "You cannot teach a man anything. You can only help him find it for himself." Galileo Galilei (1564-1642)

    HR20-700 with 2 TB, HR22-100, HR22-100, HR22-100, HR23-100 all running 0x5cd and networked.

  3. #3
    Join Date
    Oct 2004
    Thanks for the info. I was unaware that partition 9 was actually my /var directory. It is starting to make sense, this windows guy is slowly being converted...

    I attached section of the kernel log pertinent to the last boot cycle, but the last line is: "InitializeProgramOrDie (myworld) failed: 0x30001 "

    Hoping someone can identify what it means, and how to fix it.

    Attachment 5329
    Last edited by Sunapee; 11-22-2005 at 04:41 PM.

  4. #4
    Join Date
    Oct 2004
    Thought it might also help if I incouded the section of tvlog file from the same boot:

    Attachment 5330
    Last edited by Sunapee; 11-22-2005 at 04:42 PM.

  5. #5
    Join Date
    Apr 2003
    Quote Originally Posted by Sunapee
    Thought it might also help if I incouded the section of tvlog file from the same boot:

    Might help if you learn to attach these log files instead of posting them in the body of the message....


  6. #6
    Join Date
    Oct 2004

    Sorry about that....

    Just edited the original posts with the logs attached instead of pasted.

    Anyone have suggestions about what steps I can take to resolve this?

  7. #7
    Join Date
    Feb 2004
    Just wondering if there was any fix for this problem. Same situation (almost) for me. HDVR2 hung with GSOD. It went through it's fix but didn't. Just hangs during boot. No changes were made to the unit. HDVR2 running 6.2 per my SIG. Serial log fails at the same point as the OP in this thread.

    I can easily clone one of my other units but would like to preserve the MFS. Any suggestions? Serial log is attached.

    My attention is drawn to:

    NewSoftware: getting SwSystem name
    NewSoftware: failure reading SwSystem none: errDbNotFound
    Scanning for phase3 repair scripts
    Am I looking at an unrecoverable MFS?

    pdisk shows the following:
    Partition map (with 512 byte blocks) on '/dev/hdc'
     #:                type name                             length   base      (size )
     1: Apple_partition_map Apple                                63 @ 1        
     2:               Image Bootstrap 1                           1 @ 77261888 
     3:               Image Kernel 1                           8192 @ 77261889  (  4.0M)
     4:                Ext2 Root 1                           262144 @ 77270081  (128.0M)
     5:               Image Bootstrap 2                        4096 @ 77532225  (  2.0M)
     6:               Image Kernel 2                           4096 @ 77536321  (  2.0M)
     7:                Ext2 Root 2                           262144 @ 77540417  (128.0M)
     8:                Swap Linux swap                       260096 @ 77802561  (127.0M)
     9:                Ext2 /var                             262144 @ 78062657  (128.0M)
    10:                 MFS MFS application region          1048576 @ 78324801  (512.0M)
    11:                 MFS MFS media region               33100800 @ 44161088  ( 15.8G)
    12:                 MFS Second MFS application region   1048576 @ 79373377  (512.0M)
    13:                 MFS Second MFS media region        44161024 @ 64        ( 21.1G)
    14:                 MFS New MFS Application                1024 @ 80421953 
    15:                 MFS New MFS Media                 159694848 @ 80422977  ( 76.1G)
    16:          Apple_Free Extra                              3903 @ 240117825 (  1.9M)
    Thanks for any help.
    5 Series 2 DTivos: upgraded to 120GB, 6.2, SuperPatched, tserver, mfs_ftp, tivowebplus, endpadplus, bufferhack, MRV, HMO
    1 HR10-250: upgraded to 400GB, tserver, mfs_ftp, tivowebplus, endpadplus, bufferhack
    2 R15s: Just playing
    2 R10's PROMs in house but not installed yet (sitting on the bench)
    JAVAHMO Server 2.4/EtiVo Server 1.0.1924.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts