Results 1 to 5 of 5

Thread: Newbie telnet question re: Mac OS X terminal

  1. #1
    Join Date
    Nov 2005
    Posts
    18

    Newbie telnet question re: Mac OS X terminal

    This isn't Tivo specific but I hope someone knows this off the top of their head.

    When I telnet into Tivo from Mac OS X, every character I type is echoed back to me so that they show up once when I type them and once when the tivo sends them back. Everything works if I make no typos.

    Likewise I can paste commands into the terminal and they execute fine.

    Is there a command that I can issue to stop this behavior. I can't see anything in my terminal preferences that looks like it could control this. My choices of emulation are: xterm, xterm color, vt52, vt100, vt102, ansi, dtterm, rxvt.

    Thanks for the off topic reply

  2. #2
    Join Date
    Jan 2005
    Location
    Narnia
    Posts
    1,266
    Most unix systems can reliabily work with VT100 or VT102 emulation. But the issue you describe about repeated letters means you have 'local echo' turned on somewhere.

    Unfortunately, I don't have OSX (my Mac experience stopped somewhere back at System 7.5) so I can't help much. You can try this http://docs.info.apple.com/article.html?artnum=25375 and see if it helps your situation.

  3. #3
    Join Date
    Jan 2005
    Posts
    379
    telnet -K solves the problem

  4. #4
    Join Date
    Jan 2005
    Location
    Narnia
    Posts
    1,266
    You could also try just running the telnet command and setting the options before connecting to your tivo. [Since this is NOT collection from a Mac, your milage may vary]

    % telnet
    telnet > display <<<--- You may also try mode line
    Escape Character is 'CTRL+]'
    WILL AUTH (NTLM Authentication)
    LOCAL_ECHO on
    Sending both CR & LF
    WILL TERM TYPE

    Preferred Term Type is ANSI


    telnet > open my.tivo.ip.addess

    Essentially see what you can set for your telnet client.

  5. #5
    Join Date
    Nov 2005
    Posts
    18
    Excellent. telnet -K did the trick.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •