Results 1 to 5 of 5

Thread: S1 SA - Hack attempt, Jenkins freezes

  1. #1
    Join Date
    Mar 2006

    Angry S1 SA - Hack attempt, Jenkins freezes

    I am attempting to get bash running on my tivo (via serial eventually), but have encountered a strange problem.

    I have an untouched 13hr tivo series1 stand alone drive
    I have it connected to a PC as Secondary Master
    I have a cd-rom drive connected as Primary Slave
    (as specified in the jenkin's guide)

    I boot, and all goes well. It loads the linux distro and detects both devices properly
    (cdrom as hdb)
    (tivo hd as hdc)

    it now goes through each of the tivo's partitions:
    hdc1: apple
    hdc2: bootstrap 1
    hdc3: kernel 1
    etc: root1, bootstrap2, kernel2, root2, linux swap, var, mfs application region, mfs media region

    this bring me to the problem, while attempting to read hdc11, it freezes!

    has anyone had this problem where Jenkins just halts while probing the partitions?

    is there an suggested, up-to-date, alternative that will allow me to mount the tivo drive, and get it running bash?

    ps- i am pretty sure the drive is locked

  2. #2
    Join Date
    Apr 2003
    If the drive is locked, you need to unlock it. qunlock worked for early Quantum and Maxtor drives. There is a newer tool in the files forum that will probably work also called disk_util or something similar.


  3. #3
    Join Date
    Mar 2006

    I tried with MFS Tools boot cd, and it is hanging after identifying the devices, and in the midst of "partition check"

    do you think that my tivo HD is fried? should I format it and get a new image somehow??

    ERG!! I can't even get in to linux!!

    @EW: my tivo drive is reporting 13701MB, and i've heard that locked drivers report a smaller size. From the guide-
    If the number is dramatically too low (such as 9-10MB), then your drive is locked.
    Mine doesn't appear to be locked! Should I attempt it anyway? I read that you could b0rk the drive if you attempt to unlock it when it is not locked.

  4. #4
    Join Date
    Mar 2006

    At 2:35am CST, at the age of 7, my tivo drive ceased opperations after a rather nasty grinding noise emenated from my PC case..

    I never even had a chance to run bash off the little feller..he had so much left to do in life!! My PC bios no longer detects it as a device on the IDE chain.

    All sentiments aside..

    It is time to pick up the pieces and investigate getting my tivo a brand spanking new hard drive, and hack that instead. The question I have for you, is this:

    My stock TiVO hdd died from use without giving me any oppertunity to back it up. How do I go about finding the original tivo files? is this possible?? PLEASE say yes

  5. #5
    Join Date
    Feb 2002
    There are several places you can get a backup image from. You can post a request in the image begging thread found here, contact Stan Simmons over at the TCF and request access to his FTP site in this thread, or purchase InstantCake from PTVUpgrade for your model of Tivo. You can also download images from several of the peer-to-peer networks like KaZaa or edonkey.
    Please don't PM me or any other members looking for personal assistance. You'll do better by posting (after you've exhausted the search feature, of course) and taking advantage of the collective expertise of the membership instead of a single individual that may or may not be able to help you. Thank you and enjoy your stay at DDB!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts