Results 1 to 2 of 2

Thread: HR10 PPP Possible?

  1. #1
    Join Date
    May 2004
    Location
    Ohio
    Posts
    17

    HR10 PPP Possible?

    Good afternoon,

    I'm trying to get my HR10-250 to dial in via PPP over the serial connection so I can possibly receive the new 6.3 update and it doesn't seem to be working.

    In a Wireshark packet capture I see the Tivo sending a packet to the 204.176.49.0 network over HTTP but I never receive a response back from the server.

    I have tried both a Linux pppd connection with iptables MASQUERADE as well as the Windows XP serial connection as detailed at http://www.b-lan.com/otto/tivo3xp/ with the same results: a packet leaves the PPP IP address but I never receive a response back from the server. If I go to the IP address in my browser I receive a 403 Forbidden message so I know that the server is working.

    Here is my setup:

    . Cable Modem
    . Linksys WRT54G wireless router
    . Stock HR10-250 with 3.x software connected to Dell laptop via serial cable
    . ,#211 in the dial options

    Any ideas on where to proceed from here? Since the Tivo never receives a packet back, could it be a network/NAT issue?

    Thanks for your help,
    Flux.

  2. #2
    Join Date
    May 2004
    Location
    Ohio
    Posts
    17
    Figured out my own problem.

    It seems the PPP connection wasn't getting an IP address from my router. I statically assigned the To and From IP addresses in the TCP/IP settings on the Network tab of the Incoming Connections and that resolved my issues.

    Hopefully this post helps someone in the future

    Thanks,
    Flux.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •