Page 2 of 5 FirstFirst 1234 ... LastLast
Results 16 to 30 of 70

Thread: Mfs_ftp

  1. #16
    Join Date
    Jan 2005
    Location
    Narnia
    Posts
    1,263
    This is what I've done, a series of checks at bootup which creates the necessary folders if they happen to be missing:

    Put this in your /etc/rc.d/rc.sysinit.author file, after the variable and PATH definitions:
    Code:
    # Check for hack logs directory
    if [ ! -d /var/hack/log ]
     then mkdir /var/hack/log
    fi
    # Check for mfs_ftp cache directory
    if [ ! -d /var/mfs_ftp/cache ]
     then mkdir /var/mfs_ftp/cache
    fi
    Then in your permanent mfs_ftp directory, create the needed symlinks:

    tivo-bash# ln -s /myhacks/mfs_ftp/cache /var/mfs_ftp/cache

    tivo-bash# ln -s /myhacks/mfs_ftp/port.3105.log /var/mfs_ftp/port.3105.log

    (Obviously /myhacks will be wherever you set up your permanent hacks )
    Last edited by Narf54321; 12-31-2006 at 03:05 PM. Reason: Added clarity

  2. #17
    Join Date
    Aug 2005
    Location
    Hendersonville, TN (just outside of Nashville)
    Posts
    44
    Narf,

    Sorry for the delayed reply. I was considering whether I was brave enough to edit this file. I am afraid this file is significant and if I mess up this edit I will screw up my Tivo. Please bear with me.

    I opened the rc.sysinit.author file. I pasted a portion below. Is the point where this code should be put correct? I would obviously remove my "here" comments.

    About editing files-I am using SmartFTP. I right click on the file and click edit. It opens notepad for editing. Problem is the formatting is difficult to read. Not nearly as nice as it is shown below. Is there a easier way to edit this file?

    #!/bin/bash
    # Zipper author file
    echo "starting rc.sysinit.author"

    echo "set environmental variables"
    export PATH=./:.:/utils:/bin:/sbin:/tvbin:/tivobin:/busybox:/enhancements
    HERE??
    # Check for hack logs directory
    if [ ! -d /var/hack/log ]
    then mkdir /var/hack/log
    fi
    # Check for mfs_ftp cache directory
    if [ ! -d /var/mfs_ftp/cache ]
    then mkdir /var/mfs_ftp/cache
    fi

    TO HERE??
    export TIVO_ROOT=
    export MFS_DEVICE=/dev/hda10

    echo "starting telnet....."

    Now for the code in the permanent mfs_ftp directory

    Looks like I should telnet over to the Tivo and get to my permanent mfs_ftp directory. In my case /hacks/mfs_ftp (you can see this from a picture in my previous posts). The I just enter the commands you have given me?

    tivo-bash# ln -s /myhacks/mfs_ftp/cache /var/mfs_ftp/cache

    tivo-bash# ln -s /myhacks/mfs_ftp/port.3105.log /var/mfs_ftp/port.3105.log



    Lastly- When I opened SmartFTP and it tried to go to port 3105 it was "actively refused". I guessed for some reason that mfs_ftp had been shutdown by an overnight reboot or something. I did not do it.

    I was able to re-mount as ro.

    Thanks for your help.

  3. #18
    Join Date
    Dec 2003
    Location
    Indianapolis
    Posts
    297
    Quote Originally Posted by Growler View Post
    About editing files-I am using SmartFTP. I right click on the file and click edit. It opens notepad for editing. Problem is the formatting is difficult to read. Not nearly as nice as it is shown below. Is there a easier way to edit this file?
    I use TextPad to edit my files, it gives you file format options to save, you want to save as UNIX file format. If you use an editor that saves the file in pc format like notepad, the TiVo will not recognize the file.

    Quote Originally Posted by Growler View Post
    Looks like I should telnet over to the Tivo and get to my permanent mfs_ftp directory. In my case /hacks/mfs_ftp (you can see this from a picture in my previous posts). The I just enter the commands you have given me?

    tivo-bash# ln -s /myhacks/mfs_ftp/cache /var/mfs_ftp/cache

    tivo-bash# ln -s /myhacks/mfs_ftp/port.3105.log /var/mfs_ftp/port.3105.log
    Quote Originally Posted by Narf54321 View Post
    (Obviously /myhacks will be wherever you set up your permanent hacks
    Based on your reply, as Narf stated /myhacks/mfs_ftp/.... would be /hacks/mfs_ftp/....
    (2) UltimateTV - upgraded w/160GB
    (1) HR10-250 2TB 6.4a
    (1) HR10-250 620GB 6.4a
    (1) HR10-250 300GB 6.4a
    (3) HR21 (2) with AM21 & internal 2TB Seagate
    RandC

  4. #19
    Join Date
    Aug 2005
    Location
    Hendersonville, TN (just outside of Nashville)
    Posts
    44
    Quote Originally Posted by RandC View Post
    I use TextPad to edit my files, it gives you file format options to save, you want to save as UNIX file format. If you use an editor that saves the file in pc format like notepad, the TiVo will not recognize the file.
    I guess I got lucky! You may see earlier in the post that I had to create a text file for tzoffset.txt. I used notepad for that and it worked.

    I will download and try textpad. Thanks for the tip.

  5. #20
    Join Date
    Dec 2003
    Posts
    267
    Given the headaches with mfs_ftp needing read/write access, I elected to simply install the whole thing in /var but put all my other hacks in /hack (which is RO). I made a tar file of the fully patched up mfs_ftp install and keep that in /hack to restore from if /var gets wiped. I eventually added an automatic untar of that backup into my startup script so it's all automatic on startup. It just seemed easier than trying to decipher which files need RW and making symlinks.

  6. #21
    Join Date
    Jan 2005
    Posts
    41
    Fist thanks also for the great directions. Finally got my HR10 to transfer to my PC. Been pulling my hair out on that one. Do have one question. When I try to apply the patches I get :

    bash-2.02# patch -p0 < mfs_ftp.jbuehl.patch
    patching file mfs_ftp.tcl
    patch: Hunk #1 FAILED at 827.
    patch: 1 out of 1 hunk FAILED
    Segmentation fault
    bash-2.02#

    Does that mean the files are already patched ?

  7. #22
    Join Date
    Dec 2001
    Posts
    328
    After following the instructions above I can D/L from both of my HR-10's fine- works great. I cannot upload at all. It fails after about 5 seconds. Is there a log or something that can tell me what the issue is? (and yes, I did install all the patches).

    HUGE

  8. #23
    Join Date
    Dec 2003
    Posts
    267
    Quote Originally Posted by HUGE View Post
    After following the instructions above I can D/L from both of my HR-10's fine- works great. I cannot upload at all. It fails after about 5 seconds. Is there a log or something that can tell me what the issue is? (and yes, I did install all the patches).

    HUGE
    You're right, inserts don't work for me either. Doh. Here's what I did to fix it. Maybe steve90071 can update his directions to include these:

    • Instead of the "mv mfs_uberexport /hack/mfs_ftp" and "mv mfs_import /hack/mfs_ftp" steps, copy all the files from the mfs-utils_bin.mips-20050604.tar.bz2 instead of just mfs_import and mfs_uberexport.
    • After all the other steps are said and done, edit mfs_ftp.tcl and delete or comment out ALL lines containing "TmkEvent".
    • Reboot.

  9. #24
    Join Date
    Jan 2005
    Posts
    41
    Good suggestion. Steve if you can do that suggest you also put in the touch tzoffset.txt

    As for getting it working. I have it working between two HR10s with no issues but never could get the patch commands to work. Any one else have that issue ?

  10. #25
    Join Date
    Apr 2004
    Posts
    114
    Barefooter:

    I'm a little reluctant to put in the "touch" offset move because in my installations of mfs_ftp it has been created automatically. Maybe someone else can chime in with advise on this.

    Regarding the patch, I execute mine on the tivo (one RCA Dtivo and one HR10-250). I have the most recent tivotool package installed. I seem to recall that Jamie warned about some versions of "patch" not working well. I have not experienced any problems. Also, I do the jbuehl patch first and then the jamie patch.

    I'll wait a day or two for input then I'll revise the instructions.

  11. #26
    Join Date
    Apr 2004
    Posts
    114
    Per suggestions, I have edited my post #2 to provide insertion information from mr zorg, to address the issues with tzoffset, and to replace the s2bins used originally by me and posted by mr zorg in post #3 with the s2 (mips) bins provided in Jamies Unified mfs * tools.

  12. #27
    Join Date
    Dec 2001
    Posts
    328
    nevermind - fixed it.


    HUGE
    Last edited by HUGE; 01-07-2007 at 01:20 PM.

  13. #28
    Join Date
    Aug 2004
    Posts
    4,075
    Quote Originally Posted by HUGE View Post
    I'm not sure what's going on, because the file is in the directory, but I ge this error when I try to start mfs_ftp:
    I'd say this is #1 or #2 on the list of most frequently reported problems: link.

  14. #29
    Join Date
    Aug 2005
    Location
    Hendersonville, TN (just outside of Nashville)
    Posts
    44
    Never tried to upload to the Tivo.

  15. #30
    Join Date
    Jan 2005
    Posts
    41
    Steve, The new instructions on your post are excellent. Should eliminate a lot of problems people were having. Thanks for all your efforts. I know you made my life a whole lot easier.
    (2) HR10-250 500 GB upgraded to 6.4a
    (2) HR20s
    JimW

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •