Page 20 of 62 FirstFirst ... 10181920212230 ... LastLast
Results 286 to 300 of 928

Thread: TySuiteJ - GUI, Extraction, MPEG Conversion, and much much more

  1. #286
    Join Date
    Jul 2003
    Posts
    16
    Quote Originally Posted by dburckh View Post
    The zero file length usually means encryption is on.

    Well, the bad news is that testSetup is broken. The good news is that I found a work around.

    Create a "ui.content=<hosts>" entry that is the same as your "Content.tivo.hosts=<hosts>". That will work around the bug until I get 2.5.1 out.
    Thanks for the reply.

    Iím sure I turned the encryption off, but as I said earlier it must be my incompetence, that the encryption is still on, I will take a look again, and thanks for the suggestion, I will have a go an let you know how I get on..

  2. #287
    Join Date
    Sep 2006
    Posts
    648
    I looked at the ciphercheck.tcl code and it should be easy to add an encryption check to 2.5.1. Unfortunately, I've been traveling for work 3 out of the last 4 weeks, so I'm still trying to catch up on life.
    Last edited by dburckh; 08-13-2007 at 03:45 PM.

  3. #288
    Join Date
    Sep 2006
    Posts
    648
    Quote Originally Posted by stressbuster View Post
    I am using the latest version (2.5 dated 7/29/07) on Win XP SP2. I can't seem to get the external ty converter feature to work anymore. I don't get any error messages it just creates the .mpg file directly. It used to create the .ty file and then run tytompg to create the .mpg. I have ui.useExternalTyConverter=true and a correct path to tytompg.exe. Any idea of whats going on? Thanks.

    Jay
    I found a work around I like so much that I'm calling it the fix! I'm removing the "ui.useExternalTyConverter" from 2.5.1

    Define a ui.button called external. e.g.
    Code:
    ui.buttons=external,ty

  4. #289
    Join Date
    Sep 2006
    Posts
    648

    TySuiteJ 2.5.1 Beta 1

    Version 2.5.1b1
    ---------------
    • Fixed testSetup.cmd
    • Added encryption checking
    • Fixed issue where IOException was being buried by NullPointerException
    • Removed ui.useExternalConverter. Use ui.buttons=external,... or Save As... button

  5. #290
    Join Date
    Aug 2004
    Posts
    14
    Quote Originally Posted by dburckh View Post
    I found a work around I like so much that I'm calling it the fix! I'm removing the "ui.useExternalTyConverter" from 2.5.1

    Define a ui.button called external. e.g.
    Code:
    ui.buttons=external,ty
    Thanks. I'll give it a try.

    Jay

  6. #291
    Join Date
    Jul 2003
    Posts
    16
    Down-loaded the new version running testsetup.bat now gives this!


    C:\Users\d\Documents\Tivo>testsetup
    java version "1.6.0_02"
    Java(TM) SE Runtime Environment (build 1.6.0_02-b06)
    Java HotSpot(TM) Client VM (build 1.6.0_02-b06, mixed mode, sharing)
    Testing connection from: fe80:0:0:0:c8ea:1d1e:12d1:7c04%8

    Testing UI Connections
    ----------------------
    Checking Host: 192.168.0.2
    Checking: NowShowing
    Passed: NowShowing
    Checking: mfs_uberexport
    Passed: mfs_uberexport
    Checking: dserver.tcl
    Starting dserver.tcl
    08/14/2007 17:49:18.411 INFO [io.DServerTyStreamHelper] Starting dserver on 192
    .168.0.2
    getting NowShowing
    getting Ty Stream for FSID: 2773579
    Found valid Ty Part
    shutting down dserver.tcl
    Passed: dserver.tcl

    Checking: UpnpMediaServer.content
    Host already validated, skipping: 192.168.0.2

    FAILED: Directory not found:
    FAILED: Directory not found:

    Checking: GenericWebServer.content
    Host already validated, skipping: 192.168.0.2


    Checking: MyIHomeWebServer.content
    Host already validated, skipping: 192.168.0.2

    FAILED: Directory not found:
    FAILED: Directory not found:

    C:\Users\d\Documents\Tivo>


    running tySuiteJ.jar by double clicking on it works ok and I can download the files off the TiVo and watch them ok!

    Regards

    Dogo

  7. #292
    Join Date
    May 2005
    Posts
    2
    I have been using tysuite 2.2 successfully. I tried to use 2.5. I put the new dserver.tcl on my tivo. However, when I run tysuite, it reports no content found. It shows the proper IP of my TiVo. testsetup runs OK. What am I missing?

  8. #293
    Join Date
    Sep 2006
    Posts
    648
    Quote Originally Posted by wscannell View Post
    I have been using tysuite 2.2 successfully. I tried to use 2.5. I put the new dserver.tcl on my tivo. However, when I run tysuite, it reports no content found. It shows the proper IP of my TiVo. testsetup runs OK. What am I missing?
    Hmmm. If you haven't tried it already, get 2.5.1b1 from here: http://www.dealdatabase.com/forum/sh...&postcount=289

    Run dserver.tcl on the Tivo before starting TySuiteJ
    Code:
    dserver.tcl 56178 &
    After a second, you should see "dServer open for d-business"

    Try the UI.

    If that doesn't work, run this and attach the output (testSetup.txt) to a post. Run the UI and copy any output to the same post.
    Code:
    testSetup.cmd > testSetup.txt 2>&1

  9. #294
    Join Date
    May 2005
    Posts
    2
    Thank you for the reply. 2.5b1 works fine. Great product.

  10. #295
    Join Date
    Aug 2001
    Location
    Florham Park, NJ
    Posts
    187
    With 2.5b1 I can't seem to get through a successful testSetup.cmd. It reports "Directory not found" but gives me no idea of what is misconfigured.

    Directory E:\\Tivo which is used throughout the configuration file does exist.

    This is my first attempt ever to use TySuiteJ. Despite the test failing I can download ty files successfully with the GUI.

    My results are:
    Code:
    $ ./testSetup.cmd 
    java version "1.6.0_01"
    Java(TM) SE Runtime Environment (build 1.6.0_01-b06)
    Java HotSpot(TM) Client VM (build 1.6.0_01-b06, mixed mode, sharing)
    Testing connection from: 192.168.1.102
    
    Testing UI Connections
    ----------------------
    Checking Host: 192.168.1.104
    Checking: NowShowing
    Passed:   NowShowing
    Checking: mfs_uberexport
    Passed:   mfs_uberexport
    Checking: dserver.tcl
              Starting dserver.tcl
              getting NowShowing
              getting Ty Stream for FSID: 3035100
              Found valid Ty Part
              shutting down dserver.tcl
    Passed:   dserver.tcl
    
    Checking: UpnpMediaServer.content
    Host already validated, skipping: 192.168.1.104
    
    FAILED: Directory not found: 
    FAILED: Directory not found: 
    
    Checking: GenericWebServer.content
    Host already validated, skipping: 192.168.1.104
    
    
    Checking: MyIHomeWebServer.content
    Host already validated, skipping: 192.168.1.104
    
    FAILED: Directory not found: 
    FAILED: Directory not found:
    application.properties contains

    Code:
    #Anything starting with a "#" is commented out
    
    Content.tivo.type=TIVO!
    #Content.tivo.hosts=192.168.2.200,192.168.2.202
    #Content.tivo.hosts=192.168.2.202
    Content.tivo.hosts=192.168.1.104
    
    #ui.downloads=C:\\Tivo
    ui.downloads=E:\\Tivo
    
    ui.useExternalTyConverter=false
    Content.video.type=VIDEO!
    Content.video.dirs=
    Content.video.exts=.mpg,.avi,.m2p,.ts
    
    Content.audio.type=AUDIO!
    Content.audio.dirs=
    Content.audio.exts=.mp3
    Content.audio.mobileReady=true
    
    Content.photo.type=PHOTO!
    Content.photo.dirs=
    Content.photo.exts=.jpg
    
    Content.mobile.type=VIDEO!
    Content.mobile.dirs=E:\\Tivo
    Content.mobile.exts=.mp4,.mov
    Content.mobile.mobileReady=true
    
    
    UpnpMediaServer.content=/Video/{Content.tivo},/Audio/{Content.audio},/Pictures/{Content.photo}
    #UpnpMediaServer.content=/Video/{Content.tivo}
    UpnpMediaServer.patchFirstVideoSequence=false
    UpnpMediaServer.port=8380
    UpnpMediaServer.PHOTO!.correctOrientation=true
    UpnpMediaServer.PHOTO!.rescale=true
    UpnpMediaServer.client.height=1080
    
    GenericWebServer.content=/Video/{Content.tivo},/Mobile/{Content.mobile}
    GenericWebServer.port=8280
    GenericWebServer.patchFirstVideoSequence=false
    GenericWebServer.secure=false
    GenericWebServer.user=
    GenericWebServer.pass=
    GenericWebServer.transcodedDir=E:\\Tivo
    
    MyIHomeWebServer.content=/Video/{Content.tivo},/Audio/{Content.audio},/Pictures/{Content.photo}
    MyIHomeWebServer.port=8180
    MyIHomeWebServer.patchFirstVideoSequence=true
    MyIHomeWebServer.nowShowing.rowsPerPage=20
    
    BackgroundFileConverter.cacheDir=.
    
    #Transcoding profiles
    Transcoder.engines=ffmpeg
    Transcoder.engine.ffmpeg=cmd,/c,.\\ffmpeg\\ffmpeg.exe {Options} 2> encoder_out.txt
    #Transcoder.engine.ffmpeg=bash,-c,./ffmpeg/ffmpeg {Options} 2> encoder_out.txt
    Transcoder.profiles=ipodMobile,ipodSD,treo700p,dvd
    Transcoder.profile.ipodMobile=iPod Screen,ffmpeg,mov,-deinterlace -y -i - -vcodec libxvid -s 320x240 -r 30000/1001 -bufsize 8192 -qscale 5 -acodec libfaac -ab 96 -ac 2 -async 1 -title "{Title}" "{OutputFile}"
    Transcoder.profile.ipodMobile.wide=iPod Screen-Wide,ffmpeg,mov,-deinterlace -y -i - -vcodec libxvid -s 320x176 -r 30000/1001 -bufsize 8192 -qscale 5 -acodec libfaac -ab 96 -ac 2 -async 1 -title "{Title}" "{OutputFile}"
    Transcoder.profile.iPhone=iPhone,ffmpeg,mov,-deinterlace -y -i - -vcodec libxvid -s 432x320 -r 30000/1001 -bufsize 8192 -qscale 5 -acodec libfaac -ab 96 -ac 2 -async 1 -title "{Title}" "{OutputFile}"
    Transcoder.profile.iPhone.wide=iPhone-Wide,ffmpeg,mov,-deinterlace -y -i - -vcodec libxvid -s 480x270 -r 30000/1001 -bufsize 8192 -qscale 5 -acodec libfaac -ab 96 -ac 2 -async 1 -title "{Title}" "{OutputFile}"
    Transcoder.profile.ipodSD=iPod On TV,ffmpeg,mov,-deinterlace -y -i - -vcodec libxvid -s 640x480 -r 30000/1001 -bufsize 8192 -qscale 4 -acodec libfaac -ab 160 -ac 2 -async 1 -title "{Title}" "{OutputFile}"
    Transcoder.profile.ipodSD.wide=iPod On TV-Wide,ffmpeg,mov,-deinterlace -y -i - -vcodec libxvid -s 640x368 -r 30000/1001 -bufsize 8192 -qscale 4 -acodec libfaac -ab 160 -ac 2 -async 1 -title "{Title}" "{OutputFile}"
    Transcoder.profile.treo700p=Treo 700p,ffmpeg,mp4,-deinterlace -y -i - -vcodec libxvid -s 320x240 -r 15 -bufsize 8192 -qscale 12 -acodec libfaac -ar 22050 -ab 32 -ac 2 -mbd rd -me full -f mov -title "{Title}" "{OutputFile}"
    Transcoder.profile.treo700p.wide=Treo 700p,ffmpeg,mp4,-deinterlace -y -i - -vcodec libxvid -s 320x176 -r 15 -bufsize 8192 -qscale 12 -acodec libfaac -ar 22050 -ab 32 -ac 2 -mbd rd -me full -f mov -title "{Title}" "{OutputFile}"
    Transcoder.profile.dvd=DVD Video,ffmpeg,mpg,-y -i - -target ntsc-dvd -aspect 4:3 "{OutputFile}" 2> encoder_out.txt
    Transcoder.profile.dvd.wide=DVD Video,ffmpeg,mpg,-y -i - target ntsc-dvd -aspect 16:9 "{OutputFile}" 2> encoder_out.txt
    #Transcoder.profile.xvid=XviD,ffmpeg,avi,{0} -threads 2 -deinterlace -y -i - -vcodec libxvid -s 640x480 -qscale 5 -acodec libmp3lame -ab 128 -ac 2 -title "{3}" "{2}" 2> encoder_out.txt
    #Transcoder.profile.xvid.720=XviD 720p,ffmpeg,avi,{0} -threads 2 -deinterlace -y -i - -vcodec libxvid -s 1280x720 -qscale 5 -acodec copy -vtag XVID -title "{3}" "{2}" 2> encoder_out.txt
    #Transcoder.profile.xvid.1088=XviD 1080p,ffmpeg,avi,{0} -deinterlace -y -i - -vcodec libxvid -s 1920x1088 -qscale 5 -acodec copy -vtag XVID -map 0.0 -map 0.1:0.0 -title "{3}" "{2}" 2> encoder_out.txt
    
    ui.useExternalTyConverter=false
    FileTransferrer.externalTyConverter=C:\\internet\\tivo\\tytompg-0.17\\windows-x86\\tytompg.exe -i "{0}" -o "{1}"
    #FileTransferrer.fileNamePattern={FolderPath}{EpisodeTitle}
    
    #Default log level
    #util.Logger.logLevel=[TRACE | DEBUG | INFO | WARN | ERROR]
    util.Logger.logLevel=INFO
    #util.Logger.file=tivo.log
    
    #web.MinimalServletRequest.logLevel=TRACE
    #web.MinimalServletResponse.logLevel=TRACE
    
    #setting this will produce smaller .mpg files, but they may not be compatible with DVD software.  NOTE: ProjectX DVB or VideoRedo will repacketize to DVD standard size.
    #RestreamingTyRecordParser.maxPacketSize=32768

  11. #296
    Join Date
    Sep 2006
    Posts
    648
    If you note the sections headers, it's saying the setup for the UPNP server and the MyIHome server content failed. If you aren't using those it's not a big deal.

    FYI: Here's the problem
    Code:
    Content.video.dirs=

  12. #297
    Join Date
    Feb 2005
    Posts
    15
    I just noticed that if I have a program with the same name with TySuiteJ251b1 that it only keeps the last one downloaded. For example I had 3 morning news shows recorded on 3 different days, and it only kept the last one unfortunately I deleted the shows not realizing that it over wrote the other 2.

  13. #298
    Join Date
    Sep 2006
    Posts
    648
    Are you using the "FileTransferrer.fileNamePattern=" option?

    If not, see the \help\readme.htm.

    If you are and it's not work, I'll look at it.

  14. #299
    Join Date
    Feb 2005
    Posts
    15
    No, I hadn't touch it and by default it was commented out. I will try it thanks. Great Program, though I haven't tried to convert the stuff to dvd yet. I am still learning tytools had me a little spoiled.

  15. #300
    Join Date
    Sep 2006
    Posts
    648
    DVD conversion is lacking. I've never had much interest in making DVDs. I haven't ever tried it in TyTool.

    As a note, the transcode DVD option just creates DVD compliant mpeg video. It does not create dvds. You'll need Nero or something like that to actually build the VOBs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •