Page 66 of 85 FirstFirst ... 1656646566676876 ... LastLast
Results 976 to 990 of 1264

Thread: TivoWebPlus 2.1 Testing and Development

  1. #976
    Join Date
    May 2005
    Posts
    913
    looks like TWP is opening files and not closing them somewhere... if it's happening without much user interaction, it's some sort of background task.

    Are there any suspicious/repeated entries in the log?
    Former Tivo Hacker (retired)

  2. #977
    Join Date
    Apr 2002
    Location
    State of Jefferson, USA
    Posts
    48
    I don't see anything strange in the logs. Maybe you can see something.
    -----------------------------------
    Hughes GXCEBOT 3.5d
    306 HRS
    SiliconDust Cache Card
    TWP 2.1.b3 - HackMan 7.1.1

  3. #978
    Join Date
    May 2005
    Posts
    913
    oh... I didn't realize you used sendkey so much... that's probably the culprit in one way or another.
    Have you made any system changes recently? (new browser version, perhaps?)
    Former Tivo Hacker (retired)

  4. #979
    Join Date
    Apr 2002
    Location
    State of Jefferson, USA
    Posts
    48
    I always make system changes LOL. But nothing significant lately. I use Firefox 99% of the rime. I do use the twp remote alot since I watch tv in my office and use the twp remote to skip commercials etc. You think that might have something to do with the prob? If so, what would the fix be? I do have to restart the TiVo occasionally when it won't respond to the regular remote.
    -----------------------------------
    Hughes GXCEBOT 3.5d
    306 HRS
    SiliconDust Cache Card
    TWP 2.1.b3 - HackMan 7.1.1

  5. #980
    Join Date
    Apr 2005
    Location
    Providence, RI
    Posts
    484
    Y'know, I've been having this problem for a while as well. I thought maybe it was being caused by a new module I was writing but now I'm going to take a closer look myself.

    Quote Originally Posted by IcedTivo View Post
    I'm getting this error frequently almost daily. When it happens the web remote quits responding and the screen looses the css and reverts to a vert col of text. restart/full often works to fix but sometimes have to reboot.


    -------INTERNAL SERVER ERROR------ --cut here--POSIX EMFILE {too many open files}
    couldn't open "/TivoWebPlus/themes/.common.css": too many open files
    while executing
    "open $fnam "r""
    (procedure "serve_file" line 31)
    invoked from: "serve_file $chan $path $env $ext $head_req $mod_since"
    (procedure "doSession" line 100)
    invoked from: "doSession $chan $addr $port"
    --cut here--
    192.168.1.101 - - [24/Jan/2010 13:09:17] /faiec.css
    -------INTERNAL SERVER ERROR------ --cut here--POSIX EMFILE {too many open files}
    couldn't open "/TivoWebPlus/themes/faiec.css": too many open files
    while executing
    "open $fnam "r""
    (procedure "serve_file" line 31)
    invoked from: "serve_file $chan $path $env $ext $head_req $mod_since"
    (procedure "doSession" line 100)
    invoked from: "doSession $chan $addr $port"
    --cut here--
    192.168.1.101 - - [24/Jan/2010 13:09:17] /images/hdvr2.png
    -------INTERNAL SERVER ERROR------ --cut here--POSIX EMFILE {too many open files}
    couldn't open "/TivoWebPlus/images/hdvr2.png": too many open files
    while executing
    "open $fnam "r""
    (procedure "serve_file" line 31)
    invoked from: "serve_file $chan $path $env $ext $head_req $mod_since"
    (procedure "doSession" line 100)
    invoked from: "doSession $chan $addr $port"
    --cut here--
    192.168.1.101 - - [24/Jan/2010 13:09:17] /keytrap2.js
    -------INTERNAL SERVER ERROR------ --cut here--POSIX EMFILE {too many open files}
    couldn't open "/TivoWebPlus/scripts/keytrap2.js": too many open files
    while executing
    "open $fnam "r""
    (procedure "serve_file" line 31)
    invoked from: "serve_file $chan $path $env $ext $head_req $mod_since"
    (procedure "doSession" line 100)
    invoked from: "doSession $chan $addr $port"
    --cut here--
    192.168.1.101 - - [24/Jan/2010 13:09:17] /sorttable.js
    -------INTERNAL SERVER ERROR------ --cut here--POSIX EMFILE {too many open files}
    couldn't open "/TivoWebPlus/scripts/sorttable.js": too many open files
    while executing
    "open $fnam "r""
    (procedure "serve_file" line 31)
    invoked from: "serve_file $chan $path $env $ext $head_req $mod_since"
    (procedure "doSession" line 100)
    invoked from: "doSession $chan $addr $port"
    --cut here--
    192.168.1.101 - - [24/Jan/2010 13:11:47] /quit/r
    192.168.1.101 - - [24/Jan/2010 13:11:47] /.common.css
    -------INTERNAL SERVER ERROR------ --cut here--POSIX EMFILE {too many open files}
    couldn't open "/TivoWebPlus/themes/.common.css": too many open files
    while executing
    "open $fnam "r""
    (procedure "serve_file" line 31)
    invoked from: "serve_file $chan $path $env $ext $head_req $mod_since"
    (procedure "doSession" line 100)
    invoked from: "doSession $chan $addr $port"
    --cut here--
    192.168.1.101 - - [24/Jan/2010 13:11:47] /faiec.css
    -------INTERNAL SERVER ERROR------ --cut here--POSIX EMFILE {too many open files}
    couldn't open "/TivoWebPlus/themes/faiec.css": too many open files
    while executing
    "open $fnam "r""
    (procedure "serve_file" line 31)
    invoked from: "serve_file $chan $path $env $ext $head_req $mod_since"
    (procedure "doSession" line 100)
    invoked from: "doSession $chan $addr $port"
    --cut here--
    Restarting TWP
    More software at http://davidlauria.com/software.
    The lost alt-rock masterpiece from the '90s, Range of Motion's "Soft Buzz of Silence", is now available on iTunes!

  6. #981
    Join Date
    Sep 2009
    Posts
    6

    2.1 status?

    Hi DJL - what did you find when you took a closer look?

    Thanks!

  7. #982
    Join Date
    Dec 2003
    Posts
    188

    Purge questions

    I occasionally get this this when attempting to do a purge on my DTiVo:
    (after hitting "Confirm Purge")
    Code:
    -------INTERNAL SERVER ERROR------  --cut here--action:confirm, path:, env:u2 bdeleted sub Purge fsida(9203343) on fsida(9203344) on fsida(9196745) on fsida(9245554) on fsida(9203758) on fsida(9203345) on fsida(9196728) on fsida(9203760) on fsida(9203759) on fsida(9203706) on fsida(9203346) on fsida(9203347) on fsida(9203348) on fsida(9203350) on fsida(9203349) on fsida(9183287) on fsida(9203351) on fsida(9200660) on fsida(9203352) on fsida(9203353) on fsida(9188241) on fsida(9203335) on fsida(9203336) on fsida(9199483) on fsida(9203337) on fsida(9210709) on fsida(9203338) on fsida(9203339) on fsida(9203340) on fsida(9203342) on submit Confirm_Purge, code:'errTmActiveLockConflict'
    commit failed (errTmActiveLockConflict)
    
        while executing
    "transaction {
    foreach $vars [lrange $batch $i [expr $i+$bsiz-1]] {
    if [set code [catch {uplevel $body} errs]] {
    if {$code<4} break
    }
    incr i $vsiz
    }
    }"
        (procedure "ForeachTrans" line 13)
        invoked from: "ForeachTrans -noread id $ids 5 {
    set rec [db $::db openid $id]
    set state [dbobj $rec get State]
    if { $state != $old } { lappend bad $id; continue }
    if..."
        (procedure "DeleteRecs" line 8)
        invoked from: "DeleteRecs {9203343 9203344 9196745 9245554 9203758 9203345 9196728 9203760 9203759 9203706 9203346 9203347 9203348 9183287 9203349 9203350 9200660 92..."
        ("eval" body line 1)
        invoked from: "eval DeleteRecs [list $ids] $params"
        (procedure "MOD::action_confirm" line 27)
        invoked from: "$cmd $chan $path $env"
    --cut here--
    If I simply go back and deselect a few of the items set to purge, and hit "Confirm" again, it purges without issue. I can also then go back and select the few files I un-checked, and purge them. Seems kind of odd, I assume from the error and the inconsistency that it's some kind of timing thing......

    Also - both my DTiVo and my S! TiVo are running the same code, but the S1 has no "purge" function - is there a reason for that? Or is there something I need to edit?

  8. #983
    Join Date
    May 2002
    Posts
    234
    I run into a similar problem when deleting things from the todo list. If I just keep retrying it eventually completes with an error saying that some items were in the wrong state (which tells me that some items get deleted by earlier attempts)

  9. #984
    Join Date
    Dec 2003
    Posts
    188

    Rebooting when using FTP

    My S1 TiVo was on the 2009-5-22 release for a long time. Recently I upgraded to 2009-12-08.

    Now - if I'm transferring files via MFS_FTP the TiVo crashes instantly if I try to do anything with TWP.

    Any idea why this might be?

    I can easily go back to the prior release, it doesn't appear there was much (if anything) affected for my old TiVo in the new release....

  10. #985
    Join Date
    Apr 2005
    Location
    Providence, RI
    Posts
    484
    I'm having general reliability issues with that particular tivo, so I don't think it's a TWP issue. The only difference between that one and my other (which is working fine) is ncid, so I need to look into the latest release there. I'll let you know if I find anything.

    Quote Originally Posted by glenstewart View Post
    Hi DJL - what did you find when you took a closer look?

    Thanks!
    More software at http://davidlauria.com/software.
    The lost alt-rock masterpiece from the '90s, Range of Motion's "Soft Buzz of Silence", is now available on iTunes!

  11. #986
    Join Date
    Sep 2009
    Posts
    6
    I'm by no means an experienced Tivo expert, but can speak from recent results with my S1 and watching how it behaves as I use MFS_FTP and some TCL scripts.

    What I see, is that the system cannot tolerate continued load for more than a certain amount of time, before it reboots to "correct" itself. If you watch the load that MFS_FTP places on the S1, it's substantial. I try to steer clear of running TCL scripts constantly, due to high RAM and CPU use. Instead of MFS_FTP, I use tools that use vserver (eg. vstream-client), which is much lighter on resource use.

    I used to run several different scripts, but now only TWP 2.0 constantly. I'm waiting for reports of stability and other benefits from 2.1 before trying it.

    Quote Originally Posted by vancod View Post
    My S1 TiVo was on the 2009-5-22 release for a long time. Recently I upgraded to 2009-12-08.

    Now - if I'm transferring files via MFS_FTP the TiVo crashes instantly if I try to do anything with TWP.

    Any idea why this might be?

    I can easily go back to the prior release, it doesn't appear there was much (if anything) affected for my old TiVo in the new release....

  12. #987
    Join Date
    Dec 2003
    Posts
    188
    Thanks for the info, and that makes sense. I assume the latest version of TWP causes the load to cross that threshold where in the past it did not.

    I really have not been keeping up "with the times" on TiVo hacking - but to my knowledge there is no other current toolset that allows for extraction and editing of ty files. I have no desire to do anything with content that still has the commercials in it - that's why I've stuck with MFS_FTP....

  13. #988
    Join Date
    May 2005
    Posts
    913
    If you have recent mfs binaries, you should be able to pull ty/tmf files directly from TWP.
    Former Tivo Hacker (retired)

  14. #989
    Join Date
    Dec 2003
    Posts
    188
    Quote Originally Posted by BTUxNine View Post
    If you have recent mfs binaries, you should be able to pull ty/tmf files directly from TWP.
    Sorry - is this process in docs somewhere? I doubt the binaries I have a very "fresh", but they've been patched along the way.
    There's only a couple binaries in my path:
    Sep 4 2002 bin/mfs_export
    Sep 6 2008 bin/mfs_uberexport

    Again, this is a really old TiVo..... and it's been years since I've read up on hacks / upgrades and what is "current"

  15. #990
    Join Date
    May 2005
    Posts
    913
    IIRC, if TWP can find mfs_uberexport in the path, extraction via TWP should be enabled... I'll check the code to verify.

    If you don't see links in the NSL, you should go to the rowformat module and reset the format string for NSL.
    Former Tivo Hacker (retired)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •