Results 1 to 7 of 7

Thread: R10 upgrade went horribly wrong !

  1. #1
    Join Date
    May 2008
    Posts
    6

    27 R10 upgrade went horribly wrong !

    OK, I have 5 R10's. I purchased 1 320 Gig & 4 500GB DB35 drives.
    I made a "TIVO.BAK" file as I upgraded each. Starting with R10 # 3 I backed up with no errors, but upon the restore I kept getting restore errors. This happened with the last 3 drives. (yes I put each "TIVO.BAK" in it's own directory after cycle. Do I have 5 directories.
    These were all 1 drive replacements (Not adding second drive)
    I was adding a 320 Gig drive to 1 unit & 500GB drive to the other four units.
    I used the Hinsdale upgrade process, w/ their CD.

    http://www.newreleasesvideo.com/hins...to/index9.html

    Configuration:
    Pentium 4 (5 years old, 512Meg memory)
    hda - Primary Master (Windows 98SE Drive C: Partition)
    hdb - Primary Slave - New Upgrade Drive (320/500GB)
    hdc - Secondary Master - Origional Tivo R10 Drive (80 GB)
    hdd - Secondary Slave - CDROM (Boot Unix CD)

    Commands:
    mkdir /mnt/dos
    mount /dev/hda1 /mnt/dos (No errors received)
    mfsbackup -f 9999 -6so /mnt/dos/tivo.bak /dev/hdc (No errors received)
    mfsrestore -r 4 -s 127 -bzpi /mnt/dos/tivo.bak /dev/hdb (restore errors rec'd)

    I can't figure out what went wrong. These were all working units.
    I'm afraid to pull the drive out of the working ok units.
    I even tried restoring from the 1st good drives "Tivo.bak" file,still got errors.
    I even tried putting the 320/500GB drives on my regular PC (3.4GHZ Dual-Core) system, formatting & testing the drives with western digital drive software. Reports surface is fine, no errors. (Took hours & hours to scan).

    When I try to power on the units, I get the sunrise, then the "Almost there. Just a few minutes more..." screen & it just stays there. Is their someone who sells a clean R10 image file? I'd hate to spend $ 100 for a new 80 GB drive from weeknees.com.


    Anyone have any ideas?

  2. #2
    Join Date
    Aug 2004
    Posts
    4,075
    Quote Originally Posted by macwizard8112 View Post
    ...
    I used the Hinsdale upgrade process, w/ their CD.
    ...
    Those instructions and software are dated and have problems with modern tivos. Try mfslive, winmfs or the weaknees instructions and software.

  3. #3
    Join Date
    Nov 2006
    Posts
    274
    Use winmfs from www.mfslive.org. Use it's copy function to upgrade each drive. If you copy each drive, and make sure the disk you put back in the tivo is the upgrade disk that was copied from the disk that came out of that box, that should keep any recordings on the drive, and keep you from having to Clear and Delete Everything.
    They say beer will make me dumb. It are go good with pizza!-----------
    3XR10, prommed, 3xdvr40,4xdvr39, all networked, ranging from 40GB to 750GB

  4. #4
    Join Date
    Dec 2004
    Posts
    116
    Or use the easy command line generator from the mfslive site:

    http://www.mfslive.org/cgen.php

  5. #5
    Join Date
    May 2008
    Posts
    6

    20 I will try

    I'll try it & let you know.

    Thanks.

  6. #6
    Join Date
    May 2008
    Posts
    6

    Angry Tried MFS live...got the following error

    During upgrade process got the following error:

    Backing up 112 of 1466 mb (7.63%) (84.18% comp) 4 mb/sec (ETA 0:05:14)kernel BUG at slab.c:1439!
    Invalid operand: 0000
    CPU: 0
    EIP: 0010:[<c013015d>] Not Tainted
    EFLAGS: 00010087
    eax: 160fc2a5 ebx: 0007b9f0 ecx: 00007b9f edx: c15d71c8
    esi: c2935000 edi: c2935724 ebp: defdfef4 esp: defdfedc
    ds: 0010 es: 0018 ss: 0018
    Process kswapd (pid: 5, stackpage=defdf000)

    All 3 drives gave similar errors. No I did NOT ever hook these to a Windows 2000 or Win XP system. Only hooked to a pc running win98SE. (as Secondary Master (HDC)).

    Any ideas?

  7. #7
    Join Date
    May 2007
    Posts
    456
    Try the WinMFS like crash said. It is one powerful and easy to use app...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •