Page 4 of 4 FirstFirst ... 234
Results 46 to 58 of 58

Thread: tvapppatch.tcl support

  1. #46
    Join Date
    Jan 2005
    Posts
    1,008
    Quote Originally Posted by Soapm View Post
    Was a file ever made for 11.0k
    It's in the 11.0k rollout thread here.
    ScanMan --> Just another Tivo hacker...
    Killhdinitrd SA S2 Monte S2 Unscramble Upgrade Tivo Software

  2. #47
    Join Date
    May 2007
    Posts
    456
    How do I know if the encryption is disabled on my TivoHD? Below is what I used after superpatch on my S2DT but ciphercheck on this Tivo responds "Not a TiVo super block! (magic=0xebbafeed)"

    /tvbin/crypto -gsn
    /tvbin/crypto -x -gek
    ciphercheck

  3. #48
    Join Date
    Jan 2005
    Posts
    1,008
    Quote Originally Posted by Soapm View Post
    How do I know if the encryption is disabled on my TivoHD? Below is what I used after superpatch on my S2DT but ciphercheck on this Tivo responds "Not a TiVo super block! (magic=0xebbafeed)"

    /tvbin/crypto -gsn
    /tvbin/crypto -x -gek
    ciphercheck
    Make sure you are using the 64-bit mfs_utils for the TivoHD found here.
    ScanMan --> Just another Tivo hacker...
    Killhdinitrd SA S2 Monte S2 Unscramble Upgrade Tivo Software

  4. #49
    Join Date
    May 2007
    Posts
    456
    Cool, do all of these just go in busybox? I saw ciphercheck there and replaced it so it now gives the correct response but is it safe to load all these in busybox?

    A lot of them I don't find on my Tivo but I haven't got to installing mfs_ftp and was thinking of only installing tyftp this go around so didn't plan on installing mfs_ftp...

  5. #50
    Join Date
    May 2004
    Posts
    253
    Just pick a random thread to post in, that will get you an answer.

  6. #51
    Join Date
    May 2007
    Posts
    456
    Quote Originally Posted by mike_s View Post
    Just pick a random thread to post in, that will get you an answer.
    If you look a little higher you will see my question started as a result of the patch which is the topic of this thread. So not so random if you allow room for being human...

  7. #52
    Join Date
    May 2004
    Posts
    253
    This thread is for support of tvapppatch.tcl. That's a utility which blindly reads files and does patching as instructed. It's not the patches themselves. I should know, I wrote it.

    If you're having problems with a specific patch, or don't understand what a patch does, or don't know how to check if a patch worked, this is not the place.

  8. #53
    Join Date
    May 2007
    Posts
    456
    Sorry Mike, seemed like a good place to me. If you want to know if your car is running right you go back to the dealership.

    I wanted to know if the patch worked right so I went back to where I got it. Sorry if my logic offended you...

  9. #54
    Join Date
    Mar 2005
    Posts
    235
    I think Mike's point was that you didn't get the patch from this thread, you got the program that applies the patch here. You got it the actual patch from another thread 11.0k starting to roll out . This thread had no mention of ciphercheck, mfs_utils, busybox, mfs_ftp, or tyftpd. It would be more appropriate to post questions relating to those utilities in their respective threads.

  10. #55
    Join Date
    May 2007
    Posts
    456
    See attached, after upgrading to 11m I can't get the patch to run. I can see the file in /var/hack and it's executable but it says it's not there when I try to run it. I've deleted the file several times and put a new version there but they all do the same thing. I've even tried moving it to the root directory and no change.

    Attachment 7583

    Nevermind, looks like I needed to run dos2unix and she worked like a charm. Thanks for the great app...
    Last edited by Soapm; 08-31-2013 at 07:45 PM. Reason: Resolved.

  11. #56
    Join Date
    May 2004
    Posts
    253
    Yea. When it says "file not found," it's the shell telling you it can't find "/tvbin/tivosh<cr>", the carriage return (<cr>) part of the DOS line ending being considered part of the file name under Linux.

  12. #57
    Join Date
    Jun 2010
    Posts
    60
    Quote Originally Posted by Soapm View Post
    See attached, after upgrading to 11m I can't get the patch to run. I can see the file in /var/hack and it's executable but it says it's not there when I try to run it. I've deleted the file several times and put a new version there but they all do the same thing. I've even tried moving it to the root directory and no change.

    Attachment 7583

    Nevermind, looks like I needed to run dos2unix and she worked like a charm. Thanks for the great app...

    Is the upgrade to 11m mandatory? It been at least 2 years since I played with the linux on my tivo so Im a bit out of sorts.

  13. #58
    Join Date
    May 2004
    Posts
    253
    Due to DDB deleting past posts with attachments, I added the most recent (!, 3 years old) versions to the first post. Maybe someone will figure out/post the new patches for the ur-S3 (648) - I won't have time to get to it for a while.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •