Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: Insertion questions...

  1. #1
    Join Date
    Feb 2009
    Posts
    23

    Insertion questions...

    After using Movieloader on my directivo with sw 6.4a for a couple of weeks now, I hve run into a couple of issues that I can't seem to find answers to by searching the forums. I am also not sure if they are Movieloader issues or MFS_FTP issues... hence the post in this area instead of one of those threads...

    I am converting VOBs to tmf using VideoReDo to convert to mpeg, ffmpeg with ty support to convert to ty, and finally ty+2tmf via perl to convert to tmf (3 steps).

    My issues:

    1. The inserted tmf files show a 0:00 duration in the NPL, but still play with the normal green bar at the bottom of the screen showing the correct duration during playback.

    2. Is there a way to edit what data is rolled into the tmf file, before or after, using the pearl script? I can access the programs with TWP to edit basic info, but what about things like ratings? For example, I would like to make a R rated movie show up as "R", so my 7 year old doesn't "accidentally" watch an R rated movie I've inserted.

    3. For some reason, the VOBs I've inserted play with a VERY slight (almost unnoticeable) amount of occasional (but repeatable) "glitches" in the video. I thought it might be one of my conversion steps, but I don't think I'm really altering the video stream in any of my steps... I use -acodec copy and -vcodec copy in my ffmpeg command line, and as far as VideoReDo goes, I simply load the VOB and go directly to "save as" and my settings for the output file are 4 MBits Bitrate for video and 224 Kbps bitrate audio (after reading the help file, I do not even believe these alter the stream, but rather are used if the input file has an unconventional stream going into it). This issue is really almost a non-issue, but I do not know if it is MFS_FTP related or not. I am hoping someone has seen this and knows where I need to go look for the source of the issue.

    I appreciate your assistance and thoughts...

    Bill

  2. #2
    Join Date
    Dec 2004
    Posts
    116
    You may be seeing an artifact of 24 or 25 frame per second video. I'm not sure if Tivo handles 3:2 or 2:3 pulldown during playback. You might try using FFMPEG to convert the VOB to MPG instead of VideoReDo and use the -r 29.97 switch to make sure it's the right framerate. If it is the right framerate already, you'll be able to use FFMPEG with -vcodec copy to convert the VOB to MPG. If you have to change the framerate, you can't use -vcodec copy.

    You can also try this: http://www.videohelp.com/tools/VOB2MPG

    Issue 1 is normal. I haven't been able to fix it. I've never learned how to do 2, but if you search around here and Tivo Community forum, I think rbautch has released some utilities for that purpose.
    Last edited by Rorschach; 04-01-2009 at 05:59 PM.

  3. #3
    Join Date
    May 2005
    Posts
    320
    There's no reason to convert the VOB to MPG first anyway. You can use ty-enabled ffmpeg to go directly from VOB to TY. If you have a proper XML template to use, you can insert that into the TY during that step as well. That would be how you could get something like movie ratings to show up.

  4. #4
    Join Date
    Feb 2009
    Posts
    23
    Quote Originally Posted by whitepelican View Post
    There's no reason to convert the VOB to MPG first anyway. You can use ty-enabled ffmpeg to go directly from VOB to TY. If you have a proper XML template to use, you can insert that into the TY during that step as well. That would be how you could get something like movie ratings to show up.
    The only reason I was converting to mpeg first was to compress the video so the file would not be so large... Ty enabled ffmpeg does not reduce the bitrate for me... no matter what I use on the command line I get the same results on the output stream. That said, both of these ideas are certainly worth trying. I'll let you know how it goes.

    As for the xml, I am going to tackle that after I resolve the video problem.

    Thanks for the replies,
    Bill

  5. #5
    Join Date
    Feb 2009
    Posts
    23
    Quote Originally Posted by Rorschach View Post
    You might try using FFMPEG to convert the VOB to MPG instead of VideoReDo and use the -r 29.97 switch to make sure it's the right framerate.
    I went ahead and tried this, but got the exact same results. I have tried inserting the video to both of my tivos, and the results are the same on both.

    My next step is to completely remove the audio stream and see what happens. I am fairly certain I've already tried the -vcodec copy -acodec copy to go straight to a ty file as whitepelican suggested, but if removing the audio does not correct this, then I will be trying that next...

    In case I am missing something, here is the start of my output (from this attempt to remove the audio) using winff:
    D:\Tivo Video Work\WinFF>chcp 1252
    Active code page: 1252

    D:\Tivo Video Work\WinFF>title Converting VTS_01_1.VOB (1/1)

    D:\Tivo Video Work\WinFF>"D:\Tivo Video Work\WinFF\ffmpeg.exe" -i "F:\VOB\EAGLE_EYE_D1_AC\VIDEO_TS\VTS_01_1.VOB" -vcodec mpeg2video -s 544x480 -r 29.97 -b 4000kb -an "D:\Tivo Video Work\ffmpeg\VTS_01_1.mpg"
    FFmpeg version SVN-r16573, Copyright (c) 2000-2009 Fabrice Bellard, et al.
    configuration: --extra-cflags=-fno-common --enable-memalign-hack --enable-pthreads --enable-libmp3lame --enable-libxvid --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libfaac --enable-libgsm --enable-libx264 --enable-libschroedinger --enable-avisynth --enable-swscale --enable-gpl
    libavutil 49.12. 0 / 49.12. 0
    libavcodec 52.10. 0 / 52.10. 0
    libavformat 52.23. 1 / 52.23. 1
    libavdevice 52. 1. 0 / 52. 1. 0
    libswscale 0. 6. 1 / 0. 6. 1
    built on Jan 13 2009 02:57:09, gcc: 4.2.4

    Seems stream 0 codec frame rate differs from container frame rate: 29.97 (30000/1001) -> 59.94 (60000/1001)
    Input #0, mpeg, from 'F:\VOB\EAGLE_EYE_D1_AC\VIDEO_TS\VTS_01_1.VOB':
    Duration: 00:59:50.43, start: 0.205367, bitrate: 12743 kb/s
    Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x480 [PAR 32:27 DAR 16:9], 9800 kb/s, 59.94 tb(r)
    Stream #0.1[0x20]: Subtitle: dvdsub
    Stream #0.2[0x21]: Subtitle: dvdsub
    Stream #0.3[0x80]: Audio: ac3, 48000 Hz, 5.1, s16, 448 kb/s
    Output #0, mpeg, to 'D:\Tivo Video Work\ffmpeg\VTS_01_1.mpg':
    Stream #0.0: Video: mpeg2video, yuv420p, 544x480 [PAR 80:51 DAR 16:9], q=2-31, 4000 kb/s, 29.97 tb(c)
    Stream mapping:
    Stream #0.0 -> #0.0
    Press [q] to stop encoding
    For those who haven't seen my post in the files thread, there is additional info on the things I've tried thus far: http://www.dealdatabase.com/forum/sh...9&postcount=14

    I know you told me to use MP2 audio Rorschach, but if I can't keep my Dolby 5.1 track (which my dtivo sends to my a/v box via fiber), then the whole process of watching ripped dvds on my tivo box really begins to loose its appeal to me. This most recent attempt should tell me whether the audio stream is a factor in my video problem or not... (in theory).

    ---- UPDATE ----
    Removing the audio stream resulted in some improvement in the video playback... I am not sure where to go from here now. The video quality was decent, but I am not sure it would be acceptable at 3000 kbs or 480x480. I also do not know what the effect of reducing the audio bitrate will be....
    Last edited by GBill; 04-02-2009 at 12:45 AM. Reason: Update

  6. #6
    Join Date
    May 2005
    Posts
    320
    Quote Originally Posted by GBill View Post
    The only reason I was converting to mpeg first was to compress the video so the file would not be so large... Ty enabled ffmpeg does not reduce the bitrate for me... no matter what I use on the command line I get the same results on the output stream. That said, both of these ideas are certainly worth trying. I'll let you know how it goes.

    As for the xml, I am going to tackle that after I resolve the video problem.

    Thanks for the replies,
    Bill
    That doesn't make any sense to me. I don't believe VideoRedo can transcode the video to compress it. If you are just setting a lower bitrate on the "Save as" options, I think that is just a flag in the video stream, and as far as I know it's not actually transcoding the video. If you're getting jerky video after doing that, then I would say it is a result of VideoRedo's processing. FFmpeg can certainly be used to transcode the video to a lower bitrate by using the -b option (I personally don't see why you would want to waste the time to do that just to lower your DVD's quality). If ffmpeg isn't giving you smaller file sizes, you might try using the 2-pass encoding, so that you can achieve a more accurate bitrate. But I've probably done dozens (maybe a hundred?) DVD-to-TMF conversions, and the video always looks fine. I only use DVDDecrypter to rip the DVD, and then ty-enabled ffmpeg to convert the VOB to TY, plus ty+2tmf.pl to create the TMF.

  7. #7
    Join Date
    Dec 2004
    Posts
    116
    Change it to:

    D:\Tivo Video Work\WinFF>"D:\Tivo Video Work\WinFF\ffmpeg.exe" -y -i "F:\VOB\EAGLE_EYE_D1_AC\VIDEO_TS\VTS_01_1.VOB" -vcodec mpeg2video -async 1 -mbd rd -trellis 2 -cmp 2 -subcmp 2 -g 100 -s 544x480 -r 29.97 -b 5800k -acodec copy "D:\Tivo Video Work\ffmpeg\VTS_01_1.mpg" -- The extra switches enable FFMPEG's high quality encoding capabilities and of course slow things down a bit. They are optional. Keep the -async 1 if your original has AC3 audio or the video/audio won't be synced properly. The 5800k bitrate matches the maximum bitrate Tivo's hardware was originally speced to handle. Anything higher invites problems.

    The Tivo will not play a 9800 kb/s, 59.94 tb movie. That's a progressive MPG and Tivo only plays interlaced so you have to transcode it. A direct copy will not play. It will play the AC3 5.1 audio so you don't have to change that or remove audio. By the way, don't use the -b switch with -4000kb it should just be a -4000k -- k not kb. Your problem may be a single letter in your FFMPEG command line.

    I tried the VOB2MPG utility and it created one good MPG file from the many VOBs on a DVD. Your problem is the VOB to MPG step for sure. The other poster says he is making the VOB to TY conversion in one step with the ty enabled FFMPEG. I haven't done that because it's very slow, but it's worth another shot. The VOB2MPG utility is slow too, but it corrects all the timestamp info in the process of combining all the VOBs together.
    Last edited by Rorschach; 04-02-2009 at 11:17 AM.

  8. #8
    Join Date
    Feb 2009
    Posts
    23
    Quote Originally Posted by Rorschach View Post
    By the way, don't use the -b switch with -4000kb it should just be a -4000k -- k not kb. Your problem may be a single letter in your FFMPEG command line.
    I thought the same thing, but that was the switch in the winff presets... I am pretty sure it is working since my output stream looks like:
    Stream #0.0: Video: mpeg2video, yuv420p, 544x480 [PAR 80:51 DAR 16:9], q=2-31, 4000 kb/s, 29.97 tb(c)
    I am going to try your command line recommendations next... I actually removed some of those switches from the default winffmpeg command line because I couldn't find documentation of what some of them were doing on ffmpeg.org.

    I did not try VOB2MPG yet, because I did not think I needed the extra step. I currently use Magic DVD ripper, and it has an option to create a single VOB from my DVDs... If I exhaust all of my options (or just get fed up) with winff I will give it a try for sure.

    As far as whitepelican's observations, my reason for using videoredo was that I've read in several places on this board that it "washes" the video steam and apparently minimizes timestamp problems. It does not compress it at all. I personally really didn't care to use it if I didn't have to. Last night I tried for the first time to go from VOB to mpeg with winff, and I recieved the same results. SO, I too do not see the need for it in my situation as it stands now.

    My reason for compressing the video is that I have a wireless setup with one of my tivo boxes, and the transfer times of the larger files prohibits me from watching them during the transfer unless I do so... It also saves space. Converting from VOB to mpeg using Ty enabled ffmpeg (v1.7) gives me zero compression for some reason. I try to specify a lower bitrate, but for some reason, it still shows my output stream at a higher bitrate, and the file sixe is equal to my VOB size. However, given that others have been successfull with using it to go from VOB to TY, I will also try that again as well.

    I will post my results later this afternoon. Thank you for all of the suggestions that both of you have provided.

  9. #9
    Join Date
    Dec 2004
    Posts
    116
    The switches I recommended came from the FFMPEG FAQ:

    http://ffmpeg.mplayerhq.hu/faq.html

    WINFF's switches are not supported in the latest FFMPEG builds in many cases. The advantage to FFMPEG is the speed and quality of the output.

    The VOB2MPG utility does not do any transcoding and it allows you to pick the soundtrack from available choices on the disk. Many DVDs have AC3 2 channel 192kb audio and that's a good choice for Tivo. It's slow but it does exactly the job that you are looking for and it's free.

  10. #10
    Join Date
    May 2005
    Posts
    320
    Quote Originally Posted by Rorschach View Post
    That's a progressive MPG and Tivo only plays interlaced so you have to transcode it. A direct copy will not play.
    This has not been my experience at all. I only have HR10-250's now, so I can't test at the moment. But I know in the past that I ripped many DVDs to TY using "-vcodec copy -acodec copy" and never re-encoded to interlace the video. Those resulting files would have always been 720x480 progressive scan MPEG2, and they always played fine on either SD or HD DirecTivos. Honestly, I don't understand why this is a problem, outside of GBill's desire to compress the video.

  11. #11
    Join Date
    Dec 2004
    Posts
    116
    I think you're right. I've been able to play most anything ripped too. I think the FFMPEG output was deceptive and I was trying to come up with something to explain the problems. It's probably some kind of unknown user error. With all the hacks and the low cpu power of the Tivo, a high bitrate file will tax the tivo's capability and cause some jitter or hiccups sometimes. I think the guy has a lot of hacks stealing CPU cycles, so maybe the setpri thing will help him out too. I am pretty sure he's not converting the VOBs to MPG properly though and that's probably what's wrong too.

    I tested some MPG files that were 24 frame and 25 frame pulled down via DGPulldown to 29.97 and the Dtivo will play those too, so it can do more than I gave it credit for.

    One strange thing I'm noticing is when I go to play the movie on the tivo for the first time, the movie begins in the middle somewhere instead of at the start - as if I'd played and resumed, but I haven't.

    I can't import a TY file with MFS_FTP/Movieloader and play it. It always results in a reboot of the Tivo if I try. I have to convert the ty to tmf. Has that been your experience? With tivoserver/6.2a no problems with ty files.

  12. #12
    Join Date
    Feb 2009
    Posts
    23
    OK... After many attempts and re-reading everything both of you have written me, I think I understand what is happening...

    I took a VOB and converted to ty using only ty enabled ffmpeg. I used -vcodec mpeg2video -s 544x480 -r 29.97 -b 6000k -acodec copy -async 1. The video seems to jitter as you describe, but only if my tivo is working at doing something else at the same time... For example, if I try to watch the movie while it is still transferring it, it jitters, but if I wait until it is done, everything seems better.

    I do notice that my tivo plays 544x480 better than 480x480 (at least for this one video I have been playing with for about a week now).

    I now also realize what I was doing wrong with ty ffmpeg with regards to reducing the bitrate... The command line I used above works, and all the switches do what I expect.

    I also notice the same behavior when I try to import ty files as you Rorschach, but I think it was because I imported it into the ty folder instead of the ty+ folder... I haven't re-tried that one yet.

    SO, now I am curious about my tivos behavior. I do not believe I have all that many hacks running, but who knows. I am using the relatively old Hughes SD-DVR40 dtivos. I am also doing a kernel chainload to allow me to run wirelessly using 6.4a software.

    Is there anything I can do or check? Both tivos have new drives that are much larger than the 40gb original drives... I remember reading about swap files and such when upgrading drive size, but I never changed any of those settings. I guess I could simply live with the fact that I can't do too much at the same time. What is also interesting is that one of the tivos only has one satellite input, but exhibits the same behavior as the one connected with two inputs.

    Thanks for the help guys,
    Bill

  13. #13
    Join Date
    Dec 2004
    Posts
    116
    You left out some very critical information in your original posts there guy. Obviously, your problem has nothing whatsoever to do with transcoding or inserting or anything you've focused on in your many messages. The Tivo's CPU has very little processing power or memory to use - it barely has enough to do its essential functions. Your setup has got to be using a lot of CPU power, especially the wireless networking hack. It's probably using the SWAP for memory all the time just to operate. Your video playback will suffer.

    You can try the setpri command as I suggested so that Tivo programs get higher priority than hacks. It has to be set prior to running hacks, so it must run prior to starting any. Who knows how your hacks are organized or in what order they run or even what they are in the startup hierarchy.

    I think your easiest fix is to use a wireless bridge instead of the kernel chainload wireless setup. That alone is going to hog resources and screw up playback.

  14. #14
    Join Date
    Feb 2009
    Posts
    23
    Quote Originally Posted by Rorschach View Post
    You left out some very critical information in your original posts there guy. Obviously, your problem has nothing whatsoever to do with transcoding or inserting or anything you've focused on in your many messages. The Tivo's CPU has very little processing power or memory to use - it barely has enough to do its essential functions. Your setup has got to be using a lot of CPU power, especially the wireless networking hack. It's probably using the SWAP for memory all the time just to operate. Your video playback will suffer.

    You can try the setpri command as I suggested so that Tivo programs get higher priority than hacks. It has to be set prior to running hacks, so it must run prior to starting any. Who knows how your hacks are organized or in what order they run or even what they are in the startup hierarchy.

    I think your easiest fix is to use a wireless bridge instead of the kernel chainload wireless setup. That alone is going to hog resources and screw up playback.
    Hindsight certainly is 20/20. What may be obvious now was not so obvious to me when I originally posted. I am just starting out here; try to cut me some slack okay? Contrary to what you may think, I am not a complete *****. Doesn't the fact that this only happens with inserted video at least imply that my problem might have something to do with transcoding?? For what it's worth, I tried a straight -vcodec copy -acodec copy with ty enabled ffmpeg of the same VOB again, and my tivo did not play it well at all. Even when I was not recording on any tuner, and even with both tuners selected to a "dead" channel.

    As for the “very critical information” I left out, I assumed that we are all running some sort of hacked tivo box, and that my method (while a bit less common) is not unique.

    I know you read my post in the other thread where I stated:
    I thought... "maybe the stream is TOO much for my s2 dtivo to handle", so I compressed to 480x480 4:3, but all I got was a visibly more compressed stream with the same "jerky" playback.
    I guess I need to do some reading, but I don’t understand how my monte setup is hogging resources…

    I now plan on going back to a simple killinitrd kernel on my tivo that is wired (I kept them both configured the same for simplicity) to see if that will solve this issue.

    Thanks for your time and suggestions.
    Last edited by GBill; 04-04-2009 at 02:47 AM.

  15. #15
    Join Date
    Dec 2004
    Posts
    116
    You can see why I might think you weren't a newbie when you are chainloading kernels before you've posted many messages. However, using the Dtivo to operate the wireless network connection is the CPU hog, not necessarily the monte setup that gets you there. It takes a lot of CPU power and that's why Tivo invented the Tivo wireless connector to take some load off the CPU. If you are using a dongle other than the Tivo wireless connector, then I'm certain that's the problem. If you've actually got a subsystem supporting the Tivo wireless adapter, your CPU will be less affected. But seriously the Tivo has literally no horsepower to spare and the jerky playback is symptomatic of that issue, not a transcoding issue where the playback will stop and start and freeze up.

    My last suggestion is to use the latest third party or 0.5 FFMPEG binary to make the MPG and the ty enabled FFMPEG to make the ty file from that. Actually that VOB2MPG thing might be better to make the MPG.

    I don't think too poorly of you - look at all my dumb questions that resulted in the guide to do this? For all I know your Tivo box is screwed up and nothing we're discussing is going to make the slightest difference.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •