Results 1 to 6 of 6

Thread: OZ: Hacks and Kernel Patch no longer appears to work after update?

  1. #1
    Join Date
    Feb 2009

    OZ: Hacks and Kernel Patch no longer appears to work after update?

    Hi All,

    I have just tried to reapply my hacks to my Aust TivoHD and nothing appears to work anymore?

    Here is my
    echo "Start"
    export PATH=$PATH:/hack/bin:/hack:/var/hack
    # Turn Off Firewall
    iptables -F
    echo "Make sure /var/.bash_history still xists"
    touch /var/.bash_history
    #echo "Start Bash on Serial"
    #/bin/bash < /dev/ttyS1 &> /dev/ttyS1 &
    echo "Start telnet"
    tnlited 23 /bin/bash -login &
    echo "Start FTP server"
    /hack/bin/tivoftpd &
    echo "Start endpadplus"
    /hack/endpadplus/endpadplus.tcl 2 13 -shd -nob2b -auto &
    echo "Check if /var has been cleared"
    if [ ! -d /var/hack ]; then
    	echo "/var/hack is missing rebuilding TivoWebPlus & mfs_ftp"
    	cd /var
    	mkdir hack
    	cd hack
    	tar xvzf /hack/backup/tivowebplus.tgz
    	tar xvzf /hack/backup/mfsftp.tgz
    	touch /var/var.cleared
    echo "Start TivoWebPlus"
    /var/hack/TivoWebPlus/tivoweb &
    echo "Start mfs_ftp"
    /var/hack/mfs_ftp/mfs_ftp.tcl &
    touch /var/last.reboot
    echo " is finished"
    At first I thought they may have replaced the kernel on the drive so I backed it up using winmfs then repatched it with ReplaceInitRdTool which is exactly what I did when initially modding this unit (previously worked)

    For the life of me I can't get telnet or ftp to startup??

    I mounted the tivo drive with mfslive and all the hacks I had previously added were all still on the drive.


    One thing I did notice lastnight when I downloaded the gzip update files lastnight before the update was the following files which were different between the two versions.
    Can anyone think of anything I may have missed????

    Is it possible that is no longer running by default and I need to add it somewhere?

    I have backed up all of my /etc directory if anyone wants to have a closer look pm me.

    Lets hope I just missed something simple and lets hope Tivo have not tried to stop modding the aust units.

    PS: I checked that the IP address didn't change so it's not something as amatuer as that
    PPS: HME apps still work so it's still definitely on the network.
    Last edited by pdd; 03-27-2009 at 03:46 AM.

  2. #2
    Join Date
    Feb 2009
    An update...

    I just extracted the entire /etc directory from an old image (old software) with working hacks and compared via svn this directory to my current(non working) /etc....

    They are exactly the same in every way.

    This is stranger still??

    There is no way they could have modified the PROM I am assuming... and even if they did then the machine wouldn't boot as it has my patched kernel on it..

    By the way the tivo boots fine and works as a normal factory tivo. Just no telnet or ftp

  3. #3
    Join Date
    Feb 2009
    Another mystery....

    I just mounted the drive on my PC in mfslive
    mount /dev/sdb4 /tivo

    I then copied over a PRE PATCHED tivoapp with all the patches I found today... they don't work either the system behaves as normal??

    Are there two partitions here?

    Have I been modding an old one that is no longer in use?

  4. #4
    Join Date
    Feb 2009
    Just to keep things rolling with my 4th post to myself
    (you guys in the US are all probably still asleep)


    Nobody told me there were two partitions that the tivo can boot from.... well actually I do remember reading that somewhere ages ago..

    When I first hacked my tivo I mounted /dev/sdb4 and placed all my hacks in there....

    Now after the update it is now using /dev/sdb7

    I have just copied across all of my hacks from /dev/sdb4 to /dev/sdb7 and everything is working as expected...

    Trap for young players.... I was in the wrong partition

    I am assuming when updates happen they are applied to another partition so if the update fails it can roll back to a previously working version of the software?

    Smart move Tivo.... cept it stuffed me up for a few hours...

    All working as expected and I learnt something new

    Also patches I posted previously are all working too... haven't done bufferhack yet... that can wait till another time.

  5. #5
    Join Date
    May 2004
    If you copied any TiVO files (e.g. tivoapp) from the old partition to the new, you will likely have problems. When an update is installed, it comes as a set (not only the files in the linux partitions, but also changes inside MFS), and everything is designed to work together.

    tivoapp patches (at least the locations) are almost always different between versions.

  6. #6
    Join Date
    Feb 2009
    I only copied the hack files ie new files uploaded for hacking purposes none of them were tivo files from the old version. The tivoapp file I had patched was the new one so no problems there.

    Its all working perfectly now. Ended up applying bufferhack too and all good there as well.

    I do however have a copy of the new tivoapp on the old partition which is not currently in use... Pretty sure this will get overwritten during the next update.
    Last edited by pdd; 03-27-2009 at 10:24 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts