Results 1 to 13 of 13

Thread: Tivo HD stuck at "Welcome! Powering up..."

  1. #1
    Join Date
    Aug 2009

    Tivo HD stuck at "Welcome! Powering up..."

    Hey all,
    I have a Tivo HD with a prom mod that's been running fine for the past year or so. A few days ago I found it was not powered on. When I try to power it on, it does not get past the "Welcome! Powering up..." screen.

    I've tried a few things so far with no luck.

    I cannot get into kickstart mode (by holding Pause on the tivo remote). The amber/red lights never come on.

    I've connected the drive to my home pc and it seems ok (I could access the partitions w/ MFS Live). I ended up restoring the original backup I created w/ WinMFS. However, that didn't help.

    I have also tried another spare hard drive I had, but that has the same results.

    I have tried removing the onboard battery to reset any saved settings and I have pulled the cable card and unplugged everything (except for the power cable and hdmi cable). The one thing I did notice is that the green and amber ethernet lights are constantly lit, even without a cable plugged in, however I'm unsure if that is normal or not.
    I saw some posts about capacitor issues, but all the caps look fine.

    Does anyone have any thoughts on what else I should look at?

    Last edited by Jagged; 03-15-2011 at 05:54 PM.

  2. #2
    Join Date
    Dec 2007
    Wow, that sounds EXACTLY what I'm currently going through with my TiVo HD, including all the same troubleshooting steps. Only differences are that mine doesn't have a PROM mod, and mine also sat in storage for about 6 months after I got my Premiere. I was getting it prepped to give to my parents when it began acting up.

    I haven't figured out the problem with mine just yet, but here's what I know so far...

    After going through several different hard drives and not getting anywhere on my own, I arranged to borrow a TiVo HD from a coworker. My plan was to swap hard drives, logic boards, and power supplies around a bit until I isolated which major component was failing in my unit. I hadn't figured out what I would do after depends on what I found to be the problem.

    Unfortunately, when I got my coworker's unit home last week, I found that it too was dead. Somewhat fortunately, though, his issue was rather obvious: half a dozen bulging capacitors in his power supply.

    I ordered replacement caps from and when they get here in the next day or two I'm going to repair his power supply and then get back to troubleshooting my unit.

    Like your TiVo, the power supply in mine looks good - there are no obviously failed capacitors. I also have an ESR meter that I used to test all the capacitors on my power supply, and there were no obvious failures, but there were a few that were a little outside the nominal values. I'm not 100% sure that's enough prevent the TiVo from working, though.

    Interestingly, the power supplies in the two TiVo HDs I have on hand are quite different. My coworker's unit looks pretty much like the one for sale at Weaknees, and is fairly substantial. Mine, however, has a much lower component count and practically screams "cheap" in comparison.

    My gut is currently telling me that this is a power supply issue (perhaps TiVo tried to reduce the cost of the power supply with a simpler, less expensive model, but ended up cutting too many does have fairly high current ratings, and it just looks less "beefy" than other high-current power supplies I've dismantled).

    In any case, I won't know more for a couple more days until my Mouser order arrives and I get a chance to repair my coworker's power supply and then test it in my unit. My Mouser order does include a complete set of replacement caps for my own power supply, so if mine does turn out to be dead I'll try replacing all the capacitors first.

    Any chance you can post a photo of your power supply? I'm curious if ours both have the simplified design...

    I'll post more as soon as the parts get here and I have a chance to break out my soldering iron.

  3. #3
    Join Date
    Aug 2009
    I believe mine is similar to yours (in that it looks very cheap/simplistic). There's not a ton to it. I'll try to post a picture this evening. I'll be interested to hear how things work out for you.


  4. #4
    Join Date
    Dec 2007
    Well, I got the other power supply repaired last night, but unfortunately that didn't revive my TiVo. My hard drive also booted up the other TiVo without issue, so it's definitely looking like a logic board issue at this point, which means there's probably not a whole lot we can do about it.

  5. #5
    Join Date
    Mar 2003
    Have y'all tried connecting a serial port to your TivoHDs to see what is coming out of it at boot time?

    My Tivo S3 once had a weird problem where it wouldn't boot - it got stuck with all of the LEDs lit on the front panel, and the solution turned out to be pulling the battery off the logic board for an hour or two.

  6. #6
    Join Date
    Aug 2009
    Quote Originally Posted by swinokur View Post
    Have y'all tried connecting a serial port to your TivoHDs to see what is coming out of it at boot time?

    My Tivo S3 once had a weird problem where it wouldn't boot - it got stuck with all of the LEDs lit on the front panel, and the solution turned out to be pulling the battery off the logic board for an hour or two.
    Thanks swinokur,
    I tried pulling the battery, though not for that long, I don't think (about 10min or so). I'll pull it and try it tomorrow.

    I have not tried tapping into the serial port, yet as it requires a special adapter (or some have recommended using a nokia usb adapter). That'll probably be one of my next steps.

  7. #7
    Join Date
    Aug 2009
    I just wanted to provide an update that removing the battery did not resolve the issue.

  8. #8
    Join Date
    Dec 2007
    Ok, this is weird... mine is alive again. I think. Unfortunately, I don't know what I did to make it work.

    Here's what I did over the weekend:

    1) Booted my TiVo HD hard drive in my buddy's TiVo. That worked fine. EDIT: came up saying "hardware error has been detected", I assume due to the drive swap.
    2) Did a Clear & Delete Everything while running it in the other TiVo.
    3) Booted again on other TiVo, but did not run guided setup.
    4) Moved hard drive back to my TiVo. No luck. Same reboot loop as before.
    5) Pulled CMOS battery for a few minutes (really only long enough to test its voltage with my multimeter--didn't think about pulling it for an extended period). No effect.

    After that, I left it alone for a couple days.

    Tonight after I got home from work, I scrounged up my USB to serial adapter (a Belkin adapter using the PL2303 chipset, FWIW) and a jumper cable to connect to the header on the logic board. I had the same thought...see if there are any messages on the serial console indicating what might be the problem.

    Booted it up with the serial cable attached and a terminal emulator running. I must have had the baud settings wrong (9600), because all I got was a bit of gibberish right when it powered on. So, I pulled the power, changed the baud settings, and tried again with 115200. More jibberish. But, I let it keep booting anyway and, lo and behold, it booted successfully. Pulled the power, rebooted without the serial cable attached, and it still booted up fine, and prompting me to go through guided setup again.

    So, at the moment, it seems to be working...however, I just started going through the setup again and on the "Activate Your Service" screen, it says:

    Have your service number handy: Not Available

    I'm not sure if I should be concerned about this or not and if I should try to continue.

    Also, just for reference, does anyone know what the right serial port settings are? I couldn't find it in a few minutes of Googling and decided to go by trial and error, but if someone can point me to a reference, that'd be great.
    Last edited by dcorder; 03-23-2011 at 02:28 AM.

  9. #9
    Join Date
    Dec 2007
    Ok, the "Not Available for the TSN" was apparently just due to the hard drive swap (and me panicking a bit) that I've gone through guided setup followed by another clear & delete everything, it seems to be OK...I'm currently going through guided setup again.

    I *really* wish I could tell you what it was that brought my TiVo back to life, but honestly, I have no clue (and that bugs me).

  10. #10
    Join Date
    May 2004
    Some electronics are manufactured with claustrophobia. Once you open the box, the problems go away.

    Seriously, it could be something like a cold solder joint, and moving it around simply got it to make contact again. It may crap out again in a day or a decade...

  11. #11
    Join Date
    Feb 2004
    New York City
    On the first refurbished TiVo HD I bought directly from, the Xcode MPEG2 encoder died 10 days after unboxing the TiVo. The TiVo would only boot up successfully one time out of about 10-15. Sometimes it would boot up 2-3 times in a row, then stop working for a day or so. The serial output indicated a problem initializing the xcode kernel module and the TiVo would just die (reboot) at that point. I had to send the box back to TiVo and get it replaced.

    Do you have any analog cable channels? try tuning to a analog channel and see if it works. If the Xcode chip is malfunctioning, it will just be a black screen.

    Even if it's not this particular chip, another part of the motherboard could've gotten a loose connection as mike_s said.

  12. #12
    Join Date
    Aug 2009
    I received my usb ttl adapter and got some output. Unfortunately, I'm stuck at this point.. I've tried a couple of different drives, with no success (the original WD 160gb and a new 1tb samsung).

    I'm guessing the SATA controller has gone belly up, but I'm wondering if anyone has any other suggestions?



    I should also add that I've tried an external power adapter and a different sata cable for the hard disks, I've reimaged (and even tried InstantCake, as well, just in case something was wrong w/ my winmfs backups).

    CPU-REV 0x74010021 C1
    read C1=00000008
    write C1=0000000f
    read C2=00000015
    write C2= 00000039
    First Read Center =0000000e
    First Write Center =00000024
    read C3=0000000e
    write C3= 0000000f
    read C4=0000000e
    write C4= 00000039
    New Write Center = 00000024
    read C5=00000008
    write C5= 00000024
    read C6=00000014
    write C6=00000024
    New Read Center = 0000000e
    read_width =0000000c
    write_width =0000002a
    starting to load uncached text
    loaded uncached text
    verified uncached text
    loaded zimage
    verified zimage
    inflating zimage (40000 bytes)
    inflated zimage  (92432 bytes)
    flushed cache data
    expanded bss
    flushed cache bss
    checked sha
    IDE drive(0): Disk not responding to device selection
    autoboot failed to read boot sector
    Service number is XXXXXXXXXXXXXXX.
    What is password?
    Last edited by Jagged; 04-01-2011 at 09:24 PM.

  13. #13
    Join Date
    Sep 2007

    Symptoms of a dying Power Supply

    Probably not your issue, but I just had a similar problem with a S2 RCA DVR40 DTivo. About 2-3 weeks ago I was finding it "off" (i.e., no response to "Live TV" or "Menu" buttons) in the morning with the red record light on (I always put it in standby overnight). Unplugging it and plugging it back in worked OK to get it going again for a little while. Then it started freezing in menus, requiring restarts. Sometimes I would have to boot it up twice b/c it would freeze up after the first reboot. Then more recently, images were sometimes garbled, like there was rain interference, but the weather was clear and good 95+ signal strength.

    Then this morning, it was "off" again with red light on (like it was recording, but not on and not responding to buttons). I tried a power cycle but it froze on the grey "Welcome. Powering Up..." screen. Thought maybe the HDD was bad so I swaped in another, and no go. Tried the HDD in another DTivo I have (a DVR80 that is blacklisted b/c the previous owner never settled their bill)...and it booted to the "hardware error" (due to wrong HDD installed). Crap. Looked like bad mainboard in the other one then.

    Then I tried booting it again and I noticed a weird high-pitched noise. I thought it was maybe the fan, so I unplugged it, and it still made the noise. Only thing I could figure at that point was it must be the p/s. Sure enough, I swapped in the power supply from the blacklisted DVR80 and I was back in business.

    I should note that I hadn't opened the box in over 4 years and there was considerable dust in the fan, causing it to virtually stop spinning and blocking nearly all airflow. My guess is the p/s overheated due to this and that's what caused it to die. So, I'm now going to open up my boxes every year or so and clean out all the dust as preventative maintenance. Hopefully this will help someone if they are worried about a bad mainboard, even if this isn't the problem the OP is facing.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts