Results 1 to 2 of 2

Thread: CPR for Series I

  1. #1
    Join Date
    Dec 2004
    Posts
    831

    CPR for Series I

    Lord, it's been so long since I worked on an S1, I've forgotten just about everything I ever knew. My old, reliable Philips S1 had a coronary a couple of weeks ago, and I would like to try resuscitating it before it goes on the trash pile. It's stuck in a reboot loop when I power it up with the upgraded drive it has had in it for years. It just comes up with the "Just a moment" TiVo splash, goes to black for a moment, then pops up the Tivo splash again. 'No GSOD, no gray screen. If I put the original drive (I think it's from this unit) back in, it just hangs on the splash screen.

    I can load the drive into WinMFS, and it recognizes the boot page and the partitions. I've thought about swapping the working partitions, but I'm not certain this drive ever received an upgrade, so the alternate partitions might be empty.

    I loaded it into a Linux boot, but while pdisk recognizes the partition map, tivopart doesn't recognize the drive as a valid TiVo drive. I would like to poke around by hand. What binary can I run under Linux that will allow me to read and write the S1 drive?

    Does anyone have any other suggestions I might try? This is an ancient S1, so I don't want to spend much time and no money at all on this project.
    Having trouble with TyTool? Try TyTool Documentation
    Need to hack an S3 / THD? Try S3 Hacking Script

  2. #2
    Join Date
    Jan 2002
    Location
    Sonoran Desert
    Posts
    2,829
    I would recommend building a serial cable, and configuring the bootpage to dsscon=true console=3,115200 and then dump the console output using a terminal app, then post it here. That would go a long ways towards figuring out the cause of the problem.

    You may need to alter those parameters a little bit as I don't remember the exact parameters the S1 uses (I haven't touched one in ages.) If you look around here, you should be able to find it.

    On top of that, examine all of the capacitors and make sure none of them are bulging.

    Finally, something that *may* help, is since winmfs appears to be working with the drive, I'd try using it to copy the drive to another drive, and then use that second drive. It may massage whatever MFS problem there may be as it rebuilds the partitions from scratch. If it is a problem with the hard disk failing, that would also resolve it.
    Before PMing me: Iím not your personal tech support. If you have a question, ask in public so I don't have to repeat if somebody else asks. If you want images or slices, use emule. I will ignore all support PMs.

    Sponsor a vegetarian! I have taken the pledge, how about you?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •