Page 9 of 10 FirstFirst ... 78910 LastLast
Results 121 to 135 of 144

Thread: tyftpd (mfs_ftp.tcl alternative)

  1. #121
    Join Date
    Mar 2005
    Posts
    233
    Well that was sloppy. The tcl script has been fixed in the 1st post, the helper should have been ok.

  2. #122
    Join Date
    Dec 2001
    Posts
    25
    For anyone still having trouble with tyftpd, do NOT run dos2unix on the helper file. That will corrupt the helper because the helper file is a binary file (not ASCII). Dos2unix is for ASCII type files only. Easiest way to fix this if the helper was inadvertently corrupted is to download and install the latest tyftpd.zip file.
    -dwellar

  3. #123
    Join Date
    Dec 2009
    Posts
    17
    I am trying - and failing miserably - to integrate s3tots into this. Any help? My c skills just aren't up to par.

    BCC successfully integrated it into mfs_ftp, but I have issues with mfs_ftp.

    BTW one thing I am trying to do is get the REST function working properly (an attempt at random access, basically I want to stream with xbmc) though I can't get anything to work at all.
    Last edited by Rakeesh; 07-29-2012 at 02:01 PM.

  4. #124
    Join Date
    Mar 2005
    Posts
    233
    Rakeesh,

    Sorry, but I am not sure I understand your post. Have you encountered a bug in RETR or are you attempting to implement REST? The RETR command is uesed to retrieve a file from the server. The REST command is used to adjust the start position for both RETR and STOR. Implementing REST properly would take some thought considering the different file types and dynamic nature of those files depending on if they are STOR or RETR.

  5. #125
    Join Date
    Dec 2009
    Posts
    17
    Quote Originally Posted by jkozee View Post
    Rakeesh,

    Sorry, but I am not sure I understand your post. Have you encountered a bug in RETR or are you attempting to implement REST? The RETR command is uesed to retrieve a file from the server. The REST command is used to adjust the start position for both RETR and STOR. Implementing REST properly would take some thought considering the different file types and dynamic nature of those files depending on if they are STOR or RETR.
    Sorry yeah I meant REST.

  6. #126
    Join Date
    Apr 2005
    Location
    Providence, RI
    Posts
    469
    This would be a great addition, if you can get it working. If I recall, BCC used a simple pipe into s3tots. It wasn't the fastest solution, but it did the job.

    Quote Originally Posted by Rakeesh View Post
    I am trying - and failing miserably - to integrate s3tots into this. Any help? My c skills just aren't up to par.
    BCC successfully integrated it into mfs_ftp, but I have issues with mfs_ftp.
    BTW one thing I am trying to do is get the REST function working properly (an attempt at random access, basically I want to stream with xbmc) though I can't get anything to work at all.
    More software at http://davidlauria.com/software.
    The lost alt-rock masterpiece from the '90s, Range of Motion's "Soft Buzz of Silence", is now available on iTunes!

  7. #127
    Join Date
    May 2003
    Posts
    5
    Is there a version of mfs_ftp_helper available for the Series 1 DTiVos? My wife's mfs_ftp keeps crashing (was working fine for years) so I thought I'd give this a try. But IIRC, the Series 1 units are PPCs and not MIPS.
    Dan T.
    RKBA!

  8. #128
    Join Date
    Aug 2004
    Posts
    102
    Check line 244: (in proc ProcessCommands {client} )

    HELP {reply $client "502 Sorry, no help is available.}
    should it be:
    HELP {reply $client "502 Sorry, no help is available."}


    Thanks for a great program.

  9. #129
    Join Date
    Sep 2004
    Location
    STL
    Posts
    135
    Quote Originally Posted by dwellar View Post
    For anyone still having trouble with tyftpd, do NOT run dos2unix on the helper file. That will corrupt the helper because the helper file is a binary file (not ASCII). Dos2unix is for ASCII type files only. Easiest way to fix this if the helper was inadvertently corrupted is to download and install the latest tyftpd.zip file.
    I just downloaded the latest version (1.8). Put the two files in \var\hack When I run it I have the following problem. Tried again after rebooting with similar results. Don't have the earlier version to try. Thanks in advance, Dave

    Code:
    MBTivo /var/hack #ll 
    total 307
    drwxr-xr-x   5 0        0            1024 Oct  9 02:27 .
    drwxr-xr-x  16 0        0            1024 Oct  9 02:41 ..
    drwxr-xr-x   2 0        0            1024 Oct  7 04:28 Saved_Apps
    drwxr-xr-x  16 0        0            1024 Sep 20 02:29 TivoWebPlus
    drwxr-xr-x   2 0        0            1024 Sep 20 02:29 etc
    -rwxr-xr-x   1 0        0             329 Oct  3 00:57 hacks.fil
    -rwxr-xr-x   1 0        0          199662 Oct  9 02:27 mfs_ftp_helper
    -rwxrwxr-x   1 0        0           67271 Oct  9 02:27 tyftpd.tcl
    MBTivo /var/hack #./tyftpd.tcl &
    [1] 515
    MBTivo /var/hack #bash: ./tyftpd.tcl: No such file or directory
    
    [1]+  Exit 127                ./tyftpd.tcl
    MBTivo /var/hack #./tyftpd.tcl -l -d &
    [1] 522
    MBTivo /var/hack #bash: ./tyftpd.tcl: No such file or directory
    
    [1]+  Exit 127                ./tyftpd.tcl -l -d

  10. #130
    Join Date
    Sep 2004
    Location
    STL
    Posts
    135

    Success

    I found something that may help others..... I know, it's not often.

    When using Filezilla in the Auto mode, file sizes were a little larger than the original. Trying again as Binary, the file sizes stayed the same. Now it seems to run fine. I started a session in Filezilla using port 3105 and saw the TMF etc. directories. File listings came up OK and the kill pid worked well for me also. I'll be trying movieloader next. Very kewl jkozee thanks!

    Code:
    bash-2.02# ./tyftpd.tcl -p 3105 -s -v &
    [1] 22143
    bash-2.02# 10/11/12 23:00:54 - tyFTPd version 1.8 Startup
    10/11/12 23:00:54 - Server Ready for Action
    
    bash-2.02# ps aux | grep tyftpd
    0        22143  5.5  6.3  43264  8072 ttyp0    S    23:00   0:01 /tvbin/tivosh ./tyftpd.tcl -p 3105 -s -v
    0        22144  0.0  6.3  43264  8072 ttyp0    S    23:00   0:00 /tvbin/tivosh ./tyftpd.tcl -p 3105 -s -v
    0        22146  0.0  6.3  43264  8072 ttyp0    S    23:00   0:00 /tvbin/tivosh ./tyftpd.tcl -p 3105 -s -v
    0        22147  0.0  6.3  43264  8072 ttyp0    S    23:00   0:00 /tvbin/tivosh ./tyftpd.tcl -p 3105 -s -v
    0        22152  0.0  0.4   2636   516 ttyp0    S+   23:01   0:00 grep tyftpd
    bash-2.02# kill 22143
    bash-2.02# ps aux | grep tyftpd
    0        22158  0.0  0.4   2636   516 ttyp0    S+   23:01   0:00 grep tyftpd
    Last edited by Dave20042004; 10-11-2012 at 07:19 PM. Reason: more explicit
    Activity on forum is light. Need hardware help? I can supply preprogrammed proms: $10: 9 sold so far, I can prom your board $75: 5 done so far: PM or Email if interested.

  11. #131
    Join Date
    Dec 2005
    Posts
    6

    Pixelated .ty+ and .tmf

    Hi. I installed tyftpd from post #1 onto my Hughes SD40 running 6.4a. I've hacked the Hughes with Superpatch and PTVUpgrade for 6.4a. Tyftpd seems to run OK but when I download a recorded program to .tmf or .ty+ and try to play it with vlc the video has pixelated areas in most of the scenes. It looks almost like some of the scenes are overlapping some of the others. It also appears that the audio drops out after the first minute or so (but I'm not entirely sure of that). My PC is running Linux-Mint version 12.0 and is up to date.

    Is the latest version of tyftpd in post #1 or is there some other link to use to download the latest and greatest?
    Is this a problem others are having with standard definition streams?

    I'd like to convert the .ty+ or .tmf files to mpeg or mp4.
    I've tried using tytompg gives the same pixelated scenes and no audio. I'm pretty sure I am using an old version of that.
    Is that the correct tool to use? If not can you point me to a better program for the conversion?

    I've also used TYTool 10R4 but it seems to get a lot of errors with the video downloads.

    Thanks,
    Chuck

  12. #132
    Join Date
    Oct 2004
    Posts
    306
    Quote Originally Posted by clandress View Post
    when I download a recorded program to .tmf or .ty+ and try to play it with vlc the video has pixelated areas in most of the scenes. It looks almost like some of the scenes are overlapping some of the others. It also appears that the audio drops out after the first minute or so (but I'm not entirely sure of that).
    VLC capability of playing .ty files correctly comes and goes with different versions. No versions, as far as I know, handle .tmf files correctly.

    Quote Originally Posted by clandress View Post
    Is this a problem others are having with standard definition streams?
    Not I or anybody I know.

    Quote Originally Posted by clandress View Post
    I'd like to convert the .ty+ or .tmf files to mpeg or mp4.
    I've tried using tytompg gives the same pixelated scenes and no audio. I'm pretty sure I am using an old version of that.
    Is that the correct tool to use?
    Yes. Early versions did not handle .tmf and I think I remember there used to be audio problems. Try a recent version. The consistency of your results through VLC and tytompg is difficult for me to understand and there may be some single underlying problem I'm not grasping. But on the surface it seems you may be getting different symptoms from different source problems (for example maybe trying to play .tmf files in VLC and remembering incorrectly that you ALSO got the same results with .ty files) and combining them in your mind into a single set of consistent symptoms.

    So I may be wrong but I don't think tyftpd is your problem. Try different versions of VLC (and don't try to play .tmf's) and tytompg. I use a Mac for this so can't help you with version numbers.

  13. #133
    Join Date
    Mar 2005
    Posts
    233
    Quote Originally Posted by DanT View Post
    Is there a version of mfs_ftp_helper available for the Series 1 DTiVos? My wife's mfs_ftp keeps crashing (was working fine for years) so I thought I'd give this a try. But IIRC, the Series 1 units are PPCs and not MIPS.
    Sorry, I don't have a PPC toolchain setup, nor a unit to test with. If you are able to complile it, or find someone who can, I will certainly include it in the disribution.

  14. #134
    Join Date
    Mar 2005
    Posts
    233
    Quote Originally Posted by tas3086 View Post
    Check line 244: (in proc ProcessCommands {client} )

    HELP {reply $client "502 Sorry, no help is available.}
    should it be:
    HELP {reply $client "502 Sorry, no help is available."}


    Thanks for a great program.
    Yes, of course. Thanks for the feedback. I have updated the latest release with your patch.

  15. #135
    Join Date
    Dec 2006
    Posts
    55
    Quote Originally Posted by jkozee View Post
    Sorry, I don't have a PPC toolchain setup, nor a unit to test with. If you are able to complile it, or find someone who can, I will certainly include it in the disribution.
    Where can I get mfs_ftp_helper.c please? Unless I'm going blind I can't see it in the mfs-utils repository.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •