Results 1 to 3 of 3

Thread: 11.0n.K1 stopped but no recordings, can I upgrade using lrhorer's remotely?

  1. #1
    Join Date
    Oct 2011

    11.0n.K1 stopped but no recordings, can I upgrade using lrhorer's remotely?

    My Tivo just got the dreaded update on disk. For the first time in tivo ownership, it was blocked from installing (YES) by something I did last time, I think the no thanks patch if i remember correctly. So thats the good news.

    I have some questions on what is going on now though...I have a tuning adapter so that always causes problems but anyway for my understanding and to get how it all works, please help! As always, I try to document what I do so others can reference it also and report back what I find. I have a whole lot of questions so I will put them in one place and hope for answers. I look thru the forum extensively but am also trying to help others out so thanks for your help in advance and please correct any errors you see.

    First of all guide updates have been happening fine, but just recently it seems no matter what I do, I cannot get the tivo to schedule season pass recordings. I don't know if there is a separate problem or just if you can only have the new software so long even when it does not upgrade automatically as a method to force update or what. Here is what I have tried.

    Standard practice with Cox and my Tuning adapter is every 2 weeks or so I get an S03 error and the way I found to resolve that in the past was to wait until there were no recordings happening for quite awhile, unplug the tuning adapter for over 5 hours and then when it comes back online, it does or has done garbage collection and that clears the S03 problem and the guide updates afterwards and everything is fine.

    First as an aside
    I saw in a thread that

    This is a good solution, but I have this issue all the time, (Crappy TA's) so I use cron to schedule the "dbgc-mcp -fg-gc" command daily.
    I searched on that and it looks like it works for some and not for others. What exactly does that do, I am guessing it forces garbage collection and clears something, but wanted to know if it was safe to run anytime or only when its not recording or what? I would love not to have to unplug/replug my TA once every few weeks.

    Any info you could give me on this would be great.

    Now to the real deal

    Is the lack of applying the update causing the problem no season pass recording? I think some people have gone with older software for quite awhile, like years with older software without problems. I tried all the regular troubleshooting I could find, which in summary is this.

    There is a known problem with suggestions and season passes. You should be able to get your season passes working again by following these steps:
    Power cycle the TiVo - To do this unplug the TiVo, wait about 30 seconds and then plug the TiVo in again.

    Then try the following:

    Switch the priority of one season pass.

    Turn off suggestions, restart the TiVo and then change the priority of a season pass.

    Update any option within a season pass.

    I Did multiple derivations of that and still cannot get season passes to record. Guide date loads but season passes rebuild (looking for upcoming episodes etc) does not so only manual recordings or one times work.

    So is there any other trick or do I just have to update the software to return normal function?

    Assuming eventually I will have to update the software, even if there is some trick I am missing, how do I go about that using lrhorer's script or is that possible.

    I found this thread that talks about how to install the update via telnet and stop the reboot so you can do the rest, but the details they give are not for using the script.

    Also used some of the commands here to check everything...

    Which confirmed I had the upgrade waiting and such. I know I have to copy the new codes over and all that, just wondering if this is spelled out anywhere as I understand the beginning of the process, upgrading the software, but when we get into all the stuff the script does, I am not so great. I could always let it update and run the old fashioned way, but I like learning this stuff and documenting it.

    I will go thru the main thread on updating "live" but any help or links to where I need to be would be helpful.

    I did the bootpage -p /dev/hda and got root=/dev/hda4
    then verified software waiting...
    then did
    echo mls /SwSystem | tivosh
    and got
        Name                      Type        FsId      Date  Time   Size
        ----                      ----        ----      ----  ----   ----
        11.0n.H1-01-2-652         tyDb     7345917  09/14/16 13:42    916
        11.0n.K1-01-2-652         tyDb     7871698  02/07/17 20:23    892
    so it's ready. I understand how to run the upgrade and process it, but what I need to copy over to run the script and what to do next, I have to research. Any help would be great. I will update as I find what to do next...

  2. #2
    Join Date
    Oct 2011
    So digging thru I found part of lrhorer's upgrade protocol here:

    which looks like it does lots of what I want, I think I just have to run the kill initial install and stop boot process manually, upgrade and run this script?

    But where do I put the files? That is what I cannot find anywhere so far. Also, I have no other modifications to my tivo than the script has run in the past, so no cron folders and other stuff running.

    From reading further, I am stuck at this step.
    2) Extract replace_initrd.mips.tar.gz on your PC to get null-linuxrc.img.gz, replace_initrd.mips

    3) Ftp files from PC to /var/hack on Tivo (Required files: postinstall, hacks.fil, null-linuxrc.img.gz, replace_initrd.mips)
    where do I get the replace_initrd.mips to replace with. Since I already have the hacks on the tivo from prior hacks, should I just have to copy hacks.fil over and the script at the bottom of that page?
    Last edited by sanjonny; 02-10-2017 at 09:09 PM.

  3. #3
    Join Date
    Oct 2011
    I did the above procedure and was unable to get it to work. I believe I had a problem with transferring the postinstall file correctly as I could not get the tivo to recognize it, I changed permissions and such and tried several times via ./postinstall after either chmod 555 postinstall or chmod u+x and still could not get it to run. The good news is that I upgraded my prior work so if you want the easy way to pull the drive, I updated the zip file and it works great using lrhorer's wonderful script.

    I did update the file remotely following following spocko's directions

    I transferred all the files spocko stated to the /var/hack directory on my tivo and the update part went great, ran updated and exited leaving me to do the next part, but I could not get his postinstall script to run. If anyone has any insight into what I might have done wrong, that would be great. I would love to say we won't have to do this again, but just in case, I would like to get it to work on the tivo. I ended up just rebooting and pulling the drive using the process described in the link above. After all is done, season pass recordings started again fine.
    Last edited by sanjonny; 02-27-2017 at 09:39 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts